Bug Hunting Session
Bug 67660 - PDF export causes crash on OSX
Summary: PDF export causes crash on OSX
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Mac OS X (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0 target:4.1.2
Keywords: regression
: 68449 69523 69574 69793 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-02 09:45 UTC by peter
Modified: 2013-10-14 11:01 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash report on OSX (71.03 KB, text/plain)
2013-08-02 09:45 UTC, peter
Details
Source file causing crash (42.17 KB, application/vnd.oasis.opendocument.text)
2013-08-02 09:45 UTC, peter
Details
Original document created in 2009. (38.30 KB, application/vnd.oasis.opendocument.text)
2013-08-02 21:43 UTC, peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter 2013-08-02 09:45:29 UTC
Created attachment 83520 [details]
Crash report on OSX

I have a document that seems normal enough (it does have a couple of simple formula). When I try to export it as a pdf, libreoffice crashes. I've attached both the source document and crash report.
Comment 1 peter 2013-08-02 09:45:59 UTC
Created attachment 83521 [details]
Source file causing crash
Comment 2 peter 2013-08-02 09:46:44 UTC
I also downloaded the latest nightly (31/7) and it also crashed.
Comment 3 Jorendc 2013-08-02 10:09:47 UTC
Hi Peter,

Thanks for creating a separate bug for this :-).

I can confirm a crash using Mac OSX 10.8.4 with LibreOffice 4.1.0.4 and 
Version: 4.2.0.0.alpha0+ Build ID: 429148c5f10828c50ae41309942f4946b12a7df9
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-02_00:51:34

PS: Thanks for testing the latest version of LibreOffice too! Note my way to make clear which version I used (the Build-ID). You can see the build-ID by going to LibreOfficeDev > About LibreOfficeDev.

Kind regards,
Joren
Comment 4 peter 2013-08-02 10:20:45 UTC
Thanks for that Joren, my build-ID for the daily version was:

Version: 4.1.1.0.0+
Build ID: b3abb55edd5f6c3168882239df2b4b28dc96cfa

For the release version it is:
Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

I'm using Mac OSX 10.8.4
Comment 5 tommy27 2013-08-02 12:23:14 UTC
@peter
did you experience the same crash on previous 3.6.x or 4.0.x releases?
Comment 6 peter 2013-08-02 21:42:00 UTC
No - I created this document in 2009 and made a pdf of it then. Recently I opened it, fixed the formulae (something has changed since 2009 and they no longer displayed correctly), saved the document and exported it - then it crashed.

I still have a copy of the original file before I edited it - I've uploaded it in case that's useful too.
Comment 7 peter 2013-08-02 21:43:32 UTC
Created attachment 83555 [details]
Original document created in 2009.

This document displayed correctly in 2009 and was successfully exported as a pdf. Now exporting it crashes libreoffice.
Comment 8 Commit Notification 2013-08-06 10:25:48 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a321be22907c47e2e378c494f0de9f3f68af5167

fdo#67660: Fix memory mismanagement crash



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Don't use this account, use tml@iki.fi 2013-08-06 10:48:39 UTC
Argh, the bug I was fixing was bug #67416 , sorry, I put the wrong bug number in the commit message, but let's hope it has the same root cause as this one.
Comment 10 Don't use this account, use tml@iki.fi 2013-08-06 11:08:20 UTC
Yep, same crash as bug #67416 , so let's mark this as a duplicate.

*** This bug has been marked as a duplicate of bug 67416 ***
Comment 11 Commit Notification 2013-08-08 12:09:13 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=20b5932eb6f16b3674592977db56a29fb35ef6f7&h=libreoffice-4-1

fdo#67660: Fix memory mismanagement crash


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Emir Sarı (away) 2013-08-10 05:34:32 UTC
Still reproducible with Version: 4.2.0.0.alpha0+
Build ID: f30cde45db99d5c57e8be6956bbf824ab92328c2
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-09_00:35:4
Comment 13 Don't use this account, use tml@iki.fi 2013-08-10 07:49:05 UTC
Emir: I could not reproduce using exactly that daily build. How exactly did you do the PDF export? I just selected File>Export as PDF... from the menu, let all default settings be, clicked the Export button, clicked the Save button, clicked the Replace button when it asked if I wanted to replace an existing w2k_l1_overheads.pdf file. Worked fine.

Are you sure you ran the right LibreOfficeDev.app, the one from the daily build in question?
Comment 14 Emir Sarı (away) 2013-08-10 11:30:26 UTC
@Tor,

Tried once more after deleting the user profile using the same steps, worked fine. 

Closing as RESOLVED FIXED.
Comment 15 Tor Lillqvist 2013-08-26 07:28:19 UTC
*** Bug 68449 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2013-09-23 20:29:40 UTC
*** Bug 69523 has been marked as a duplicate of this bug. ***
Comment 17 Thomas van der Meulen 2013-09-25 15:22:30 UTC
*** Bug 69793 has been marked as a duplicate of this bug. ***
Comment 18 Maxim Monastirsky 2013-10-14 11:01:43 UTC
*** Bug 69574 has been marked as a duplicate of this bug. ***