Bug 68449 - LibreOffice CRASHES when Exporting PDF with Formulas that contain a Square root
Summary: LibreOffice CRASHES when Exporting PDF with Formulas that contain a Square root
Status: RESOLVED DUPLICATE of bug 67660
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2013-08-22 20:03 UTC by Vossman
Modified: 2013-09-17 11:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
empty ODT with sqrt formula (10.95 KB, application/vnd.oasis.opendocument.text)
2013-08-22 20:03 UTC, Vossman
Details
crash infos (69.43 KB, text/plain)
2013-08-23 21:11 UTC, Julien Nabet
Details
4.1.1rc2 PDF export crash log (71.17 KB, text/plain)
2013-08-25 19:36 UTC, Vossman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vossman 2013-08-22 20:03:56 UTC
Created attachment 84472 [details]
empty ODT with sqrt formula

Any time I have a document that contains a formula with a sqrt{} it crashes.

Steps to reproduce:
1. Open new Writer or Impress document
2. Insert... Object... Formula...
3. Create an equation with a sqrt{}
4. Click anywhere to close equation editor
5. File... Export as PDF...
6. Click "Export"
7. CRASH
Comment 1 Vossman 2013-08-22 20:08:07 UTC
Found this bug in LO 4.1.0 and downloaded LO 4.1.1rc2 and bug was still present. Do not remember having this bug on the 4.0 series...
Comment 2 Vossman 2013-08-23 00:52:42 UTC
Works fine in LO 4.0.5 release, so the problem exists between LO 4.0 and LO 4.1.
Comment 3 Julien Nabet 2013-08-23 04:20:33 UTC
On pc Debian x86-64 with master sources updated yesterday or with 4.1 sources updated 1 week ago, I don't reproduce the crash.

Vossman:
- did you install any LO specific extensions?
- could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?
If you still reproduce this, could you attach crash info? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX:_How_to_get_debug_information)
Comment 4 Vossman 2013-08-23 19:55:25 UTC
Can someone with a Mac test this? It may be platform specific.
Comment 5 Vossman 2013-08-23 20:13:52 UTC
I tested this on my wife's Mac OS X 10.6.8 and it also crashes. Clearing out my user space also did not work. I am running 10.8.4
Comment 6 Julien Nabet 2013-08-23 20:30:21 UTC
vossman: I'll give a try with my MacOs but meanwhile, could you attach crash info? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX:_How_to_get_debug_information)?
Comment 7 Julien Nabet 2013-08-23 20:58:53 UTC
On MacOs 10.7.5 with LO 4.0.4.2, no crash during export. I'm gonna upgrade LO and give it a new try.
Comment 8 Julien Nabet 2013-08-23 21:11:05 UTC
Created attachment 84539 [details]
crash infos

With 4.1.0.4, I reproduced the problem.
I attached the crash debug.
I used a brand new LO profile and didn't install any specific fonts.
Also, accessibility options are ones by default on Mac.
Comment 9 Julien Nabet 2013-08-23 21:11:29 UTC
So put it at NEW.
Comment 10 Julien Nabet 2013-08-24 13:04:28 UTC
I gave a try to the pre release 4.1.1 RC2, no crash. No crash too for daily building on master sources (future 4.2.0) http://dev-builds.libreoffice.org/daily/master/MacOSX-X86@43/current/

Vossman: could you give a try to the pre release and keep us informed?
Comment 11 Julien Nabet 2013-08-24 13:05:52 UTC
*** Bug 68225 has been marked as a duplicate of this bug. ***
Comment 12 Vossman 2013-08-24 23:35:03 UTC
I initially found the bug by downloading the just released 4.1.1rc2 from the "hidden" (un-advertized) pre-release folder, so 4.1.1rc2 fails for me.
Comment 13 Vossman 2013-08-25 00:19:50 UTC
Nightly build 4.2.0 alpha does NOT crash. I will re-download and double check 4.1.1rc2
Comment 14 Vossman 2013-08-25 00:25:49 UTC
4.1.1rc2 still CRASHES.
Comment 15 Vossman 2013-08-25 03:37:50 UTC
So, in summary, seems to happen on a Mac (not Ubuntu) and only on the 4.1 series. the 4.0 and 4.2 series seem to work fine.
Comment 16 Julien Nabet 2013-08-25 08:01:03 UTC
Vossman: about 4.1.1 RC2, did you also try with a brand new LO profile?
If yes, did the crash give the same info as my attachment (see https://bugs.freedesktop.org/attachment.cgi?id=84539)?
Comment 17 Vossman 2013-08-25 19:36:56 UTC
Created attachment 84616 [details]
4.1.1rc2 PDF export crash log

deleted profile and created new document
Comment 18 Tor Lillqvist 2013-08-26 07:28:19 UTC
Based on the backtrace this is very likely the same as bug #67660.

*** This bug has been marked as a duplicate of bug 67660 ***