Bug 66487 - Export PDF/A crashes LibreOffice
Summary: Export PDF/A crashes LibreOffice
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
(See in Summary)
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 48406 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-02 08:04 UTC by Leif Lodahl
Modified: 2013-08-03 16:32 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
chrash report (153.76 KB, text/plain)
2013-07-02 08:04 UTC, Leif Lodahl
Details
Document that chrashes LibreOffice (412.29 KB, application/vnd.oasis.opendocument.text)
2013-07-02 20:03 UTC, Leif Lodahl
Details
Crash report on OSX (67.61 KB, text/plain)
2013-08-02 03:09 UTC, peter
Details
Test document that crashes LibreOffice 4.1 on export to pdf. (42.17 KB, application/vnd.oasis.opendocument.text)
2013-08-02 03:14 UTC, peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Lodahl 2013-07-02 08:04:38 UTC
Created attachment 81848 [details]
chrash report

Exporting a text document to PDF with the PDF/A-1a option checked consequently chrashes LibreOffice.

To reproduce:
1) start a new text document
2) Write some plain text (or not)
3) Select File - Export to PDF...
4) Check "PDF/A-1a"
5) Export 
-> PDF is stored
6) Wait a few seconds
-> LibreOffice chrash

On one machine the crash happens a few seconds AFTER the PDF-document is actually created and stored correctly. On another machine no PDF-output is stored (chrash happens before save).

PS: Even with a plain document with no content the dialog warning about transparent objects occurs.

Exporting the same document as normal PDF (not PDF/A-1a) is succesfull.

Tried only with Linux so far.

Version: 4.1.0.1.0+
Build ID: a1239f7a1a8aac82c3599fbdfe826cb67baae9c
TinderBox: Linux-x86_64@31-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-06-27_18:33:02
Comment 1 Cor Nouws 2013-07-02 08:40:18 UTC
Hi Lief,
With 4.1.0rc1 on Ubuntu 32 Bits, I do not have that crash.
Comment 2 Julien Nabet 2013-07-02 19:45:30 UTC
Leif: I haven't given a try yet but following to the Cor's test, could you attach your file so we can try to reproduce this?
Comment 3 Leif Lodahl 2013-07-02 20:03:07 UTC
Created attachment 81909 [details]
Document that chrashes LibreOffice

This document doesn't crash 4.1.0 RC1 but does crash while using daily build.

Please note that the document contains a rather large SVG image on the last page. Without PDF/A-1a everything works fine.

Version:
Version: 4.1.0.1.0+
Build ID: 1d405e396361d2a01b29e97ed9f8f0199614fef
TinderBox: Linux-x86@34-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-06-27_21:54:09


May I suggest that we leave it open as NEEDINFO for a few days. If nobody can reproduce the problem then I will close it.
Comment 4 Julien Nabet 2013-07-02 20:25:37 UTC
On pc Debian x86-64 with master sources udpated today, I don't reproduce the crash but had 2 warnings:
- PDF/A forbids transparency. A transparent object was painted opaque instead.
- some objects were converted to an image in order to remove transparencies, ...

Anyway, if you want other people give it a try, I put it back to Unconfirmed
Comment 5 Cor Nouws 2013-07-02 22:18:33 UTC
(In reply to comment #3)

> Please note that the document contains a rather large SVG image on the last
> page. Without PDF/A-1a everything works fine.

So could you try if the document > PDF-A also crashes when the image is removed :)
Comment 6 Maxi Schimmel 2013-07-04 17:21:09 UTC
Here, with Versión: 4.1.0.1, Compilation Id.: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155, I can confirm the bug.

I opens Writer, fills the page with few words, exports as PDF checking the "PDF/A" box, the PDF was created but LO crashes.

How I can get traces for help you guys?

My machine: Windows Server 2008R2 SP1
Comment 7 Julien Nabet 2013-07-04 19:18:30 UTC
(In reply to comment #6)
> ...
> How I can get traces for help you guys?
You can follow this link: https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Windows
Comment 8 tommy27 2013-07-05 05:19:23 UTC
no crash with test file using LibO 4.0.4.2 on Win7 Pro 64bit
Comment 9 Jorendc 2013-07-05 07:53:08 UTC
Also not reproducible using Mac OSX 10.8.4 with LibreOffice 4.1.0.2 RC.
It freeze for a couple of seconds when I hit the export dialog, but then I received the same warnings as Julien en Comment 4:

(In reply to comment #4)
> 2 warnings:
> - PDF/A forbids transparency. A transparent object was painted opaque
> instead.
> - some objects were converted to an image in order to remove transparencies,
> ...

Kind regards,
Joren
Comment 10 tommy27 2013-07-05 11:06:16 UTC
I receive the "transparency warning" too but I don't think it's a bug...
it looks like a generic warning about the A-PDF conversion of some graphical elements.

the bug report is about a crash during conversion which I do not experience
Comment 11 Ydier 2013-07-12 07:25:02 UTC
I have the same problem with the file attached with windows 8 -64 bits
Comment 12 tommy27 2013-07-12 09:01:29 UTC
@Ydier
which problem do you refer? the crash or the warning?
Comment 13 peter 2013-08-02 03:09:59 UTC
Created attachment 83495 [details]
Crash report on OSX
Comment 14 peter 2013-08-02 03:12:27 UTC
I've attached "Crash report on OSX" above which appears whenever I try to export my document in OSX. I'll upload the document causing the trouble also. Note that it doesn't matter if I have the "PDF/A-1a" setting checked or not, it still crashes.
Comment 15 peter 2013-08-02 03:14:39 UTC
Created attachment 83496 [details]
Test document that crashes LibreOffice 4.1 on export to pdf.

This document can't be exported to PDF on my computer (OSX) without crashes LibreOffice 4.1.
Comment 16 tommy27 2013-08-02 04:53:50 UTC
@peter

no crash at all with last test file and LibO 4.0.4 and 4.1.0 on Win7 64bit.
pdf export works well, I just receive the transparency warning if pdf1a is checked
Comment 17 peter 2013-08-02 09:49:47 UTC
That(In reply to comment #16)
> @peter
> 
> no crash at all with last test file and LibO 4.0.4 and 4.1.0 on Win7 64bit.
> pdf export works well, I just receive the transparency warning if pdf1a is
> checked

That's great - I realised too that I've posted this on a linux bug report. As such I've made a new bug listing the OS as OSX. Thanks for taking the time to look at it.

OSX Bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=67660
Comment 18 tommy27 2013-08-02 12:20:30 UTC
ok peter.

is there any Linux user who can confirm the original PDF/A-1a export crash report with final 4.1.0.4 release?

as said before there's no crash on Windows.
Comment 19 Julien Nabet 2013-08-03 14:23:14 UTC
On pc Debian x86-64 with 4.1 sources updated yesterday + a brand new LO profile, I don't reproduce the crash.
However I got PDF/A forbids transparency. A transparent object was painted opaque instead.
Comment 20 tommy27 2013-08-03 16:25:49 UTC
*** Bug 48406 has been marked as a duplicate of this bug. ***
Comment 21 tommy27 2013-08-03 16:32:59 UTC
it seems that the original crash reported in early 4.1.0 builds doesn't happen anymore (many Linux users do not reproduce it), so I'm gonna set the status to RESOLVED WORKSFORME since we don't know what effectively fixed it.

regarding the "transparency warning" a dedicated bug report has bbe filed at Bug 65439