Bug 69574 - Crash on PDF Export
Summary: Crash on PDF Export
Status: RESOLVED DUPLICATE of bug 67660
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-19 12:52 UTC by Marcus Hudritsch
Modified: 2013-10-14 11:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODP that crashes in OSX during PDF export (1.28 MB, application/vnd.oasis.opendocument.presentation)
2013-09-25 06:12 UTC, Marcus Hudritsch
Details
The crash is created by the last formula in the document (1.57 MB, application/vnd.oasis.opendocument.text)
2013-09-25 07:00 UTC, Marcus Hudritsch
Details
Formula removed: No crash (1.56 MB, application/vnd.oasis.opendocument.text)
2013-09-25 07:01 UTC, Marcus Hudritsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Hudritsch 2013-09-19 12:52:53 UTC
Total crash on PDF export on Mac OSX 10.8.5.

Process:         soffice [8283]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         4.1.1.2 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [226]
User ID:         501

Date/Time:       2013-09-19 14:51:02.663 +0200
OS Version:      Mac OS X 10.8.5 (12F37)
Report Version:  10

Interval Since Last Report:          210612 sec
Crashes Since Last Report:           4
Per-App Crashes Since Last Report:   3
Anonymous UUID:                      663C3B41-0758-9A3A-1E72-454CDF99CF07

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000ffffffff

VM Regions Near 0xffffffff:
--> shared memory          00000000ffffb000-00000000ffffc000 [    4K] r-x/r-x SM=SHM  
    

Application Specific Information:
objc_msgSend() selector name: release


Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	0x983a6a8b objc_msgSend + 27
1   com.apple.CoreFoundation      	0x99bc531b CFRelease + 171
2   libvcllo.dylib                	0x01a57162 CTTextStyle::~CTTextStyle() + 50
3   libvcllo.dylib                	0x01a5a2cd AquaSalGraphics::SetFont(FontSelectPattern*, int) + 29
4   libvcllo.dylib                	0x0189c643 OutputDevice::ImplInitFont() const + 147
5   libvcllo.dylib                	0x018aab61 OutputDevice::ImplLayout(rtl::OUString const&, long, long, Point const&, long, long const*, bool) const + 705
6   libvcllo.dylib                	0x0191ac32 vcl::PDFWriterImpl::drawStretchText(Point const&, unsigned long, String const&, unsigned short, unsigned short, bool) + 114
7   libvcllo.dylib                	0x018eca40 vcl::PDFWriter::DrawStretchText(Point const&, unsigned long, String const&, unsigned short, unsigned short) + 64
8   libvcllo.dylib                	0x018f1e0d vcl::PDFWriterImpl::playMetafile(GDIMetaFile const&, vcl::PDFExtOutDevData*, vcl::PDFWriter::PlayMetafileContext const&, VirtualDevice*) + 4989
9   libvcllo.dylib                	0x018ebf20 vcl::PDFWriter::PlayMetafile(GDIMetaFile const&, vcl::PDFWriter::PlayMetafileContext const&, vcl::PDFExtOutDevData*) + 48
10  libpdffilterlo.dylib          	0x3fea8d65 PDFExport::ImplExportPage(vcl::PDFWriter&, vcl::PDFExtOutDevData&, GDIMetaFile const&) + 565
11  libpdffilterlo.dylib          	0x3feab21c PDFExport::ExportSelection(vcl::PDFWriter&, com::sun::star::uno::Reference<com::sun::star::view::XRenderable>&, com::sun::star::uno::Any const&, StringRangeEnumerator const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, long) + 3356
12  libpdffilterlo.dylib          	0x3feadfb0 PDFExport::Export(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 10192
13  libpdffilterlo.dylib          	0x3feb9035 PDFFilter::implExport(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 4693
14  libpdffilterlo.dylib          	0x3feb9917 PDFFilter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 87
15  libsfxlo.dylib                	0x0070876a SfxObjectShell::ExportTo(SfxMedium&) + 3674
16  libsfxlo.dylib                	0x0070f792 SfxObjectShell::SaveTo_Impl(SfxMedium&, SfxItemSet const*) + 6962
17  libsfxlo.dylib                	0x00712ad7 SfxObjectShell::PreDoSaveAs_Impl(String const&, String const&, SfxItemSet*) + 935
18  libsfxlo.dylib                	0x007134f2 SfxObjectShell::CommonSaveAs_Impl(INetURLObject const&, String const&, SfxItemSet*) + 2082
19  libsfxlo.dylib                	0x006fb2f3 SfxObjectShell::APISaveAs_Impl(String const&, SfxItemSet*) + 531
20  libsfxlo.dylib                	0x0073f2ca SfxBaseModel::impl_store(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, unsigned char) + 2042
21  libsfxlo.dylib                	0x00749ab6 SfxBaseModel::storeToURL(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 278
22  libsfxlo.dylib                	0x006dea11 SfxStoringHelper::GUIStoreModel(com::sun::star::uno::Reference<com::sun::star::frame::XModel>, rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, unsigned char, rtl::OUString, unsigned short) + 4065
23  libsfxlo.dylib                	0x006fcb49 SfxObjectShell::ExecFile_Impl(SfxRequest&) + 5369
24  libsfxlo.dylib                	0x0082c3a8 SfxDispatcher::Call_Impl(SfxShell&, SfxSlot const&, SfxRequest&, unsigned char) + 360
25  libsfxlo.dylib                	0x00595183 SfxBindings::Execute_Impl(SfxRequest&, SfxSlot const*, SfxShell*) + 99
26  libsfxlo.dylib                	0x005cc5b5 SfxDispatchController_Impl::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, com::sun::star::uno::Reference<com::sun::star::frame::XDispatchResultListener> const&) + 4021
27  libsfxlo.dylib                	0x005cd635 SfxOfficeDispatch::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 341
28  libfwklo.dylib                	0x0f39f06c framework::MenuBarManager::Select(Menu*) + 668
29  libvcllo.dylib                	0x019e2202 Menu::Select() + 98
30  libvcllo.dylib                	0x019dd238 Menu::ImplCallSelect(void*) + 24
31  libvcllo.dylib                	0x01a55acd ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 6333
32  libvcllo.dylib                	0x01a629d8 AquaSalInstance::Yield(bool, bool) + 312
33  libvcllo.dylib                	0x01723d94 Application::Yield(bool) + 84
34  libvcllo.dylib                	0x01723e4c Application::Execute() + 60
35  libsofficeapp.dylib           	0x0006f29a desktop::Desktop::Main() + 7642
36  libvcllo.dylib                	0x0172a1f2 ImplSVMain() + 226
37  libvcllo.dylib                	0x01a61a21 AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 129
38  libvcllo.dylib                	0x01a9dcfb -[VCL_NSApplication sendEvent:] + 315
39  com.apple.AppKit              	0x9016062c -[NSApplication run] + 951
40  com.apple.AppKit              	0x901035f6 NSApplicationMain + 1053
41  libvcllo.dylib                	0x01a622e7 ImplSVMainHook(int*) + 343
42  libvcllo.dylib                	0x0172a22a SVMain() + 26
43  libsofficeapp.dylib           	0x0009d765 soffice_main + 325
44  org.libreoffice.script        	0x00001f4e main + 30
45  org.libreoffice.script        	0x00001f25 start + 53


It works under Windows 7 (same version of LO)
It crashes since 4.1. 4.0 worked fine.
See the attached odt file.
Sorry for the size.
Tanks for any help.
Marcus 

              
Operating System: Mac OS X
Version: 4.1.1.2 release
Comment 1 tommy27 2013-09-25 03:24:33 UTC
there's no attached test file. please upload it.
Comment 2 Marcus Hudritsch 2013-09-25 06:12:17 UTC
Created attachment 86502 [details]
ODP that crashes in OSX during PDF export

Process:         soffice [762]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         4.1.1.2 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [224]
User ID:         501

Date/Time:       2013-09-25 08:11:20.142 +0200
OS Version:      Mac OS X 10.8.5 (12F37)
Report Version:  10

Interval Since Last Report:          443304 sec
Crashes Since Last Report:           7
Per-App Crashes Since Last Report:   6
Anonymous UUID:                      663C3B41-0758-9A3A-1E72-454CDF99CF07

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000028

VM Regions Near 0x28:
--> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/LibreOffice.app/Contents/MacOS/soffice
    __TEXT                 0000000000001000-0000000000002000 [    4K] r-x/rwx SM=COW  /Applications/LibreOffice.app/Contents/MacOS/soffice

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.CoreFoundation      	0x99bc5390 CFRelease + 288
1   libvcllo.dylib                	0x01a57162 CTTextStyle::~CTTextStyle() + 50
2   libvcllo.dylib                	0x01a5a2cd AquaSalGraphics::SetFont(FontSelectPattern*, int) + 29
3   libvcllo.dylib                	0x0189c643 OutputDevice::ImplInitFont() const + 147
4   libvcllo.dylib                	0x018aab61 OutputDevice::ImplLayout(rtl::OUString const&, long, long, Point const&, long, long const*, bool) const + 705
5   libvcllo.dylib                	0x0191ad02 vcl::PDFWriterImpl::drawTextArray(Point const&, String const&, long const*, unsigned short, unsigned short, bool) + 114
6   libvcllo.dylib                	0x018eca90 vcl::PDFWriter::DrawTextArray(Point const&, String const&, long const*, unsigned short, unsigned short) + 64
7   libvcllo.dylib                	0x018f1e8c vcl::PDFWriterImpl::playMetafile(GDIMetaFile const&, vcl::PDFExtOutDevData*, vcl::PDFWriter::PlayMetafileContext const&, VirtualDevice*) + 5116
8   libvcllo.dylib                	0x018ebf20 vcl::PDFWriter::PlayMetafile(GDIMetaFile const&, vcl::PDFWriter::PlayMetafileContext const&, vcl::PDFExtOutDevData*) + 48
9   libpdffilterlo.dylib          	0x1dc30d65 PDFExport::ImplExportPage(vcl::PDFWriter&, vcl::PDFExtOutDevData&, GDIMetaFile const&) + 565
10  libpdffilterlo.dylib          	0x1dc3321c PDFExport::ExportSelection(vcl::PDFWriter&, com::sun::star::uno::Reference<com::sun::star::view::XRenderable>&, com::sun::star::uno::Any const&, StringRangeEnumerator const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, long) + 3356
11  libpdffilterlo.dylib          	0x1dc35fb0 PDFExport::Export(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 10192
12  libpdffilterlo.dylib          	0x1dc41035 PDFFilter::implExport(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 4693
13  libpdffilterlo.dylib          	0x1dc41917 PDFFilter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 87
14  libsfxlo.dylib                	0x0070876a SfxObjectShell::ExportTo(SfxMedium&) + 3674
15  libsfxlo.dylib                	0x0070f792 SfxObjectShell::SaveTo_Impl(SfxMedium&, SfxItemSet const*) + 6962
16  libsfxlo.dylib                	0x00712ad7 SfxObjectShell::PreDoSaveAs_Impl(String const&, String const&, SfxItemSet*) + 935
17  libsfxlo.dylib                	0x007134f2 SfxObjectShell::CommonSaveAs_Impl(INetURLObject const&, String const&, SfxItemSet*) + 2082
18  libsfxlo.dylib                	0x006fb2f3 SfxObjectShell::APISaveAs_Impl(String const&, SfxItemSet*) + 531
19  libsfxlo.dylib                	0x0073f2ca SfxBaseModel::impl_store(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, unsigned char) + 2042
20  libsfxlo.dylib                	0x00749ab6 SfxBaseModel::storeToURL(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 278
21  libsfxlo.dylib                	0x006dea11 SfxStoringHelper::GUIStoreModel(com::sun::star::uno::Reference<com::sun::star::frame::XModel>, rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, unsigned char, rtl::OUString, unsigned short) + 4065
22  libsfxlo.dylib                	0x006fcb49 SfxObjectShell::ExecFile_Impl(SfxRequest&) + 5369
23  libsfxlo.dylib                	0x0082c3a8 SfxDispatcher::Call_Impl(SfxShell&, SfxSlot const&, SfxRequest&, unsigned char) + 360
24  libsfxlo.dylib                	0x00595183 SfxBindings::Execute_Impl(SfxRequest&, SfxSlot const*, SfxShell*) + 99
25  libsfxlo.dylib                	0x005cc5b5 SfxDispatchController_Impl::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, com::sun::star::uno::Reference<com::sun::star::frame::XDispatchResultListener> const&) + 4021
26  libsfxlo.dylib                	0x005cd635 SfxOfficeDispatch::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 341
27  libfwklo.dylib                	0x0ef0106c framework::MenuBarManager::Select(Menu*) + 668
28  libvcllo.dylib                	0x019e2202 Menu::Select() + 98
29  libvcllo.dylib                	0x019dd238 Menu::ImplCallSelect(void*) + 24
30  libvcllo.dylib                	0x01a55acd ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 6333
31  libvcllo.dylib                	0x01a629d8 AquaSalInstance::Yield(bool, bool) + 312
32  libvcllo.dylib                	0x01723d94 Application::Yield(bool) + 84
33  libvcllo.dylib                	0x01723e4c Application::Execute() + 60
34  libsofficeapp.dylib           	0x0006f29a desktop::Desktop::Main() + 7642
35  libvcllo.dylib                	0x0172a1f2 ImplSVMain() + 226
36  libvcllo.dylib                	0x01a61a21 AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 129
37  libvcllo.dylib                	0x01a9dcfb -[VCL_NSApplication sendEvent:] + 315
38  com.apple.AppKit              	0x9016062c -[NSApplication run] + 951
39  com.apple.AppKit              	0x901035f6 NSApplicationMain + 1053
40  libvcllo.dylib                	0x01a622e7 ImplSVMainHook(int*) + 343
41  libvcllo.dylib                	0x0172a22a SVMain() + 26
42  libsofficeapp.dylib           	0x0009d765 soffice_main + 325
43  org.libreoffice.script        	0x00001f4e main + 30
44  org.libreoffice.script        	0x00001f25 start + 53
Comment 3 Marcus Hudritsch 2013-09-25 07:00:31 UTC
Created attachment 86515 [details]
The crash is created by the last formula in the document

Process:         soffice [2121]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         4.1.1.2 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [224]
User ID:         501

Date/Time:       2013-09-25 08:58:52.317 +0200
OS Version:      Mac OS X 10.8.5 (12F37)
Report Version:  10

Interval Since Last Report:          446156 sec
Crashes Since Last Report:           29
Per-App Crashes Since Last Report:   28
Anonymous UUID:                      663C3B41-0758-9A3A-1E72-454CDF99CF07

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000028

VM Regions Near 0x28:
--> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/LibreOffice.app/Contents/MacOS/soffice
    __TEXT                 0000000000001000-0000000000002000 [    4K] r-x/rwx SM=COW  /Applications/LibreOffice.app/Contents/MacOS/soffice

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.CoreFoundation      	0x99bc5390 CFRelease + 288
1   libvcllo.dylib                	0x01a57162 CTTextStyle::~CTTextStyle() + 50
2   libvcllo.dylib                	0x01a5a2cd AquaSalGraphics::SetFont(FontSelectPattern*, int) + 29
3   libvcllo.dylib                	0x0189c643 OutputDevice::ImplInitFont() const + 147
4   libvcllo.dylib                	0x018aab61 OutputDevice::ImplLayout(rtl::OUString const&, long, long, Point const&, long, long const*, bool) const + 705
5   libvcllo.dylib                	0x0191ac32 vcl::PDFWriterImpl::drawStretchText(Point const&, unsigned long, String const&, unsigned short, unsigned short, bool) + 114
6   libvcllo.dylib                	0x018eca40 vcl::PDFWriter::DrawStretchText(Point const&, unsigned long, String const&, unsigned short, unsigned short) + 64
7   libvcllo.dylib                	0x018f1e0d vcl::PDFWriterImpl::playMetafile(GDIMetaFile const&, vcl::PDFExtOutDevData*, vcl::PDFWriter::PlayMetafileContext const&, VirtualDevice*) + 4989
8   libvcllo.dylib                	0x018ebf20 vcl::PDFWriter::PlayMetafile(GDIMetaFile const&, vcl::PDFWriter::PlayMetafileContext const&, vcl::PDFExtOutDevData*) + 48
9   libpdffilterlo.dylib          	0x1b2d8d65 PDFExport::ImplExportPage(vcl::PDFWriter&, vcl::PDFExtOutDevData&, GDIMetaFile const&) + 565
10  libpdffilterlo.dylib          	0x1b2db21c PDFExport::ExportSelection(vcl::PDFWriter&, com::sun::star::uno::Reference<com::sun::star::view::XRenderable>&, com::sun::star::uno::Any const&, StringRangeEnumerator const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, long) + 3356
11  libpdffilterlo.dylib          	0x1b2ddfb0 PDFExport::Export(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 10192
12  libpdffilterlo.dylib          	0x1b2e9035 PDFFilter::implExport(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 4693
13  libpdffilterlo.dylib          	0x1b2e9917 PDFFilter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 87
14  libsfxlo.dylib                	0x0070876a SfxObjectShell::ExportTo(SfxMedium&) + 3674
15  libsfxlo.dylib                	0x0070f792 SfxObjectShell::SaveTo_Impl(SfxMedium&, SfxItemSet const*) + 6962
16  libsfxlo.dylib                	0x00712ad7 SfxObjectShell::PreDoSaveAs_Impl(String const&, String const&, SfxItemSet*) + 935
17  libsfxlo.dylib                	0x007134f2 SfxObjectShell::CommonSaveAs_Impl(INetURLObject const&, String const&, SfxItemSet*) + 2082
18  libsfxlo.dylib                	0x006fb2f3 SfxObjectShell::APISaveAs_Impl(String const&, SfxItemSet*) + 531
19  libsfxlo.dylib                	0x0073f2ca SfxBaseModel::impl_store(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, unsigned char) + 2042
20  libsfxlo.dylib                	0x00749ab6 SfxBaseModel::storeToURL(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 278
21  libsfxlo.dylib                	0x006dea11 SfxStoringHelper::GUIStoreModel(com::sun::star::uno::Reference<com::sun::star::frame::XModel>, rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, unsigned char, rtl::OUString, unsigned short) + 4065
22  libsfxlo.dylib                	0x006fcb49 SfxObjectShell::ExecFile_Impl(SfxRequest&) + 5369
23  libsfxlo.dylib                	0x0082c3a8 SfxDispatcher::Call_Impl(SfxShell&, SfxSlot const&, SfxRequest&, unsigned char) + 360
24  libsfxlo.dylib                	0x00595183 SfxBindings::Execute_Impl(SfxRequest&, SfxSlot const*, SfxShell*) + 99
25  libsfxlo.dylib                	0x005cc5b5 SfxDispatchController_Impl::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, com::sun::star::uno::Reference<com::sun::star::frame::XDispatchResultListener> const&) + 4021
26  libsfxlo.dylib                	0x005cd635 SfxOfficeDispatch::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 341
27  libfwklo.dylib                	0x0f60106c framework::MenuBarManager::Select(Menu*) + 668
28  libvcllo.dylib                	0x019e2202 Menu::Select() + 98
29  libvcllo.dylib                	0x019dd238 Menu::ImplCallSelect(void*) + 24
30  libvcllo.dylib                	0x01a55acd ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 6333
31  libvcllo.dylib                	0x01a629d8 AquaSalInstance::Yield(bool, bool) + 312
32  libvcllo.dylib                	0x01723d94 Application::Yield(bool) + 84
33  libvcllo.dylib                	0x01723e4c Application::Execute() + 60
34  libsofficeapp.dylib           	0x0006f29a desktop::Desktop::Main() + 7642
35  libvcllo.dylib                	0x0172a1f2 ImplSVMain() + 226
36  libvcllo.dylib                	0x01a61a21 AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 129
37  libvcllo.dylib                	0x01a9dcfb -[VCL_NSApplication sendEvent:] + 315
38  com.apple.AppKit              	0x9016062c -[NSApplication run] + 951
39  com.apple.AppKit              	0x901035f6 NSApplicationMain + 1053
40  libvcllo.dylib                	0x01a622e7 ImplSVMainHook(int*) + 343
41  libvcllo.dylib                	0x0172a22a SVMain() + 26
42  libsofficeapp.dylib           	0x0009d765 soffice_main + 325
43  org.libreoffice.script        	0x00001f4e main + 30
44  org.libreoffice.script        	0x00001f25 start + 53
Comment 4 Marcus Hudritsch 2013-09-25 07:01:11 UTC
Created attachment 86516 [details]
Formula removed: No crash
Comment 5 Marcus Hudritsch 2013-09-25 07:09:25 UTC
Hi, after 1 hour of binary searching I found out that it is the first square root in a formula that crashed the PDF export.
Regards
Marcus
Comment 6 tommy27 2013-09-30 00:35:40 UTC
no crash with 4.1.1.2 under Win7 64bit.
maybe a Mac specific bug.
Comment 7 Marcus Hudritsch 2013-09-30 12:32:47 UTC
Yes. The bug is only on Mac OSX.
Comment 8 Maxim Monastirsky 2013-10-14 11:01:43 UTC

*** This bug has been marked as a duplicate of bug 67660 ***