Bug Hunting Session
Bug 67697 - Autocorrect entries with formatting cannot be added
Summary: Autocorrect entries with formatting cannot be added
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.3 target:4.0.6
Keywords:
: 64699 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-03 06:16 UTC by MAMOHT
Modified: 2013-09-19 19:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MAMOHT 2013-08-03 06:16:23 UTC
Здравствуйте.
ВНИМАНИЕ!!!
В версиях LibreOffice от 4.0.0 до 4.1.0 в Текстовом процессоре в опции "Параметры автозамены" в поле заменяемого текста невозможно сохранить форматированный текст. Даже при снятой галочке "Только текст" - она (эта галочка) автоматически устанавливается при выходе. Таким образом, к примеру,  вместо переводов каретки и знаков табуляции между словами в поле заменяемого текста и соответственно в самом документе при вводе, отображаются пробелы. Кроме того, в версии 4.1.0 текст автозамены можно внести в поля (и то, неформатированного текста) только загрузив LibreOffice под "sudo".
Вот такие вот пироги...
Кто осмелится возразить и подсказать, как решить эту проблему? Улыбка
Расчитываю на дельные советы, а не на бестолковое словоблудие!!!
Comment 1 MAMOHT 2013-08-03 06:18:53 UTC
Здравствуйте.
ВНИМАНИЕ!!!
В версиях LibreOffice от 4.0.0 до 4.1.0 в Текстовом процессоре в опции "Параметры автозамены" в поле заменяемого текста невозможно сохранить форматированный текст. Даже при снятой галочке "Только текст" - она (эта галочка) автоматически устанавливается при выходе. Таким образом, к примеру,  вместо переводов каретки и знаков табуляции между словами в поле заменяемого текста и соответственно в самом документе при вводе, отображаются пробелы. Кроме того, в версии 4.1.0 текст автозамены можно внести в поля (и то, неформатированного текста) только загрузив LibreOffice под "sudo".
Вот такие вот пироги...
Кто осмелится возразить и подсказать, как решить эту проблему? Улыбка
Расчитываю на дельные советы, а не на бестолковое словоблудие!!
Comment 2 Mike Kaganski 2013-08-03 13:18:09 UTC
You should use English when submitting an issue to Bugzilla. Most developers here don't read Russian, so your report is unreadable, and indicates that you ignored the rules of the service that you use. It is impolite at best.

If  you need an advice from fellow users, and not attention of developers, then you should post your message to a Russian users community.

Otherwise, please rename the issue to English, and post your description translated, too.

Also, please provide step-by-step instructions to reproduce the problem, the expected result and the actual result. This will enable people to reproduce the bug.

Please don't regard this as "бестолковое словоблудие", this is meant to allow this report to reach correct people.
Comment 3 Urmas 2013-08-04 05:11:46 UTC
It is indeed impossible to create a formatted autocorrect entry with recent LibreOffice.
Comment 4 Mike Kaganski 2013-08-04 06:26:53 UTC
Actually, the original poster referred to another problem: he could not use tabs and newline symbols in autocorrection field, they turn to spaces. This is not the same as "formatting", thus the initial report mixed these two different concepts (some kinds of text (tabs and multiline text) are impossible to use in autocorrect / no formatting support in autocorrect). Another was that on some system, he was unable to use autocorrection under ordinary user, he had to take superuser privileges.

There were no mention of real formatting in the original post, thus the name of the report was simply misleading. And the confirmation of the report written in Russian doesn't help developers who potentially will take this bug to comprehend what has been asked.
Comment 5 Urmas 2013-08-04 10:23:54 UTC
Autocorrect has 2 modes: text and rich text. Rich (i.e. formatted) text cannot be created, which is a bug.
Comment 6 Mike Kaganski 2013-09-14 01:35:52 UTC
The inability to save a Rich Text autocorrect entry (both formatting and special characters like newlines and tabs) is discussed in Bug 64699.

The inability to add a new autocorrect entry is fixed in Bug 67743.

*** This bug has been marked as a duplicate of bug 64699 ***
Comment 7 Commit Notification 2013-09-16 14:16:36 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=95e566b9a0df06d130e118181058273f034bcf2c

Resolves: fdo#67697 source formatting option list in autocorrect



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-09-17 07:37:56 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8af5a2b08dd8fa319ae02d9947f0906ecb1a4805&h=libreoffice-4-1

Resolves: fdo#67697 source formatting option list in autocorrect


It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2013-09-19 10:41:23 UTC
*** Bug 64699 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2013-09-19 19:33:13 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=feb79618508ce7888ae684dcd4501124579eeac2&h=libreoffice-4-0

Resolves: fdo#67697 source formatting option list in autocorrect


It will be available in LibreOffice 4.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.