Download it now!
Bug 67765 - Other: Can't Save New Autocorrect Entries
Summary: Other: Can't Save New Autocorrect Entries
Status: RESOLVED DUPLICATE of bug 67743
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-08-05 04:08 UTC by Kelton Newman
Modified: 2013-08-06 07:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kelton Newman 2013-08-05 04:08:07 UTC
Problem description:
Autocorrect will not save new entries.

Steps to reproduce:
1. Click: Tools
2. Click: Autocorrect Options
3. In the Replace box, type: ---
4. In the With box, type: —
5. Click: New
6. Click: OK

Current behavior:
Upon checking whether the newly added autocorrect option has been saved, it has not.  Regardless what character(s) you type in the Replace box, the desired character in the With box (which, FYI, is entity U2014 [I took the trouble to look it up in the LibreOffice "Special Character" tool])

Expected behavior:
The characters (whether ---- or ==== or -=-= or =-=- or --- or ===) should be autoreplaced with U2014 (—)


              
Operating System: Linux (Other)
Version: 4.1.0.3 rc
Last worked in: 3.5 all versions
Comment 1 Emir Sarı 2013-08-05 05:50:29 UTC
Cannot reproduce with ersion: 4.2.0.0.alpha0+
Build ID: aa5683e18de07c9e86325595ead4574efa685c3a
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-04_00:00:19

Should be a Linux specific bug.
Comment 2 Mike Kaganski 2013-08-05 08:20:11 UTC
I cannot test it, as I have no Linux. But another bug report indicated the same issue (Bug 67697, it's description is in Russian). The reporter of the mentioned bug could workaround this by using sudo.
Comment 3 m.a.riosv 2013-08-05 19:28:38 UTC

*** This bug has been marked as a duplicate of bug 67743 ***
Comment 4 Kelton Newman 2013-08-06 02:54:03 UTC
Not only does this glitch occur on the PCLinuxOS-blended version of LibreOffice,
but when I used Synaptic to uninstall the PCLinuxOS-blended version of LibreOffice,
deleted my /home/myprofilename/.config/libreoffice directory and installed
LibreOffice 4.0.1.4, Build Version 89ea49ddacd9aa532507cbf852f2bb22b1ace28,
I reproduced the problem: Cannot Save New Autocorrect Entries


I'll add an entry.  The moment I click OK and then reopen the Autocorrect entry-edit
dialog box, the new entry is gone.

I'm using PCLinuxOS 2013.07 (32-bit), Java 1.7.0_25, KDE 4.10.5, kernel 3.4.55-pclos1.pae
on an AMD Athlon II X2 e235 Dual-Core 64-bit processor, and 6 GBs of DDR2 RAM.

Just for kicks, I'm going to create a new user and try it on the new user's profile to see
whether something has happened to my user profile.




________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: deanyourfriendinky@yahoo.com 
Sent: Monday, August 5, 2013 1:50 AM
Subject: [Bug 67765] Other: Can't Save New Autocorrect Entries
 


 
Comment # 1 on bug 67765 from Emir Sarı  
Cannot reproduce with ersion: 4.2.0.0.alpha0+
Build ID: aa5683e18de07c9e86325595ead4574efa685c3a
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-04_00:00:19 Should be a Linux specific bug.
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 5 Kelton Newman 2013-08-06 03:03:13 UTC
If I run libreoffice4.1 as root, Autocorrect will save new entries.
Now all I need to learn is what permissions to apply to what file(s)
in order to allow me to save new entries without running
libreoffice4.1 as root.




________________________________
 From: Dean <deanyourfriendinky@yahoo.com>
To: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> 
Sent: Monday, August 5, 2013 10:53 PM
Subject: Re: [Bug 67765] Other: Can't Save New Autocorrect Entries
 


Not only does this glitch occur on the PCLinuxOS-blended version of LibreOffice,
but when I used Synaptic to uninstall the PCLinuxOS-blended version of LibreOffice,
deleted my /home/myprofilename/.config/libreoffice directory and installed
LibreOffice 4.0.1.4, Build Version 89ea49ddacd9aa532507cbf852f2bb22b1ace28,
I reproduced the problem: Cannot Save New Autocorrect Entries


I'll add an entry.  The moment I click OK and then reopen the Autocorrect entry-edit
dialog box, the new entry is gone.

I'm using PCLinuxOS 2013.07 (32-bit), Java 1.7.0_25, KDE 4.10.5, kernel 3.4.55-pclos1.pae
on an AMD Athlon II X2 e235 Dual-Core 64-bit processor, and 6 GBs of DDR2 RAM.

Just for kicks, I'm going to create a new user and try it on the new user's profile to see
whether something has happened to my user profile.




________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: deanyourfriendinky@yahoo.com 
Sent: Monday, August 5, 2013 1:50 AM
Subject: [Bug 67765] Other: Can't Save New Autocorrect Entries
 


 
Comment # 1 on bug 67765 from Emir Sarı  
Cannot reproduce with ersion: 4.2.0.0.alpha0+
Build ID: aa5683e18de07c9e86325595ead4574efa685c3a
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-04_00:00:19 Should be a Linux specific bug.
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 6 Kelton Newman 2013-08-06 03:03:21 UTC
If I run libreoffice4.1 as root, Autocorrect will save new entries.
Now all I need to learn is what permissions to apply to what file(s)
in order to allow me to save new entries without running
libreoffice4.1 as root.



________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: deanyourfriendinky@yahoo.com 
Sent: Monday, August 5, 2013 4:20 AM
Subject: [Bug 67765] Other: Can't Save New Autocorrect Entries
 


 
Comment # 2 on bug 67765 from Mike Kaganski  
I cannot test it, as I have no Linux. But another bug report indicated the same
issue (Bug 67697, it's description is in Russian). The reporter of the
mentioned bug could workaround this by using sudo.
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 7 Mike Kaganski 2013-08-06 06:23:53 UTC
Kelton Newman, please don't use e-mail client when answering to Bugzilla, instead, use Bugzilla web form. Or at least don't forget to remove the original message from the text of the reply. It makes the issue more readable.

Thank you.
Comment 8 tommy27 2013-08-06 07:40:10 UTC
let's continue discussion over there: Bug 67743

do you guys reproduce this issue just on LibO 4.2alpha or even on 4.1.0 final release?