Bug 67791 - Double-click save button opens two Save As dialogs (win only)
Summary: Double-click save button opens two Save As dialogs (win only)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-05 13:29 UTC by Mike Kaganski
Modified: 2017-11-30 20:55 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2013-08-05 13:29:42 UTC
When saving a new file, if to double-click the toolbar Save button (instead of single-click), two Save As dialogs are shown.

Steps to reproduce:
1. Create a new document.
2. Make some modifications, e.g. type a character.
3. Double-click Save button on the toolbar.

Expected result: one Save As dialog is opened

Actual result: two Save As dialogs are open, both accessible (they don't block each other, i.e. mutually non-modal).

Tested with LO 3.3.0.4 - 4.1.0.4, and AOO 4.0.

Considerations:

1. This bug is likely to occur if a user suffers from a locomotory disorder, or has a broken mouse that makes multiple clicks on a button press.

2. While this specific case is of low importance, it may happen that the same problem will be with other buttons (I haven't tested). There are some buttons that specifically need to be able to receive double-clicks (like, say, Style Paintbrush). But allowing to double-click some other may bring more problems, when an action will be unexpectedly triggered twice.
Comment 1 retired 2013-08-06 03:31:46 UTC
not reproducible on OS X or Ubuntu.
Comment 2 ign_christian 2013-08-06 04:21:48 UTC
Confirmed with LO 4.0.5.1 (Win7 32bit)
Comment 3 Mike Kaganski 2014-02-03 00:38:42 UTC
Can't reproduce with 4.2.0.4 under Win7x64.
Closing as WORKSFORME.