Bug Hunting Session
Bug 95726 - Doubleclick on Open File button creates two dialogs [possible crash]
Summary: Doubleclick on Open File button creates two dialogs [possible crash]
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Main-Menu File-Dialog
  Show dependency treegraph
 
Reported: 2015-11-10 10:49 UTC by Armin Le Grand
Modified: 2017-10-24 10:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Armin Le Grand 2015-11-10 10:49:41 UTC
- start LO
- double-click on open file
-> 1st doublecklick, 1st error: two open file dialogs open, close them again
-> 2nd doubleclick, 2nd error: crash

Stack:
	vcllo.dll!SalGraphics::DrawRect(long nX, long nY, long nWidth, long nHeight, const OutputDevice * pOutDev) Line 421	C++
 	vcllo.dll!OutputDevice::ImplDrawTextRect(long nBaseX, long nBaseY, long nDistX, long nDistY, long nWidth, long nHeight) Line 160	C++
 	ntdll.dll!77121ead()	Unknown
 	kernel32.dll!769514bd()	Unknown
 	msvcr120d.dll!0f9ac397()	Unknown

the this-ptr is 0x00eb0000, probably the reason. May have to do with the timer changes.
Comment 1 Armin Le Grand 2015-11-10 10:51:10 UTC
of course doubleclick is not the expected action on these buttons, but I would guess this may happen to too rare with double-click affine and trained users.
Comment 2 Armin Le Grand 2015-11-10 10:53:17 UTC
Using the two open file dialogs after 1st doubleclick to open one file each opens both files.
Comment 3 Buovjaga 2015-11-12 12:32:13 UTC
No repro. Unable to open two dialogs.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 4 Armin Le Grand 2015-11-12 12:41:34 UTC
@Beluga: Have you tried more than once? First time loads some dlls, needs long enough to not do this.
Comment 5 Buovjaga 2015-11-12 12:58:04 UTC
(In reply to Armin Le Grand from comment #4)
> @Beluga: Have you tried more than once? First time loads some dlls, needs
> long enough to not do this.

Yes, I tried several time. Now I did a new test with over 10 times.
Comment 6 Armin Le Grand 2015-11-12 13:42:45 UTC
@Beluga: Just updated and rebuild, LO  5.1.0.0.alpha1+ on win7, still two dialogs, sometimes crashes. Two dialogs also directly after start, just a fast doublecklick on open file in the left panel.
Comment 7 ribotb 2016-03-04 22:06:19 UTC
(In reply to Armin Le Grand (CIB) from comment #0)
> - start LO
> - double-click on open file
> -> 1st doublecklick, 1st error: two open file dialogs open, close them again

Reproduce with LO 5.1.1.1 : two dialog boxes

> -> 2nd doubleclick, 2nd error: crash

No crash, only one dialog box

Not reproduce with LO dialog box

Win7/x86 

Bernard
Comment 8 Robinson Tryon (qubit) 2016-03-06 17:01:28 UTC
Testing on Ubuntu 14.04 +
LO 5.2.0.0.alpha0+ (2016-02-24_23:58:47)

(In reply to Armin Le Grand (CIB) from comment #0)
> - start LO
> - double-click on open file

I'm double-clicking on the "Open File" link in the left panel.

> -> 1st doublecklick, 1st error: two open file dialogs open, close them again

Just one 'Open' dialog appears (which I closed)

> -> 2nd doubleclick, 2nd error: crash

Just one 'Open' dialog appears (which I closed)

=> I also tried triple-clicking (with similar results).

NO REPRO for me.
Comment 9 Robinson Tryon (qubit) 2016-03-06 17:07:49 UTC
(In reply to ribotb from comment #7)
> > -> 1st doublecklick, 1st error: two open file dialogs open, close them again
> 
> Reproduce with LO 5.1.1.1 : two dialog boxes

That sounds like confirmation for the *first half* of this bug (albeit the more minor part), so as we don't yet have repro for the crash:
Summary -> "[Possible crash]"
Status -> NEW
Comment 10 Armin Le Grand 2016-03-07 09:13:44 UTC
Thank all of you foer checking. It may have to do with speed stuff, I used the debug version to do this. Withthe much slower debuig build version this might be much easier to reproduce than with the product version. Thus, if one of you has a debug (developer) build handy, please try that one.
With non-debug version I have no idea how faster klicking might be achieved. Maybe with some UI tool that records clicks ans is capable to playback the recorded actions faster? If someone knows something like this, please use it, it might be the key to reproduce this task reliably.
Comment 11 Buovjaga 2016-03-07 10:46:04 UTC
(In reply to Armin Le Grand (CIB) from comment #10)
> Maybe with some UI tool that records clicks ans is capable to playback the
> recorded actions faster? If someone knows something like this, please use
> it, it might be the key to reproduce this task reliably.

This thing should be able to do it, but not ready yet: https://blog.documentfoundation.org/blog/2015/12/16/tender-for-automated-a11y-based-ui-testing-201512-04/
Comment 12 Armin Le Grand 2016-03-18 14:56:35 UTC
Just tried again with debug version, still reproducable. Using

Version: 5.2.0.0.alpha0+
Build ID: 4331b137fdbe6992ca63ceb70a6f48ed6f9a86ea
CPU Threads: 8; OS Version: Windows 6.1; UI Render: GL; 
Locale: de-DE (de_DE)
Comment 13 QA Administrators 2017-05-22 13:20:00 UTC Comment hidden (obsolete)
Comment 14 Xisco Faulí 2017-10-22 21:59:33 UTC
Armin Le Grand,
Do you still reproduce this issue on master?
Comment 15 Armin Le Grand 2017-10-24 08:22:30 UTC
No, tried with a debug build on Win, cannot reproduce anymore. Get now a 'ping' for 2nd click, no 2nd dialog.