Bug Hunting Session
Bug 67808 - DRAW : Format >> Character >> Font Effects >> Outline = NOT functional with all font types
Summary: DRAW : Format >> Character >> Font Effects >> Outline = NOT functional with a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
: 75750 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-06 04:01 UTC by NSK Saad
Modified: 2014-03-18 11:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF file of Text outline effect once exported to PDF (44.14 KB, application/pdf)
2013-08-19 19:02 UTC, NSK Saad
Details
Screen shot # 1 of Outline issue as seen in LO Draw (31.99 KB, image/png)
2013-08-19 19:11 UTC, NSK Saad
Details
Screen shot # 2 of Outline issue as seen in LO Draw (32.46 KB, image/png)
2013-08-19 19:11 UTC, NSK Saad
Details
Original LO Draw file in odg format (21.85 KB, application/vnd.oasis.opendocument.graphics)
2013-08-19 19:12 UTC, NSK Saad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NSK Saad 2013-08-06 04:01:42 UTC
Outline command in Font Effects is malfunctioning.

I just downloaded version 4.1.0.4. The new installation overwrote my 3.4.0 version.

I then opened a Draw file that I had created in version 3.4.0 and which had "outlined" text used in a logo design. The outlining was no longer present.

I attempted to outline new text again to no avail. All I get is a "thicker" black color filled version of the Font in question. This problem applies to all Fonts.

I may have to re-download 3.4.0 to save my work (if I still can (?!),unless you can suggest a fix.

thank you

Konstantin
Comment 1 Maxim Monastirsky 2013-08-19 15:56:18 UTC
Can't reproduce with 4.1.0.4 under both Windows 7 & Fedora 19, so maybe it's Mac-specific bug.

@NSK Saad: Could you please provide some test document + screenshot of the bug?
Comment 2 NSK Saad 2013-08-19 19:02:43 UTC
Created attachment 84283 [details]
PDF file of Text outline effect once exported to PDF

Attachment to my added comments on Text Outline effect bug
Comment 3 NSK Saad 2013-08-19 19:08:33 UTC
Hello,

Strange new development. In responding to your e-mail for more info and screen shots, I opened a new Draw file and showed the issue using 4 different fonts on four separate pages, where both regular and outlined font is shown. 

On the Mac's screen in Libre Office, the issue is obvious. However when O export the Draw file to PDF and open the PDF file, the issue is resolved...i.e. the fonts now appear "outlined " ??!!?? I am attempting to attach files but your system will not let me attach mor than one ata a time

Konstantin
Comment 4 NSK Saad 2013-08-19 19:11:26 UTC
Created attachment 84285 [details]
Screen shot # 1 of Outline issue as seen in LO Draw
Comment 5 NSK Saad 2013-08-19 19:11:59 UTC
Created attachment 84286 [details]
Screen shot # 2 of Outline issue as seen in LO Draw
Comment 6 NSK Saad 2013-08-19 19:12:38 UTC
Created attachment 84287 [details]
Original LO Draw file in odg format
Comment 7 Piotr Luszczek 2013-08-19 22:03:49 UTC
I have exactly the same issue.

After a little digging I can a few details on this.

The problem does occur on the latest Mac OS X (Lion=10.7 and Mountain Lion=10.8).
The earlier versions seem OK, though.

The Outline problem is one thing and the shadows is another.
Both are related to font rendering and it seems that Mac OS X Lion (10.7)
changed something in that regard. The shadows on the two newest Mac OS X
releases appear with the same color as the font. On other systems, the
shadow is in a different color so you perceive as a shadow. So the
shadow feature does not work properly because the shadow and the font
are the same color and it is not possible to tell them apart.

Apache OpenOffice 3.4 and 4.0 do render outline and shadow effects
properly on both old and new Mac OS X systems. This might offer
a hint of what is happening inside LibreO.

Another issue that might be related here is the font naming scheme.
LibreOffice uses "Casual" as a font name. All other applications
on Mac OS X call it "Apple Casual".

Is it possible that this is related to some sort of API change
in Mac OS X 10.7 and 10.8?
Comment 8 Piotr Luszczek 2013-09-30 05:47:32 UTC
This is still an issue in LO 4.1.1.2
Comment 9 Maxim Monastirsky 2014-03-04 12:53:54 UTC
*** Bug 75750 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2014-03-17 07:43:58 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=45b0c12a021fb0eb896faf4f0de9026586407012

fdo#67808 Fix Outline Font Effect support with CoreText



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.