Bug Hunting Session
Bug 68167 - Create an outline view similar to that in MS Word and Apple Pages
Summary: Create an outline view similar to that in MS Word and Apple Pages
Status: RESOLVED DUPLICATE of bug 38093
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 70862 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-16 02:20 UTC by UCLAgeek
Modified: 2016-11-14 16:36 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments
Pictures of Words and pages outline views (563.42 KB, application/vnd.oasis.opendocument.text)
2013-08-16 02:20 UTC, UCLAgeek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description UCLAgeek 2013-08-16 02:20:49 UTC
Created attachment 84117 [details]
Pictures of Words and pages outline views

This request is in response to:
http://ask.libreoffice.org/en/question/21498/feature-request-outline-view-in-writer/
and 
http://ask.libreoffice.org/en/question/20630/will-writer-ever-provide-ms-word-style-outlining-not-navigator/

Ok just to be clear writers Navigator is the equivalent to Pages/Words Inspector these are not the same as outline view. 

Outline view displays the entire document as a outline with sections and subsections. I understand that navigator provides the most basic of text folding but this is actually only a small part of outlining. 

Here are some use cases for outlining:

Note taking:
Student taking notes in class you start with the main section and add subsections with a simple return then tab press. This allows for very fast note taking and organization. 

Legal documents:
Most legal documents are organized in a hierarchy with outlining it is insanely easier to keep the document properly organized as well as properly formatted. 

Manuscripts:
Chapters, sections, paragraphs yup pretty much just a huge outline. 

Academic Papers:
Writing research paper is a very long process and being able to visually see how the paper and you notes are organized is a huge benefit. 

ok now again I know navigator kind of does this but it's a lot easier when it's wysiwyg in the document. 

Real and complete integration. Outline view is completely integrated with styles, numbering, lists, biography, table of contents, etc. Any change in the outline updates all of these.  

I have attached a few picture of both word and pages.
Comment 1 Cor Nouws 2013-08-16 07:27:50 UTC
Hi UCLAgeek,

welcome in Bugzilla and thanks for the issue.

Of course the outline view is great - that stands even without your examples. So I set this issue to New as enhancement. 
Version to 3.3.0: it reflects the oldest version of LibreOffice with the behaviour that you want to change.

For the rest I find it a pity that - reading from your description - you have little or maybe no experience with the Navigator yourself. Which if course is strange as you write this plea for a new function. 
And also a pity for your own work ;) course it is a handy tool that offers more then the outline view.

Kind regards,
Cor
Comment 2 UCLAgeek 2013-08-16 16:36:32 UTC
Hi Cor, 

I tried using Navigator a couple of times in class and honestly it really just kind of slowed me down and felt a bit awkward. The key with outline view is it's simplicity. I can promote and demote with a simple tab or shift+tab as well was creating a new section with a simple return. Navigator proved to be a bit distracting because I had to have a second window open while I typed. There is just something about seeing the outline in the document as you write. 

--Mike
Comment 3 Owen Genat (retired) 2013-10-01 23:01:48 UTC
Note that the feature of code folding (a.k.a. text folding) is a separate issue with a separate AskLO thread: 

http://ask.libreoffice.org/en/question/17127/display-hidden-text-when-a-title-is-clicked/

... and enhancement request in bug #47746. This is evidently *not* the Outline View feature described/requested in this big. It may however be worthwhile linking the two bugs above the line. I am not certain what the QA policy is on this.
Comment 4 Cor Nouws 2013-10-12 18:51:41 UTC
*** Bug 70408 has been marked as a duplicate of this bug. ***
Comment 5 Cougar Brenneman 2013-10-12 23:35:08 UTC
I'm the author of Bug 70408, which has been marked as a duplicate of this bug. I need to point out that while I agree with Mike--UCLAgeek--the features he's discussing are not the same features as I'm discussing, though they are related.

IN OTHER WORDS, these are similar requests, but not duplicates. Keep them together for convenience. But please read my request as different, because I'm highlight specific different features.

Cor: The Navigator bears some relationship to the Document Map in Word, though there are differences. I have looked at your Navigator as extensively as I could without installing LO, and I have to agree with Mike that it simply is not the same thing at all. In addition, the Navigator does not duplicate the specific features I'm requesting, such as the manipulation of individual paragraphs within the document by dragging their buttons. Navigator's ability to reorganize sections is okay, but it's nothing close to being able to reorganize paragraphs without headings. 

This is key to what I use M$ Word for. This function alone makes a huge difference in the ability to deconstruct a single sentence or a single paragraph and create something more powerful/poetic/concise/clear/insightful.

In addition, I don't want to be moving things around on a separate window any more than Mike does. I agree with Mike, but the features I mention are different. This is not a duplicate.

Cougar
Comment 6 Owen Genat (retired) 2013-10-13 13:53:30 UTC
For the sake of clarity, here is a 17-page guide describing the process of creating a document in Outline view in MS Word:

http://office.microsoft.com/en-001/word-help/create-a-document-outline-RZ006105145.aspx

From my reading of this bug, this would seem to be the feature indicated in this bug i.e., what is being requested for implementation. I am in agreement with Cor that bug #70408 appears to be a duplicate.
Comment 7 Cougar Brenneman 2013-10-13 14:38:36 UTC
Owen, I don't know of a page anywhere that tells how I use my outliner and why the lack of one is a deal killer for ME. My bug tells you why I can't use LibreOffice, and it's different from why Mike finds it inconvenient. For him, it's not a deal killer.

I'm also not copying the entire conversation on Nabble, but it's relevant, and I explain more there.

http://nabble.documentfoundation.org/Feature-Request-Lack-of-Outliner-Functionality-a-Deal-Breaker-for-Me-tp4077564p4077851.html

The following, for instance, is not normally relevant to a feature request, but on the other hand, it indicates the high priority that this feature, as I've described it, is for me.

I wrote: "I had a Linux partition on my last computer, but I found that I had to duplicate resources by having them on both partitions. When I ran out of space and had to replace the partition, I resented Linux, because I was only using it for ideological reasons, and I could not leave Windows behind until I had a fully functioning Office suite, with an integrated outliner. So in reality, the lack of outliner functionality is a deal breaker for me for everything, including whether or not I use Linux."

I also described a short project that I had just completed where LibreOffice would have required approximately 492 clicks to accomplish what I accomplished with 63 clicks using Word. LibreOffice would have also taken twice as long, and given the extra effort, I would have taken more shortcuts and done a less effective job.
Comment 8 Cor Nouws 2013-10-25 12:03:34 UTC
*** Bug 70862 has been marked as a duplicate of this bug. ***
Comment 9 Bernhard Rohrer 2013-10-25 13:15:12 UTC
I am the author of Bug 70862.

This is an ancient subject of discussion, see OOO Bug https://issues.apache.org/ooo/show_bug.cgi?id=3959

It is a non-minor issue, and I am actually not happy with the importance medium. As has been stated repeatedly in several threads it is quite possibly the single biggest issue holding the acceptance of writer back.
Comment 10 Cor Nouws 2013-10-25 13:26:34 UTC
(In reply to comment #9)

>.... it is quite
> possibly the single biggest issue holding the acceptance of writer back.


I know many of those single buggest issues, depending on who I speak with...

But - waiting for this feature being added - pls do yourself a favor and use the Navigator as good as possible ;)
Comment 11 Cougar Brenneman 2013-11-11 08:59:11 UTC
I've been avoiding LibreOffice because of the outliner problem, but I needed to find out of my Excel formulas would still work in LO, and they do. Since I had to install LO anyway, I decided to play with the Navigator in Writer to see if I can be more specific about what I need. Here are three changes that would make it come closer:

1) Create an option so that the Navigator displays the first line ONLY of every text body paragraph, so that all paragraphs can be dragged into the headings desired, and then hidden or displayed as needed.

2) Create a full-screen option for the navigator, and when the navigator is in full-screen mode, disable the modal property so that the user can switch between the full outline view in Navigator and the text view with a button, alt-tab, or cmd-tab. Create a button or menu item in the main window to bring the Navigator to the front and restore its modal property if the user loses track of where it is.

3) Create a method such that headings in the Navigator can be sorted using the sort function. Currently, this is impossible because you cannot select multiple headings. I need to be able to insert a date, for example, at the beginning of a bunch of different sub-headings, drop these subheadings into headings, and then sort them by date, all the time taking all of their children (whether text paragraphs of subheadings) with them. I need to be able to sort on multiple outline levels, sometimes numerically, sometimes by date, and sometimes alphabetically.

This is important, because when I'm in outline mode in word, much of my work is using the outline view to sort text that has no headings. 

Currently, my inability to use LO to manipulate nonheader paragraphs is a deal killer. I could never use LO until this feature is present.

The sort problem is also a deal killer.
Comment 12 Cougar Brenneman 2013-11-11 09:23:55 UTC
In #2(In reply to comment #11)
> 2) Create a full-screen option for the navigator, 

I meant "Create a maximize option for the Navigator...
Comment 13 Cougar Brenneman 2013-11-11 14:38:25 UTC
I have to say that I'm not certain that my proposals are sufficient. As I review them, I see that I sometimes need to see entire text paragraphs in outliner mode, and while I speculated that I could achieve similar functionality with my first two suggestions, I see that as a cumbersome alternative to what Word does in a single view.

In addition, it would be "making do," rather than having a superior alternative or even an equal alternative. The ability to display the first line of the paragraphs or the full paragraphs in the navigator begins to make it look more and more like it really needs to look. 

To be less cumbersome, text edits in the Navigator would also need to be available. I'm sorry that the Navigator is so insufficient, but it really is. I have tried, in my version, to write a complete, procedural description of what I do, because I was hoping that if I did so, the programmer community would understand the reasons. I'm not sure that this has happened.

While I've seen one comment that sees the similarity with code folding, a possibly useful metaphor, it only captures a tiny piece of the power of the outliner function.

I fear that the programmer community in this development project doesn't really understand the needs of the user community, and I don't know if you can, given the different nature of our disciplines.

The outliner function is powerful because it a tool that so fully supports the creative process, based on what we do with our minds while creating and organizing. It's not about formatting or any of the other false understanding about its function that I've seen. 

These are not enhancements, but basic features that are needed. LO is a substandard tool until it has these features, in terms of my own needs.
Comment 14 Bernhard Rohrer 2014-01-13 10:32:50 UTC
(In reply to comment #10)
> (In reply to comment #9)
> 
> >.... it is quite
> > possibly the single biggest issue holding the acceptance of writer back.
> 
> 
> I know many of those single buggest issues, depending on who I speak with...
> 
> But - waiting for this feature being added - pls do yourself a favor and use
> the Navigator as good as possible ;)

As many other has stated, the navigator is not fit for purpose. I have tried it, it is awkward and does not do what I need. I am seriously tempted to create a video demo in order to show what the outliner does. I am also feeling very frustrated because all I ever here when anybody asks for the outline view - for over 10 years now!!!! - is "use the navigator". 

Is the difference in functionality so unclear that I really need to create a demo?

And yes I know that you said "waiting for this feature being added" - do we have a plan for this yet?

Thanks
Comment 15 inpost 2014-01-13 11:08:03 UTC
Someone, please co-ordinate with OO (see: https://issues.apache.org/ooo/show_bug.cgi?id=3959) and create a fork for this feature.

10-year-old requests are an embarrassment.
Comment 16 Grisemine 2014-01-17 10:19:55 UTC
Hello there, nice work ! I love LO and use it every for years. And yesteray I fought - it would be so nice to have an outline view "a la Word". I know Writer very well, and use and like the navigator. But it is absolutely not like the outline. Outline is the text, you work with it like in normal edit mode. Just you can fold and unfold, and move / promote / demote parts directly in the text. Very convenient for small reviews, fantasticaly usefull for long documents as books (I'm writing both). 

I've been on OOo bug report too (link given here) and it seems this demand is 10+ years old. Some devs do not seem to understand how it works, nor why it is usefull. Just trying it for a few minutes should convince anybody how GREAT outline view is. It would be a fantastic addition to Writer... 

(please indulge my poor english ;))
Comment 17 D. C. Sessions 2014-01-22 01:10:22 UTC
1) All new to this topic, please read the OOo history before suggesting that Navigator will do the trick [1].

2) For anyone who wants to argue that outlining is old-fashioned, please consider that writers have been using the general techniques of outlining for longer than anyone (not just the current generation of software developers) has been alive.  Programmers (and FWIW I have a degree in CS) rightly sneer at the idea that software creation should be modeled on literature creation.  Hmmm.

3) Outlining is not just a tool for creating initial drafts.  If anything, it's much more of a tool for editing.  Massively -- as in, "take these two chapters, move them to after chapter 15, and insert Appendix C into the second one before section 5."

4) It's quite possible that, despite (2), there are better tools.  If you think so, don't just wave a link -- describe how an author can use those tools to send a draft to a co-author so that the co-author can make structural revisions (including insertions, moves, etc.) and return the document.  I suppose it's possible to do this in a multi-tool process without inviting death threats, but I'm skeptical.

[1] The short history is that writer say that the outline view is essential.  A developer says, "use the Navigator."  Multiple writers explain that Navigator is using punched cards rather than an IDE.  Developer suggests a really spiffy new tool, paper tape.  Writers explain that they want an IDE.  Before long, the original developer drops off the radar.  Topic goes dormant.  Someone starts it up again, and a new developer shows up.  Loop.
Comment 18 Jean-Marc Liotier 2014-01-30 12:59:13 UTC
I just discovered that Libreoffice Impress has a basic but quite usable outline view. Any chance that its code could be used to expose the same functionality in Libreoffice Writer ?

Here are a couple of the files that a search for 'outline' dregged from the Libreoffice code:
http://opengrok.libreoffice.org/xref/core/editeng/source/outliner/outlvw.cxx
http://opengrok.libreoffice.org/xref/core/editeng/source/outliner/outliner.cxx
http://opengrok.libreoffice.org/xref/core/sd/source/ui/inc/OutlineView.hxx

The timestamps on the editeng/source/outliner directory show recent edits (http://opengrok.libreoffice.org/xref/core/editeng/source/outliner/) but http://opengrok.libreoffice.org/history/core/editeng/source/outliner shows that they are unrelated to the outlining functionality.
Comment 19 Cougar Brenneman 2014-01-31 02:17:46 UTC
Sent from Windows Mail





From: bugzilla-daemon@freedesktop.org
Sent: ‎Tuesday‎, ‎January‎ ‎21‎, ‎2014 ‎5‎:‎10‎ ‎PM
To: Cougar Brenneman

@DC Sessions below: 

In addition, the writers get fed up that the developers can’t comprehend what we’re showing them. I personally have put a lot of work into explaining exactly the functionality that I need to the developers here, but I’m not finding that anyone is understanding it. Then the writers go away. Until some new writer has the bright idea that he or she can make a difference to this conversation with more information. Wrong.


Thanks for the summary DC





@Comment # 17 on bug 68167 from D. C. Sessions  The short history is that writer say that the outline view is essential.  A
developer says, "use the Navigator."  Multiple writers explain that Navigator
is using punched cards rather than an IDE.  Developer suggests a really spiffy
new tool, paper tape.  Writers explain that they want an IDE.  Before long, the
original developer drops off the radar.  Topic goes dormant.  Someone starts it
up again, and a new developer shows up.  Loop.



You are receiving this mail because: You are on the CC list for the bug.
Comment 20 Jean-Marc Liotier 2014-01-31 09:45:05 UTC
Saying that developers ignore the gaping functional hole is exaggerated: some are fully aware, but then it is all a matter of prioritizing issues vs. resources... And we don't bring much to the table besides our rightful lamentation. Maybe we should organize some way to translate our requirements into project resources.

Mathias Bauer explained in 2007 (https://issues.apache.org/ooo/show_bug.cgi?id=3959#c76) that, on top of being a substantial and entirely new layout, outline view depended on being able to display simultaneously multiple layouts for a single document - which implied significant refactoring of the existing functionnality. In 2008 (https://issues.apache.org/ooo/show_bug.cgi?id=3959#c96) he underlined that lack of progress was not caused by undervaluing this feature but because its cost made it a lower priority. Support for multiple layouts was added to Openoffice in Q3-Q4 2010 (https://issues.apache.org/ooo/show_bug.cgi?id=81480) but that was around the time of the Openffice/Libreoffice fork so I do not know how much of that exists in the Libreoffice code.
Comment 21 Owen Genat (retired) 2014-01-31 13:20:06 UTC
Related Apache OO issue added to See Also list.
Comment 22 Jean-Marc Liotier 2014-01-31 14:08:22 UTC
Today, Mathias Bauer provided us (https://issues.apache.org/ooo/show_bug.cgi?id=81480#c10) with some details about the multiple layout work that has been performed, in part to make outline view possible:

<quote>
I'm no longer working on OpenOffice, so I can only talk about what I did until 2011.

Until that point in time we layer the ground for multiple layouts, but didn't actually use that capability because (AFAIR) some parts needed some extra work. 

All code that had hit the trunk of Ooo is part of Apache OO. As the LO people usually copied most of the OOo/AOO stuff, I assume all of this is in their repo also.

The basic idea of the refactoring was to revert dependencies: instead of having the document know the one and only existing layout object and manage it from there, there should be just a collection of layouts that all know the document and actively retrieve information from there.

AFAIR the remaining work was associated with dividing drawing objects into a model and a view part, so that every layout can have its own drawing object view (based on the same drawing object that is part of the core). Armin LeGrand and Oliver Wittmann have been involved in the discussions, and both of them are still working on AOO.
</quote>
Comment 23 Cougar Brenneman 2014-02-01 18:47:27 UTC
I just wrote comment #89 in a zdnet article extolling the virtues of LibreOffice. My comment was entitled "LibreOffice is still ignoring writers." I'm going to become more and more aggressive in posting my complaint publicly until I see real progress in handling this feature request.

http://www.zdnet.com/bigger-better-faster-libreoffice-4-2-7000025807/?s_cid=e539&ttag=e539#postComment

As inpost@gmail.com says in @comment 15, "10-year-old requests are an embarrassment."

I, for one, made this request over ten years ago the first time in the OpenOffice community. My level of frustration with LibreOffice is such that I'm now willing to join the opposition to get movement on this feature request. That includes sharing my frustration publicly and at length whenever the opportunity appears to me.
Comment 24 richlv 2014-02-01 20:11:53 UTC
it might be a better idea to write down detailed desired functionality (see feature descriptions, done by sun back in the days of the original oo.org 1.x) and find interested developers who could work on it. you might even start a donation campaign to finance the feature.
i think that has much better chances of actually achieving something positive, as opposed to "become more and more aggressive in posting my complaint publicly" or "sharing my frustration publicly and at length".

i'm not even sure what "join the opposition to get movement on this feature request" is supposed to mean. you seem to take this as a political conflict where there is a "position" group opposing this feature even though it is a simple problem of resource shortage on an opensource project.
Comment 25 Jean-Marc Liotier 2014-02-01 21:21:47 UTC
@Cougar - I don't know if you are professionally involved with developers in general and free software developers in particular… But, as someone who provides work to a crowd of them, let me share my opinion about threatening them: it does not work at all, especially when your requirements are not exquisitely well laid out and even more when you bring no project resources (people or money) to the table.

If no document exists, that gathers the detailed requirements for this functionality, then this is where users should begin - in a wiki page for example. Lacking that, project planning is difficult and hazardous - if it happens at all. Even the developers that might be aware of what we have in mind will have an easier time organizing their work if they have a clear plan.

If participants to this thread consider that useful, I am willing to start writing detailed requirements for an outline view - starting with documenting the best practice that Microsoft Word's outline view is.

Wow - I just publicly stated that a Microsoft functionality is a best practice… This is a first in 25 years - I need a strong drink…
Comment 26 Cougar Brenneman 2014-02-03 20:09:21 UTC
@Jean-Marc Liotier and @richlv

I am a consumer--a writer--and I have been writing about my need for a very long time, and in this particular thread, there are both detailed descriptions of the functionality I need and a link to a different thread where I detailed the functionality at even greater length.

So don't lecture me about how I should speak to the developer community and give them descriptions of the functionality I need. I've received no further questions about what I wrote, and as far as I can tell, what I've been saying has fallen into a big hairy black hole, both when speaking to the LibreOffice community and the OpenOffice community over ten years ago, and occasionally in between.

So at this point, I'm done with being appropriate. I'm now going to start writing publicly about what's wrong whenever possible. I included the link to the comment that I wrote on ZDnet, and in that comment, I spoke of my frustration, with the frustration of others who need this functionality, and I quoted some of the discussion from this thread.

The bottom line is that until this functionality is either duplicated or improved upon, LibreOffice is for me a nonstarter. When someone writes a glowing report about how wonderful LibreOffice is, I'm going to be in comment section writing in detail about what's wrong with LibreOffice. I'm going to argue every time I see the topic come up in a public discussion that for me, LibreOffice doesn't work.

No, the Navigator doesn't fill the bill, not at all. In this thread, I've included three suggestions about how to make the Navigator "sort of" work, but as I wrote in that post, these suggestions are only to reach the bottom level of needed functionality. With those three suggestions, I could use LibreOffice, and I might, just because I am philosophically in the open source movement.

You can lecture me about how a gentler approach works better, but I have to tell you that in my long, long, long experience of talking within this community, both is the bugzilla and in other forums about LibreOffice, I've received no traction in trying the gentler, more appreciative tone.

No, I'm pissed, and I'm going to express my anger in dealing with the lack of responsiveness in this community.
Comment 27 Jean-Marc Liotier 2014-02-03 20:14:44 UTC
Cougar wrote:
> I'm going to express my anger in dealing with
> the lack of responsiveness in this community.

Anger at yourself then - you, me & everyone else are the community.
Comment 28 Jean-Marc Liotier 2014-02-03 20:46:22 UTC
Anyway, I'm going to produce a formal user requirements document generously strewn with use cases and screenshots, in the hope that it provides better visibility to the needs of users who participate in this thread and helps willing developers to understand what could be done about it... Maybe some structure will help us channel all our emotional energy into something constructive - isn't structure what Outline View is about ?

Give me a week for a first draft - I'll publish it on the Document Foundation's wiki.

For now, I wrote a stub at https://wiki.documentfoundation.org/Outline_view and I'll enhance it with whatever information I can gather about the state of Outline View in LibreOffice Writer.
Comment 29 Cor Nouws 2014-02-05 22:31:32 UTC
(In reply to comment #28)
> Anyway, I'm going to produce a formal user requirements document generously
> ...

Good idea, thanks.
Today I happened to read this one:
  http://www.openlogic.com/wazi/bid/330058/libreoffice-navigator-makes-you-a-document-navigation-pro
pls keep that in mind when you do your work.

kind regards,
Cor
Comment 30 Cor Nouws 2014-02-05 22:35:40 UTC
PS: I never said that the Navigator is/provides the same as the outline view. I know that one too.
Comment 31 Cougar Brenneman 2014-02-06 05:35:15 UTC
Thank you, Jean-Marc. I very much appreciate your attention to this issue.

I could not see your stub when I went to look at it, but got an error message "Sorry! This site is experiencing technical difficulties." Nonetheless, I wanted to thank you as soon as I saw that you had created this stub and were taking the time to investigate it seriously.

Please read the functionality suggestions I made at Bug 70408, as well as the discussion in the nabble link that I posted in this thread. I wish I had links to other forums where I've tried to discuss this, but I think I've handled most of my needs in this bug, Bug 70408, and nabble. I also feel that UCLAgeek made some very good points in starting this bug.

I'm not completely sure how bugzilla works, but if you have any direct questions that you'd like to send me privately, I'd certainly be willing to answer them. In addition, I've been monitoring this thread regularly, and I'll keep checking back periodically, especially now that I'm beginning to feel heard. If questions need to be answered in this forum, I will do that too.

I'm willing to describe to you, for instance, how an outliner directly empowers writers to tap into their creativity at greater levels and other details that are not technical but more experiential or phenomenological, because these descriptions might be useful in understanding why I stick with what I have in M$ Word.
Comment 32 Cougar Brenneman 2014-02-14 04:46:41 UTC
(In reply to comment #28)
> Anyway, I'm going to produce a formal user requirements document generously
> strewn with use cases and screenshots, in the hope that it provides better
> visibility to the needs of users who participate in this thread and helps
> willing developers to understand what could be done about it... Maybe some
> structure will help us channel all our emotional energy into something
> constructive - isn't structure what Outline View is about ?
> 
> Give me a week for a first draft - I'll publish it on the Document
> Foundation's wiki.
> 
> For now, I wrote a stub at https://wiki.documentfoundation.org/Outline_view
> and I'll enhance it with whatever information I can gather about the state
> of Outline View in LibreOffice Writer.

I just finished spending over an hour reading the entire 12-year history from the link on your stub, Jean-Marc. Many people saying the same as me.

Two comments seemed important to me. One was #202 by liotier, commenting on what an epiphany it is for people that he teaches to use an outliner. I find the same reaction--that when I teach others to use it, they are forever grateful. Liotier says, "This is a recurring theme in collecting user requirements: 19th century people don't want a car - they want a faster horse. Just because the majority of users don't know they need an outliner doesn't mean is would not be useful to them."

Liotier seems to me to have put his finger on the whole problem. For anyone who knows how to use an outliner, it quickly becomes essential. For the rest of the population, there's no demand because they've never tried it. My guess is that includes many of the LO and OO developers. 

Hey, people! We don't want a faster horse! We want a car!

Just this year, james flowerdew made another comment, #232, which is also pointed at the problem. He wrote "Free software that only half replaces paid software is actually aiding it's paid competitors."

Finally, I'd like to quote Liotier, because he worked in software production for 20 years. "But from twenty years of writing as a software projects manager, I can testify that word processing productivity and well-structured documents are strongly correlated to the use of the outline mode."

I also worked in software development, though not as long, as a senior technical writer at Fujitsu. My past comments were about the issue of enhancing creativity and ease of organizing for a nontechnical writer, because that's what I am now. 

But as a technical writer, I also found it crucial for writing well-structured technical documents, particularly since I was tasked to writing developer guides in a language that I barely knew. (I wrote a jdbc class for one of my guides which I considered a crowning achievement, because it was immediately implemented by sales engineers.)

I also used to write everything in M$Word, and then when it was fully vetted, I'd import it into Framemaker, which I also hooked up to print the API directly from the javadocs, and I did my editing and writing of the javadocs in Word using the outliner, and then used macros to format them for insertion into the code.

The outliner was absolutely essential to doing my job as a top technical writer. I do not understand why this has been an open issue for 12 years.
Comment 33 Gerry 2014-03-29 08:56:17 UTC
Isn't this a duplicate of bug 38262?
Comment 34 Matej Cepl 2014-04-04 11:38:00 UTC

*** This bug has been marked as a duplicate of bug 38262 ***
Comment 35 Mike Kaganski 2014-11-22 07:17:40 UTC
*** Bug 70408 has been marked as a duplicate of this bug. ***
Comment 36 Ernesto Bosch 2015-04-26 18:12:45 UTC
(In reply to Cougar Brenneman from comment #32)
(In reply to comment #28)

Cougar Brenneman said:

"For anyone who knows how to use an outliner, it quickly becomes essential. For the rest of the population, there's no demand because they've never tried it. My guess is that includes many of the LO and OO developers."

"Hey, people! We don't want a faster horse! We want a car!"


As a college teacher for 25 years (since Ms Word DOS version) I found Ms Word outlining an outstanding feature for any scientific/technical writer, and as a science teacher I want my students be able to write good scientific/technical papers. 

However, students don't no how to accomplish that, so I explain to them what an outline is. But outline is just half of the story because along side outline it's needed the ability to EDIT the outline itself, AT THIS POINT MS WORD IS CLEARLY SUPERIOR TO LIBRE WRITER. I can tell that because I've been using navigator window since middle of 90's when Libre Writer was known as StarOffice Writer. It is NOT the same.

As james lowerdew said (comment, #232) "Free software that only half replaces paid software is actually aiding it's paid competitors." I can testify that: I want to push students to move to Libre Office Writer but as soon as they find Ms Word outline they pull back to Ms Word because of its outline editing capability.

LIBRE OFFICE USERS COMMUNITY NEEDS AN OUTLINE VIEW WITH IN IT EDITING CAPABILITY, although they don't know their needs yet. 

We want a car no a faster horse!!! If we want to promote open software as LibreOffice.

Thanks
Comment 37 Mike Kaganski 2015-04-27 00:29:16 UTC

*** This bug has been marked as a duplicate of bug 38093 ***