Bug 38262 - Outline View (aka MS Word)
Summary: Outline View (aka MS Word)
Status: RESOLVED DUPLICATE of bug 38093
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-13 10:05 UTC by Timur
Modified: 2015-02-21 22:03 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2011-06-13 10:05:53 UTC
Outline View is an old issue at http://openoffice.org/bugzilla/show_bug.cgi?id=3959. 
I'd like to put this on http://wiki.documentfoundation.org/Vote_for_Enhancement.
Comment 1 Björn Michaelsen 2011-12-23 12:21:34 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Timur 2011-12-24 10:03:42 UTC
The same issue on a new address: https://issues.apache.org/ooo/show_bug.cgi?id=3959
Comment 3 vitriol 2012-02-04 02:45:03 UTC
*** Bug 45610 has been marked as a duplicate of this bug. ***
Comment 4 marius 2012-05-26 03:03:44 UTC
I suggest that someone set up and add an amount on a bounty site like
http://www.fossfactory.org/ I guess several people would be interested in
paying someif this was implemented.
Comment 5 Susan Cragin 2012-06-11 12:54:58 UTC
I would be happy if the Navigator panel were editable. Word wrap would be nice but not essential. 
I like very much that Navigator gives a panel where the formatting is hidden, and you can just see the words/ideas/concepts in logical sequence.
Comment 6 Susan Cragin 2012-06-19 10:17:18 UTC
You've done it!
I can edit in Navigator Bar. 
The text comes in very, very slowly, but it does come in. 
Thank you very much. I started working with it today.
Comment 7 Susan Cragin 2012-07-18 14:25:33 UTC
So Navigator is editable, but the primary focus has not been moved there, it just tracks key movement from the main text. It's hard to know where you are and it's slow. 
I'd like to be able to edit in Navigator with the same speed as in the primary panel. Is there any way to make Navigator the primary panel? I don't need to see formatting or anything in an outline view (in fact, I would prefer not to). 
I just need to be able to enter and edit text quickly.
Comment 8 Timur 2013-05-17 14:43:29 UTC
I edited https://wiki.documentfoundation.org/Feature_Comparison:_LibreOffice_-_Microsoft_Office#Word_processors:_LibreOffice_Writer_vs._Microsoft_Word in order to split Outline view and Draft view. 
I wrote for Outline view: 
no, workaround: Navigator > Content View to drag and promote/demote headings
meaning that this is rather acceptable.
Comment 9 Gerry 2014-03-29 08:56:57 UTC
Isn't bug 68167 is a duplicate of this one?
Comment 10 Cor Nouws 2014-03-30 17:39:57 UTC
(In reply to comment #9)
> Isn't bug 68167 is a duplicate of this one?

think so..
Comment 11 Matej Cepl 2014-04-04 11:38:00 UTC
*** Bug 68167 has been marked as a duplicate of this bug. ***
Comment 12 Bob 2014-04-15 17:28:45 UTC
Bug 68167 has far more detailed discussion and references, and very specifically explanation of why minor fixes to navigator will _not_ cut it. If 68167 is to be marked as a duplicate of this, then the importance level (high) needs to be transferred as well - which I'm going to attempt to do, but I probably don't have the required karma.

I would like to add my very strong support to this RFE (yes, sorry, I realise it's quite old, but I didn't find it till now). I teach a course on technical writing (I'm a CS professor, but you teaches what you gets). As far as possible, the course is based on free software. 

Just as in software, any complex document needs a design/implementation cycle. That implies a need for good tools to support the design process (the analogue of UML and other design tools for programming). Well-designed word-processing documents - at least technical ones - are tree-structured, so the design process requires a good tree-structuring tool: one that supports the editing of the document structure at the 'ideas' level prior to and during writing, and does so in an intuitive, easy-to-use way. MS Word outline mode is excellent for this. For all that I love all the other aspects of LibreOffice, Navigator just doesn't cut it. So at the moment, I have to lamely tell my students 'beg or borrow a copy of MS Word, or use jreepad, to do the document structuring, then switch to LibreOffice'. Of course, you can guess how far my free software evangelism gets with that...

Incremental changes to Navigator aren't what's needed. For all the reasons argued at 68167, and before that on the OO links, implementing this requires a complete new design, to properly support editing document tree structures. It needs to be simple and natural to use, as MS Word outline mode is. Without such a redesign, Writer cannot be a proper tool for designing and building large documents: it will remain an editor rather than a document IDE (think vi versus eclipse). To my mind this missing functionality is by far the biggest issue with Writer, or indeed the whole of LibreOffice. And it's the biggest danger to LibreOffice - if OO implemented this first, it would be the one thing that would force me to switch. I'm sure I'm not alone in this.
Comment 13 Bernhard Rohrer 2014-04-16 09:13:05 UTC
(In reply to comment #12)
>[...]
> Incremental changes to Navigator aren't what's needed. For all the reasons
> argued at 68167, and before that on the OO links, implementing this requires
> a complete new design, to properly support editing document tree structures.
> It needs to be simple and natural to use, as MS Word outline mode is.
> Without such a redesign, Writer cannot be a proper tool for designing and
> building large documents: it will remain an editor rather than a document
> IDE (think vi versus eclipse). To my mind this missing functionality is by
> far the biggest issue with Writer, or indeed the whole of LibreOffice. And
> it's the biggest danger to LibreOffice - if OO implemented this first, it
> would be the one thing that would force me to switch. I'm sure I'm not alone
> in this.

Just adding my support for this. I am kinda horrified that this is still not assigned to be honest.
Comment 14 Bernhard Rohrer 2014-04-16 09:16:52 UTC
I am noticing that it is not here any more: https://wiki.documentfoundation.org/Vote_for_Enhancement
Comment 15 Urmas 2014-06-28 19:06:36 UTC
*** Bug 80640 has been marked as a duplicate of this bug. ***
Comment 16 Urmas 2014-06-29 00:23:22 UTC
*** Bug 80640 has been marked as a duplicate of this bug. ***
Comment 17 Yousuf Philips (jay) 2014-06-30 05:01:29 UTC
As i've been in the discussion of bug 80640, i wanted to bring in all of the stuff i've been reading regarding this issue.

1) After reading comment 2 in the OO bug report by oblomov (2002-07-20 12:49:18 UTC), i see that navigator with content view enabled is somewhat of a work around for the issue. The only thing that would need to be fixed in it for it to be acceptable is that after a text is moved, it doesnt collapse all other entries. Of course the user would also have to set all text he wishes to move as one of the ten Heading styles.

2) outline feature was asked in the dev mailing list in March 2011 < http://nabble.documentfoundation.org/http-openoffice-org-bugzilla-show-bug-cgi-id-3959-Outline-view-td2637237.html >

3) there is a wiki page up at < https://wiki.documentfoundation.org/Outline_view > that quotes Mathias Bauer regarding details about multiple layout work that was done.

4) there was another request at OO of the outline feature in 2003 < https://issues.apache.org/ooo/show_bug.cgi?id=10868 >.

2) roryof at < https://issues.apache.org/ooo/show_bug.cgi?id=124984 > is suggesting implementing C++ based Plume Creator by Cyril Jacquet < http://www.plume-creator.eu/site/index.php/en/ > or java based oStoryBook < https://sourceforge.net/p/ostorybook/discussion/?source=navbar >.
Comment 18 Yousuf Philips (jay) 2014-06-30 16:53:28 UTC
Meeks has stated in bug 80640 that to implement this feature, it will take roughly 2 months, at a cost of Eur 50k, and without a reasonable commitment to this sum, it wouldnt be possible to implement it.
Comment 19 Owen Genat (retired) 2014-07-21 00:55:41 UTC
This bug would appear to be a duplicate of bug 38093. I am also adding bug 47746 to the See Also list.

(In reply to comment #17)
> or java based oStoryBook https://sourceforge.net/p/ostorybook/discussion/?source=navbar

Anything but Java. There are enough Java-related questions coming up on AskLO as it is.
Comment 20 Mike Kaganski 2014-11-22 07:19:22 UTC
*** Bug 70408 has been marked as a duplicate of this bug. ***
Comment 21 Jean-Baptiste Faure 2015-02-21 22:03:05 UTC
Comment #19 is right, this enhancement is a duplicate of bug 38093.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 38093 ***