Download it now!
Bug 80640 - EDITING: Writer missing outline feature
Summary: EDITING: Writer missing outline feature
Status: RESOLVED DUPLICATE of bug 38093
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-28 17:23 UTC by Cougar Brenneman
Modified: 2015-04-27 00:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Raw brainstorms, organized alphabetically (66.50 KB, application/msword)
2014-06-28 23:16 UTC, Cougar Brenneman
Details
Raw brainstorms, organized alphabetically, screen shot. (155.53 KB, image/jpeg)
2014-06-28 23:18 UTC, Cougar Brenneman
Details
Step 2: Created initial headings for sorting in outline view (156.36 KB, image/jpeg)
2014-06-28 23:20 UTC, Cougar Brenneman
Details
Step 3 as a screen shot. Collapsing a messy outline. (69.79 KB, image/jpeg)
2014-06-28 23:21 UTC, Cougar Brenneman
Details
The entire document is organized and collapsed into outline sections by drag and drop. (93.79 KB, image/jpeg)
2014-06-28 23:22 UTC, Cougar Brenneman
Details
Step 5: I've begun to edit and write, one section at a time. (213.35 KB, image/jpeg)
2014-06-28 23:25 UTC, Cougar Brenneman
Details
The entire docoment, written and ready for the next step. (52.64 KB, application/x-download)
2014-06-28 23:26 UTC, Cougar Brenneman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cougar Brenneman 2014-06-28 17:23:38 UTC
Problem description: 

I've been writing to you guys since Open Office was first released, because I need a feature that is entirely required for my work. At the beginning, I didn't feel comfortable about Bugzilla, so I wrote to OpenOffice through the website or comments--I don't remember what. When I posted recently, it was marked as a duplicate and I found some of the other people who also need this feature.

The feature is LIBRE OFFICE WRITER IS UNUSABLE BY ME AS A PROFESSIONAL WRITER UNTIL IT HAS A FULLY FUNCTIONAL OUTLINER. 

Steps to reproduce:
1. Open Microsoft Word. Open any document which has headers and paragraphs. A large document with Headers 1, 2, and 3 would do very well.
2. Click: View>Outliner.
3. In the "Show Outline Level" drop-down box on the Outlining Toolbar, click "Show Level 1."
4. Notice the button icons in front of all of the Header 1 titles that show up on the screen.
5. Click one of these button icons using your left mouse button. 
6. Hold the mouse button down and drag that header to a new location by moving it up or down in the document.
7. In the "Show Outline Level" drop-down box, click "Show Level 2."
8. Notice the hierarchy of titles that appears on the screen. Notice that it looks like the Navigator in LO, and that the Level 2 titles are indented.
9. Within each one of the sections of the document, use the method in step #6 to rearrange the subsections. In other words, click and drag subsections to new locations anywhere in the section or in the document.
10. Repeat this entire process with Level 3.
11. In the "Show Outline Level" drop-down box, click "Show All Levels."
12. Notice that all paragraphs are now showing.
13. Click the button on the Outline toolbar that has a tool tip that says, "Show First Line Only." This may be by default to the right of the "Show Outline Level" drop-down box.
14. Notice that now only one line shows from every paragraph. Notice how this unclutters the screen.
15. Within each one of these base sections of the document, use the method in step #6 to rearrange the paragraphs. In other words, click and drag paragraphs to new locations anywhere in the section or in the document.
16. Try using this system to organize a to-do list, an organization list from any organization, a brainstorm list, notes from a technical meeting, etc. 
17. Do this by creating Level 3 headers. Drag notes from the raw brainstorm list into the headers. When necessary, collapse individual headers to keep the screen neat and tidy.
18. When your raw list is completely organized, collapse all header 3s so that only the header 3s show. Paragraphs no longer show at all. This looks just like the Navigator in LO.
19 Create Header 2s. Organize all of the Header 3s into Header 2s.
20. Repeat this process to organize all of the Header 2s into Header 1s.
21. Click "Show All Levels."
22. Change the view to Print or Normal.
23. Read through the now perfectly organized document and write the final version from it.

Current behavior: None of the above.

Expected behavior: All of the above.

              
Operating System: Windows 8
Version: 4.2.5.2 release
Comment 1 Arnaud Versini 2014-06-28 17:58:51 UTC
Hi

Thank you for the report.

First of all, Writer is not a clone of Word, so don't expect to have same behaviour. If you want Word, it's not the right place.

In other term, we won't copy Word.

If you want a new feature, explain this as a need, what you need to do, not what you want to do (especially if you want to copy other software behaviour).

Thanks
Comment 2 Cougar Brenneman 2014-06-28 18:21:11 UTC
FEATURE REQUEST

I DON'T WANT YOU TO COPY WORD. I WANT YOU TO UNDERSTAND THE FUNCTIONALITY, SO I'VE TOLD YOU HOW IT WORKS IN WORD. I COULD HAVE USED OTHER OUTLINERS AS EXAMPLES AS WELL. HOWEVER, DEVELOPERS DON'T UNDERSTAND A FUNCTIONAL DESCRIPTION OF THIS PROCESS, APPARENTLY, SO I PROVIDED AN EXAMPLE. THIS FUNCTIONALITY CAN BE IMPLEMENTED IN ANY WAY THAT YOU WISH, BUT WITHOUT IT, LIBREOFFICE IS SUBSTANDARD.

When I wrote this, I intended it as a feature request, not a bug. The reality is that I can never use your writer software until you have an outliner feature. I've used outliners as a full-time professional writer since the 1980s with PCOutline, and I moved to Word when they improved on it.

I wrote this extensive feature request because I'm a professional writer, and until you have this functionality, I consider your product substandard, and I tell everyone else that I talk about it to that your product is substandard.

I used PCOutline in the 80s as a full-time professional magazine journalist. I used Word's outliner in the 90s as a full-time professional senior technical writer for such organizations as Fujitsu Software.

I've used it on contract jobs in the 2000s. As a retired full-time writer working on both fiction and nonfiction, I use an outliner daily, and I will not be able to use your substandard product until you provide a professional outliner.

Just duplicate the functionality of PCOutline from the 80s, and I'll use your product. It will still be substandard, because PCOutline doesn't have drag and drop.

I DON'T WANT YOU TO COPY WORD. I WANT YOU TO UNDERSTAND THE FUNCTIONALITY, SO I'VE TOLD YOU HOW IT WORKS IN WORD. 

DEVELOPERS DON'T UNDERSTAND WRITERS, WHICH IS WHY I WAS A PROFESSIONAL SENIOR TECHNICAL WRITER DURING THE 90S.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-28 18:59:52 UTC
Hi Cougar,

Can you send in a sample document so that i can open it up in Word and see the outline feature that you wish to be added.

I think LibreOffice does have an outline feature as can be seen at < http://blog.worldlabel.com/2012/outlining-in-libreoffice-writer.html >.
Comment 4 Yousuf Philips (jay) (retired) 2014-06-28 19:01:07 UTC
This link maybe helpful as well < http://askubuntu.com/questions/187814/does-libreoffice-have-an-outline-view-similar-to-microsoft-2010 >. You can access the navigator dialog by pressing F5.
Comment 5 Urmas 2014-06-28 19:06:36 UTC
There are no developers left who are qualified enough to make this kind of code changes. If you need that feature, you have to look elsewhere.

*** This bug has been marked as a duplicate of bug 38262 ***
Comment 6 Cor Nouws 2014-06-28 21:21:39 UTC
(In reply to comment #5)
> There are no developers left who are qualified enough to make this kind of
> code changes. If you need that feature, you have to look elsewhere.


For the record: the above is a quite a misguided opinion.
Comment 7 Cougar Brenneman 2014-06-28 23:16:38 UTC
Created attachment 101945 [details]
Raw brainstorms, organized alphabetically

This document contains my raw brainstorms, organized alphabetically and stripped of organizing features. This is in response to Jay Phillips request. Also coming are screen shots and a final pdf. Wait for them before evaluating.
Comment 8 Cougar Brenneman 2014-06-28 23:18:51 UTC
Created attachment 101946 [details]
Raw brainstorms, organized alphabetically, screen shot.

This is simply so that after playing with the doc file you can still see the original lack of organization.
Comment 9 Cougar Brenneman 2014-06-28 23:20:04 UTC
Created attachment 101947 [details]
Step 2: Created initial headings for sorting in outline view

Here's step two as a screen shot.
Comment 10 Cougar Brenneman 2014-06-28 23:21:05 UTC
Created attachment 101948 [details]
Step 3 as a screen shot. Collapsing a messy outline.
Comment 11 Cougar Brenneman 2014-06-28 23:22:36 UTC
Created attachment 101950 [details]
The entire document is organized and collapsed into outline sections by drag and drop.
Comment 12 Cougar Brenneman 2014-06-28 23:25:53 UTC
Created attachment 101951 [details]
Step 5: I've begun to edit and write, one section at a time.
Comment 13 Cougar Brenneman 2014-06-28 23:26:41 UTC
Created attachment 101952 [details]
The entire docoment, written and ready for the next step.
Comment 14 Cougar Brenneman 2014-06-28 23:39:56 UTC
I've just added the various steps along the way, including the final document as a pdf, which I produced in three hours. I'm not fast enough to do this five page document in three hours without the outliner as demonstrated in the screenshots.

This is not a document that I will use. I wrote it for demonstration purposes. I have more thinking to do before turning it into an app with JS. I may be months away from that. 

I'm not a good enough programmer to produce device ready apps yet. What I produce can only be viewed on a computer. Here's an example of an app I wrote which uses chi energy for Conscious Evolution: http://www.grokwisdom.org/apps/boosting.php

Nonetheless, this is an example of a final destination for my writing. I have so much work to do on the various elements of my project that I can't waste time trying to write stuff using LibreOffice, when I need an outliner to produce material quickly.

I believe that producing the attached five page document without an outliner would have taken me six to eight hours, rather than the three I took with Word.

What I need as a writer is the same as a developer asking for an IDE for efficient programming. What you offer me as a writer is the equivalent to giving me WordPad. Until you create a tool that works efficiently, and allows me to bang out a five-page doc in three hours, I consider it substandard. I can't use it for my work. I'm too busy to waste time trying to monkey around with it. For me, it's just a waste of time to use LibreOffice.

Like I said, my attached pdf doc is not ready to become an app. I was still in the brainstorming, research phase while working on other things. This pdf doc was in the pipeline, but I decided to take it to this next step to provide Jay Phillips with the sample doc he wanted, as well as screen shots that show how I use an outliner to produce the final pdf in three short hours. 

Even if this feature request is a duplicate, I'm reopening it to provide the information that Jay requested and to emphasize that you've been marking such requests as duplicates and then ignoring them for years. 

This means that for me, your product IS LITERALLY UNUSABLE. DO I HAVE SOMEONE'S ATTENTION YET?
Comment 15 Urmas 2014-06-29 00:23:22 UTC
I'm afraid people are not interested what apps you use (or don't use).
LibreOffice is provided "as-is", and if it is inadequate to your tasks, you are free to look for an alternative elsewhere.

*** This bug has been marked as a duplicate of bug 38262 ***
Comment 16 Yousuf Philips (jay) (retired) 2014-06-29 00:54:23 UTC
Hi Cougar,

Thanks for the document and the sample screenshots. I was able to see how outline worked (you learn something everyday right) and tested it in Word 2013 and Kingsoft Writer. While reading over at < http://askubuntu.com/questions/187814/does-libreoffice-have-an-outline-view-similar-to-microsoft-2010 >, i noticed they linked to bug 68167, which was opened by someone approximately a year ago regarding the same feature and was also closed as a duplicate of bug 38262. Bug 38262 has been around for the last 3 years, since the days of LibreOffice 3.5, and unfortunately nothing has happened on it as yet. I would encourage you to visit that bug report and mention that this feature is important to you as a writer and i hope that one of these days it will be looked into.

LibreOffice functions on donations and volunteers, so unfortunately it cant please everyone's needs. I am a volunteer myself and have spent over 10 hours each day for the last month to help improve LibreOffice. I hope that you will consider donating to LibreOffice, as only with money being spent on developers to work on LibreOffice, can more features be constantly added to it.
Comment 17 Cougar Brenneman 2014-06-29 01:13:07 UTC
I actually have mentioned my needs on both of those other feature requests, and my typical experience is that developers are so uninterested in what I need as a writer that they don't even read. Urmas' reply indicates that thinks I was writing about apps I use, rather than apps I write. He clearly didn't pay attention. Of course he's going to dismiss everything I write before even reading it. He made a wrong judgment about me, and there's no communication in a situation like that.

I've explained in detail how an outliner facilitates writing in all three feature requests that you mentioned, and how it's not something that can be used in addition to the word processor one uses. It has to be part of the word processor, or the word processor is useless.

NO, I will not donate to a product that I CAN'T use for my writing.
Comment 18 Yousuf Philips (jay) (retired) 2014-06-29 03:09:08 UTC
I looked through the list of comments in bug 38262, but didnt see any in your name or are you 'Bob' of comment 12. Well if you want a freeware word processor that has this feature, you can try out Kingsoft Writer.
Comment 19 Cougar Brenneman 2014-06-29 14:31:20 UTC
Okay, Jay, I will look into Kingsoft Writer. From online reviews, I can't tell if it's sufficient. I'm still using MS Office 2003, and it works, but I've been submitting comments for a long time. I remember writing to Open Office in several ways in 2001. I used to use the name Don, but I no longer use it. I wasn't Bob.

I've been interested in OO and LO because I felt that Open Source is a good thing. But it frustrates me to be forced to use a non-open source tool because the developers cannot understand the needs of professional users.

I've shown outliner view to many people and have demonstrated it. Once they try it, they tend to be hooked. I think it's a powerful feature that makes gives any writer the capability of having super-powers as a writer. LibreOffice will never be a super product until it has such a super-powers feature. 

I think that the outliner would be more frequently used on any package if it were labeled "Super-Powers View."
Comment 20 Cougar Brenneman 2014-06-29 15:40:40 UTC
Hi, Jay,

I've installed Kingsoft, and you're right. It allows me to continue using my superpowers through outline view. It does not allow me to use my macro superpowers, which means it's also an inadequate  program, but macros are, to be fair, far less valuable and powerful than outline view. 

I'm going away, now. I'm going to stop trying to make LO into a powerful program. Developers here simply don't care about giving their users superpowers. Until MS no longer supports Office 2003, I have everything I need. Later, I'll have to reconfigure  my work routine around Kingsoft, which at least provides me with my accustomed superpowers. Maybe by that time, they'll support macros. 

LO. I'm giving up on you. You're likely to remain substandard forever.
Comment 21 Yousuf Philips (jay) (retired) 2014-06-30 02:32:05 UTC
Hi Cougar,

I've been doing some research about the history of outline view in OO/LO and will be adding it to bug 38262. During that reading, i see how you can achieve outline view with the navigator dialog. All you have to do is set your regular text to one of the heading styles you are not using, i chose 'Heading 10', and then in the navigator dialog, click the 'content view' and then you'd be able to drag and drop items. Let me know what you think. Its not perfect, because when you drag an item, it closes all of the open entries, but i assume that would easier to fix than creating the outline view in the document.
Comment 22 Michael Meeks 2014-06-30 11:22:06 UTC
Urmas - I guess you're trying to stimulate our (perfectly capable) engineers to implement this by telling them they can't do it ;-) I suspect that is unlikely to work. I'd estimate that getting a basic Outline view hacked into the layout code is going to be a couple of man months of work - the problem is as always finding someone willing to donate / pay for that :-)

Cougar - many thanks for your helpful series of screenshots / pieces on this.
Comment 23 Yousuf Philips (jay) (retired) 2014-06-30 14:27:26 UTC
Thanks for chiming in Meeks.

Do you think that it would be easy to make the navigator in content mode not collapse everything after one of the entries are moved?

I read in the dev mailing list on the issue last year that Chris was willing to donate towards the feature, and wondered if he had done so. < http://nabble.documentfoundation.org/http-openoffice-org-bugzilla-show-bug-cgi-id-3959-Outline-view-tp2637237p4027065.html >

(In reply to comment #22)
> I suspect that is
> unlikely to work. I'd estimate that getting a basic Outline view hacked into
> the layout code is going to be a couple of man months of work - the problem
> is as always finding someone willing to donate / pay for that :-)

As a number of users have all expressed interest in this feature, including on the AOO thread < https://issues.apache.org/ooo/show_bug.cgi?id=3959 >, and are willing to donate towards its implementation (ex. Cougar, Chris), wouldnt it be a good idea to evaluate the costs of its implementation and then ask for donations. With that, we could easily show interested individuals how much it would cost and how long it would take for its implementation. Mathias Bauer has previously mentioned that the ground work for multiple layout work has already been done < https://wiki.documentfoundation.org/Outline_view >.
Comment 24 Michael Meeks 2014-06-30 14:51:45 UTC
> I read in the dev mailing list on the issue last year that Chris was
> willing to donate towards the feature, and wondered if he had done so.

When I say two man months as a ball-park; that is around Eur 50k; most "I will pay for it !" claims that I've seen over time have been of the: "Eur 50" ball-park ;-) without an efficient way of aggregating 1000x of these - that's not going to produce any useful result I think. Frustrating but ... that's how it is.
Comment 25 Yousuf Philips (jay) (retired) 2014-06-30 16:42:01 UTC
Thanks for the answer. You have to excuse me as when i read 'couple of man months' i didnt think two, i thought two or more months. :)

Will add your estimates to the main bug, so people visiting it will know the details.
Comment 26 Mike Kaganski 2015-04-27 00:29:28 UTC

*** This bug has been marked as a duplicate of bug 38093 ***