Bug 68742 - FILEOPEN: XML Calc import ignore leading spaces the same way as MSO2003
Summary: FILEOPEN: XML Calc import ignore leading spaces the same way as MSO2003
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
: 80859 115246 (view as bug list)
Depends on:
Blocks: MSO-XML2003
  Show dependency treegraph
 
Reported: 2013-08-30 06:59 UTC by arcfi
Modified: 2018-09-07 11:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (11.47 KB, text/xml)
2013-08-30 06:59 UTC, arcfi
Details
error al abrir archivo xml (93.97 KB, application/xml)
2014-12-29 17:23 UTC, Juan Carlos Cuervo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description arcfi 2013-08-30 06:59:13 UTC
Created attachment 84894 [details]
Test file

XML Calc import should ignore leading spaces in the beginning of the file the same way as MSO2003.
See attachment example, MSO2003 Excel can open it, but LO Calc only gives "General Error. General input/output error."
Comment 1 retired 2013-08-30 09:14:19 UTC
Can confirm described behavior. Excel 2010 opens the file and LO master (Version: 4.2.0.0.alpha0+
Build ID: 9fed8a5e4a4c45d6a08260e9480ca6b43254b120
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-29_07:14:27)
gives general input / output error.

Setting to NEW.
Comment 2 Mike Kaganski 2013-09-23 06:00:40 UTC
According to current XML 1.0 specs (http://www.w3.org/standards/techs/xml), no white space is allowed before the XML declaration.

Microsoft agrees with that, too: see http://msdn.microsoft.com/en-us/library/ms256097.aspx

The fact that LO follows the standard more strictly then a MS product is not a bug. At most, this issue may be a feature request to relax this a bit, but it may be WONTFIX (personally I would vote for this).
Comment 3 arcfi 2013-10-19 05:36:41 UTC
We have a corporate site providing data aggregation service.
It is made to gather data about automobile accidents and road works of North East region of Russian Federation from several filials and contractors.

Data export is implemented to XML format as you can see in the attached example.
I've already contacted to webmaster and asked him to fix the problem, but without any success. Also we have no access to source code of the service.

I understand your standards policy, however migration to LibreOffice is impossible without some backward compatibility.
We want to work with LibreOffice, but this bug is blocking.
I'd appreciate if you make an exception.
Comment 4 ign_christian 2014-07-28 09:44:30 UTC
*** Bug 80859 has been marked as a duplicate of this bug. ***
Comment 5 Juan Carlos Cuervo 2014-12-29 17:23:36 UTC Comment hidden (off-topic)
Comment 6 Juan Carlos Cuervo 2014-12-29 17:24:20 UTC Comment hidden (off-topic)
Comment 7 Mike Kaganski 2014-12-29 22:43:06 UTC Comment hidden (off-topic)
Comment 8 Mike Kaganski 2018-01-26 17:16:23 UTC
*** Bug 115246 has been marked as a duplicate of this bug. ***
Comment 9 Kohei Yoshida 2018-09-07 11:28:35 UTC
The attached file now opens fine.  The fix comes from some of the changes made in the orcus library[1] (in 0.14.0).  I'll resolve this as fixed for 6.2.0.

[1] https://gitlab.com/orcus/orcus