Bug 68743 - Preferences Menue not scrollable on Mac OS X 10.8.2
Summary: Preferences Menue not scrollable on Mac OS X 10.8.2
Status: RESOLVED DUPLICATE of bug 61544
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-30 07:14 UTC by bug.wj
Modified: 2013-09-02 20:02 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Preferences Menue not scrollable, options cut off (264.41 KB, image/png)
2013-08-30 07:14 UTC, bug.wj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bug.wj 2013-08-30 07:14:22 UTC
Created attachment 84895 [details]
Preferences Menue not scrollable, options cut off

The outer frame of the LibO Preferences Menue is not scrollable on Mac OS X 10.8.2.

In very long menue windows, the options located below the normal window size are not accessible. Window cannot be resized to try and access these. Scrollbar is missing.

It's hard to explain, please check attached screenshot, there you can see how the menue is cut off.

Steps to reproduce:

1) Launch LibO
2) Go to preferences
3) Go to Load/Save -> General. Here, it's most obvious, but there are others. E.g. in LibreOffice -> User Data the "Use data for document properties" is slightly cut off.
4) Try to scroll window to access the entries that are cut off

Current behaviour:
There's no scrollbar that would allow to access these entries, they remain cut off. Scrolling does not work.

Expected behaviour:
Scrollbar should be in the outer frame of the window to scroll down, scrolling should work to access these entries.

Best, Wiebke
Comment 1 bug.wj 2013-08-30 07:18:20 UTC
Just noticed that I can't open the attachment in the browser ...
Save Link as ... works for me though. It's a .png file.

If you have problems opening, please tell me and I'll try if saving in another format works.

Best, Wiebke
Comment 2 Adolfo Jayme Barrientos 2013-08-30 20:35:23 UTC
Comment on attachment 84895 [details]
Preferences Menue not scrollable, options cut off

The attachment’s MIME type was set to text/plain, but I’ve fixed it now :-)
Comment 3 retired 2013-08-31 12:51:45 UTC
Hi Wiebke,

thanks for reporting the problem. This seems to work correctly for me with the latest master build.

Version: 4.2.0.0.alpha0+
Build ID: 9fed8a5e4a4c45d6a08260e9480ca6b43254b120
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-29_07:14:27

Also fixed in 4.1.1.2 (http://www.libreoffice.org/download/).

Can you confirm this? If so, I'd say this bug is status "WORKSFORME". If not please re-open.

Also you might want to update your OS to the latest iteration which is 10.8.4. That's what I used for my testing.

Find the master build here to test: http://dev-builds.libreoffice.org/daily/master/MacOSX-X86_64@43/

Concerning the MIME/type of the attachment: that is a known bug with bugzilla not correctly recognizing the attachment and already is filed in an existing bug.
Comment 4 Adolfo Jayme Barrientos 2013-09-01 00:38:12 UTC

*** This bug has been marked as a duplicate of bug 61544 ***
Comment 5 bug.wj 2013-09-02 20:02:58 UTC
Thanks, I'll test with 4.1.1.2

Regarding the OS update: It's a work computer, I'm not allowd to update by myself but have to wait for our computer department to push the new OS :-(

Best, Wiebke