Download it now!
Bug 61544 - UI: Some fields don't fit into Options dialog
Summary: UI: Some fields don't fit into Options dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.1
Keywords:
: 61681 65227 66323 66600 66727 67314 67316 67807 67886 67915 68386 68743 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-02-27 08:38 UTC by Ruslan Kabatsayev
Modified: 2014-08-17 19:33 UTC (History)
17 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (49.37 KB, image/png)
2013-02-27 08:38 UTC, Ruslan Kabatsayev
Details
A number of screenshots of Options dialog and my settings (375.98 KB, application/zip)
2013-03-02 10:15 UTC, HP
Details
screenshot of 4.1 beta 1 on mac osx 10.8.3 (106.15 KB, image/png)
2013-05-26 17:51 UTC, Thomas van der Meulen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Kabatsayev 2013-02-27 08:38:52 UTC
Created attachment 75622 [details]
Screenshot

See screenshot. This doesn't happen in Version 4.1.0.0.alpha0+ (Build ID: 5cd036c0742f8be8d6fc34f7e3a983cae557d94), but does in Version 4.1.0.0.alpha0+ (Build ID: 5e5b7e431edc837b2be32d03fcbb1e32377e935).
This happens with oxygen-gtk, but not with e.g. Glossy or Clearlooks.
Comment 1 HP 2013-03-02 10:14:04 UTC
I have the same issue with Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) on Ubuntu 12.04 LTS x86

Basically, even when I disable using the system font in the options dialog, options overlap. I would really like to be able to resize that dialog.
Comment 2 HP 2013-03-02 10:15:05 UTC
Created attachment 75772 [details]
A number of screenshots of Options dialog and my settings
Comment 3 Jorendc 2013-03-06 11:33:11 UTC
(In reply to comment #1)
> I have the same issue with Version 4.0.0.3 (Build ID:
> 7545bee9c2a0782548772a21bc84a9dcc583b89) on Ubuntu 12.04 LTS x86
Therefore I mark this as NEW

I can't reproduce this behavior using Linux Mint 14 x64 and LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 956c8eed2ca24285d1a19cda2f5f878b3e455ca) (latest commit that is included in my build: Date:   Tue Mar 5 18:31:18 2013 +0000). 
The content bellow that label is shown correctly.
Is this still present in current master versions? 

Kind regards,
Joren
Comment 4 Ruslan Kabatsayev 2013-03-06 20:03:05 UTC
(In reply to comment #3)
> Is this still present in current master versions? 
Still present with Version 4.1.0.0.alpha0+ (Build ID: e8e068770e35dc4f7a5e793732be6ddef96d7ba)
Comment 5 Thomas van der Meulen 2013-05-26 17:51:03 UTC
Created attachment 79811 [details]
screenshot of 4.1 beta 1 on mac osx 10.8.3

options--> load/save --> General
Comment 6 Thomas van der Meulen 2013-05-26 17:52:45 UTC
The options--> load/save --> General  also doesn't fit the screen.  version: 4.1.0.0.beta1
Build ID: 3a2c2d2417101e45fe07cfd8358acf2204a98f3 on Mac osx 10.8.3 
 
See screenshot
Comment 7 retired 2013-06-01 10:13:59 UTC
*** Bug 65227 has been marked as a duplicate of this bug. ***
Comment 8 Thomas van der Meulen 2013-06-21 08:45:21 UTC
*** Bug 61681 has been marked as a duplicate of this bug. ***
Comment 9 mal 2013-07-03 19:43:07 UTC
Does it get worse if you set the scale to something other than 100%
( see bug 66323 ) if so my bug is the same as this and i'll mark it
as such 

M
Comment 10 Ruslan Kabatsayev 2013-07-03 19:48:07 UTC
(In reply to comment #9)
> Does it get worse if you set the scale to something other than 100%
> ( see bug 66323 ) if so my bug is the same as this and i'll mark it
> as such 
> 
> M

Yes, your one indeed looks like a dup.
Comment 11 mal 2013-07-03 20:17:51 UTC
*** Bug 66323 has been marked as a duplicate of this bug. ***
Comment 12 Jorendc 2013-07-04 21:04:32 UTC
*** Bug 66600 has been marked as a duplicate of this bug. ***
Comment 13 Jorendc 2013-07-09 10:08:38 UTC
*** Bug 66727 has been marked as a duplicate of this bug. ***
Comment 14 Miklos Vajna 2013-07-24 07:29:16 UTC
(In reply to comment #3)
> I can't reproduce this behavior using Linux Mint 14 x64 and LibreOffice
> Version 4.1.0.0.alpha0+ (Build ID: 956c8eed2ca24285d1a19cda2f5f878b3e455ca)
> (latest commit that is included in my build: Date:   Tue Mar 5 18:31:18 2013
> +0000). 
> The content bellow that label is shown correctly.
> Is this still present in current master versions? 

Probably you're not using oxygen-gtk? On Linux, this typically affects only users who run KDE, but don't have the KDE VCL plugin installed (i.e. self-built code without any configure options).
Comment 15 sergio.callegari 2013-07-24 08:05:56 UTC
Seems fixed for me in 4.1 RC 3
Comment 16 Ruslan Kabatsayev 2013-07-24 09:34:01 UTC
Still reproducible on 4.1.1.0.0+ (Build ID: be945e8e54a93921a12597c7b3a5b012951600a). Not sure though how it relates to RC versions.
Comment 17 Commit Notification 2013-07-25 11:18:34 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0fcf74d203d97b7e829e72b7e55782d86a048802

Related: fdo#61544 don't include border size twice in edit optimal size



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Caolán McNamara 2013-07-25 13:55:34 UTC
There's a certain amount of relation to theming/platform so different reasons on different platforms/theming. I'd love to make the options dialog calculate the ideal size, but there are *so* many tabs that I fear it would take an age to open the dialog so currently it requests its "traditional" size. 

https://bugs.freedesktop.org/show_bug.cgi?id=63618 should help a lot on MacOSX but its not the complete solution yet
Comment 19 Commit Notification 2013-07-25 15:12:48 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8499e78ca03c792f4fa2650e02b519094ba0baa8

Related: fdo#61544 convert language page from box to grid



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2013-07-25 15:22:17 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c852f83bc4d91de51c61ad4be0edf1b848247eaa

Related: fdo#61544 convert language page from box to grid



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2013-07-25 15:31:35 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=767b02bd7614059dd80d0cd1be306d9b63291f31

Related: fdo#61544 convert save opt page from box to grid



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2013-07-25 15:40:51 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f2fa58f027707254cc6d8f076354787c252a26f

Related: fdo#61544 put help tips checkboxes side-by-side



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2013-07-25 16:45:12 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b64adf65afb1cfe1bd48fed0d71ac333ad962776

Resolves: fdo#61544 improve handling of grid's not enough layout space



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2013-07-25 17:41:57 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab8f39aae069f65a8ebd3cad45d33e2e75426597&h=libreoffice-4-1

Related: fdo#61544 put help tips checkboxes side-by-side


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2013-07-25 17:42:18 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a80828ba6bfa68d3c23af98e2717bb1adc8983e8&h=libreoffice-4-1

Related: fdo#61544 convert save opt page from box to grid


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Caolán McNamara 2013-07-25 19:49:21 UTC
This bug is a grabbag of similar problems. I'll test my final 4.1 extra fix for the layout-enabled cases.
Comment 27 Miklos Vajna 2013-07-26 08:01:14 UTC
Thanks, with oxygen-gtk, the libreoffice -> general is now perfect. impress -> general still problematic, "always with current page" checkbox is visible, but the one below it (that enables sdremote) is almost hidden.
Comment 28 Commit Notification 2013-07-26 08:38:58 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a0fbb8b460114838a1c3fabb57274b04a78d3182&h=libreoffice-4-1

Resolves: fdo#61544 improve handling of grid's not enough layout space


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2013-07-26 10:07:06 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=324fff97a1713625e2def0f973462fb0a11290fb

Related: fdo#61544 lessen height of impress options



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 30 Caolán McNamara 2013-07-26 10:16:01 UTC
So... we have two types of options pages in the options dialog. The new .ui ones and the old fixed layout ones. The options dialog itself is special in that it does not resize, unlike other new layout dialogs, to fit the size of the largest page. That's because there are *so* many options pages that to calculate all of them is risking a large delay.

What I have done here, under this id, is to 

a) readjust some of the new .ui pages to fit nicer, i.e. the "LibreOffice-General" page which should I believe fix Comment #1 (although the screenshot there is not from 4.1.0)
b) make the grid layout cleverer when it runs of of space to try and reduce spacing between elements before falling back to shrinking the elements. That should fix Comment #5

The screenshots of Comment #2 are all of pre-.ui conversion dialogs and options pages from 4.0.X and are so probably unaffected by this series of changes. Some of these have been converted to .ui now and that should improve matters, especially for the free-standing dialogs. If there are remaining problems with non .ui (you can tell because frame titles are not bold text) dialogs/pages then a step towards a solution is to convert to .ui format. That said, the checkboxes and other elements of that theme look super ugly and big. If that is not how checkboxes appear in other applications then file a new bug for that theming error.

Please open new bug for any problems (feel free to put me on cc) not fixed by this patch series instead of reopening this bug because there's a bunch of potentially orthogonal problems to fix.
Comment 31 Jorendc 2013-07-26 19:25:22 UTC
*** Bug 67314 has been marked as a duplicate of this bug. ***
Comment 32 Jorendc 2013-07-26 19:25:49 UTC
*** Bug 67316 has been marked as a duplicate of this bug. ***
Comment 33 Maxim Monastirsky 2013-08-06 06:07:06 UTC
*** Bug 67807 has been marked as a duplicate of this bug. ***
Comment 34 Maxim Monastirsky 2013-08-08 19:30:46 UTC
*** Bug 67915 has been marked as a duplicate of this bug. ***
Comment 35 Michael 2013-08-09 04:11:47 UTC
*** Bug 67886 has been marked as a duplicate of this bug. ***
Comment 36 Urmas 2013-08-21 21:26:20 UTC
*** Bug 68386 has been marked as a duplicate of this bug. ***
Comment 37 Adolfo Jayme 2013-09-01 00:38:12 UTC
*** Bug 68743 has been marked as a duplicate of this bug. ***