Download it now!
Bug 68765 - Requested clipboard format not available when right click on video
Summary: Requested clipboard format not available when right click on video
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Media Clipboard
  Show dependency treegraph
 
Reported: 2013-08-30 18:05 UTC by bugcatcher1
Modified: 2019-06-10 13:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugcatcher1 2013-08-30 18:05:24 UTC
I right click on Adobe video player (11.2.202.297 and others) and select any of these options:
Copy video URL
Copy video URL at current time
Copy embed code
Copy debug info
Copy stats for nerds

When I attempt to paste the information into a word document, I get this message: "Requested clipboard format not available."

I can immediately paste that same information into a text file (gedit) with no problem.

This has been going on for a few years, and has now reach the "need to fix it list", hence this bug report. Upgraded to Version: 4.1.1.2 Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903  with same results.
Comment 1 Joel Madero 2014-07-21 17:51:01 UTC
Confirmed:

Ubuntu 14.04 x64
LibreOffice 4.0.3.2 rc

Steps to Reproduce:
1. Go here: https://www.youtube.com/watch?v=0jVIEZmZV_M
2. While video (or commercial) is playing right click and click "copy video URL"
3. Try to paste into LibreOffice

I've seen this behaviour also when using WestLawNext which is a closed source document viewer for lawyers.

Setting to:
New
Minor - Will not prevent high quality work but can slow you down
Low - no additional comments or similar bugs makes me think the default for minor bugs is appropriate.
Comment 2 Susan Cragin 2015-01-14 18:58:49 UTC
I use Ubuntu Linux and run Dragon NaturallySpeaking with wine. 
I use NatSpeak's "Dictation Box" function to dictate text, and then when I say "Transfer" it puts the text into a buffer. 
This buffer works for every Ubuntu Linux program I have tried except LibreOffice. 
I habitually use EMACS, gedit, Chrome browser, Firefox, e-mail programs, and so on without a problem. 
In fact, I am dictating this right now.
Comment 3 Simon Reed 2015-05-24 18:04:29 UTC
This problem still exists in LibreOffice 4.2.8.2 on Linux Mint 17.1 with Adobe Flash Player 11.2.202.460

If it helps, I think the problem may be Linux-specific and it is also probably Adobe Flash specific.

If so, reports 40176 and 76338 are also related.

The problem I am having is using a similar copy-to-clipboard function on https://www.citethisforme.com/  (It used to work on that web site but they changed it a few weeks ago to Flash and it has not worked since.)  It just makes LibreOffice say "Requested clipboard format is not available.".
Comment 4 QA Administrators 2016-09-20 09:46:10 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920