Download it now!
Bug 76338 - Paste of Adobe Flash Player video URL in Writer while editing causes error
Summary: Paste of Adobe Flash Player video URL in Writer while editing causes error
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste Media
  Show dependency treegraph
 
Reported: 2014-03-18 21:43 UTC by bugcatcher1
Modified: 2019-06-10 13:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot of error (14.52 KB, image/png)
2014-03-18 21:43 UTC, bugcatcher1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugcatcher1 2014-03-18 21:43:10 UTC
Created attachment 96019 [details]
Screen shot of error

Attempting to paste Adobe Flash Player video URL in Writer while editing causes error! Get error saying that "Requested clipboard format is not available."

Steps to reproduce:
1. Go to any webpage with Adobe Flash Player video
2. Right Click on video (while running) 
3. Attempt to paste into LO Writer document.
4. Get this error: "Requested clipboard format is not available."
5. Attempt to paste same information into Gedit (textpad) and voila, there is the information!!

Attached picture: linux/LibreOffice_AdobeFlashPlayer_URL_Video_Paste_Error.png


Running LO Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72

Ubuntu 13.10  AMD Phenom(tm) II X4 810 Processor × 4   x64  8 GB memory
Comment 1 Yousuf Philips (jay) (retired) 2014-05-31 11:55:02 UTC
Confirmed on Linux Mint in 3.6, 4.2.4 and 4.3 beta. It does not effect Windows.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-04 23:07:31 UTC
Tested it in 3.3.0 and same issue so inhereted from OOo.
Comment 3 Björn Michaelsen 2014-08-21 12:21:11 UTC Comment hidden (obsolete)
Comment 4 MM 2015-05-03 13:52:05 UTC
Bug is still there with v4.4.3.2 under mint 17.1.

On windows you can paste the info, because it's set as 'unformatted text'. On linux you can *also* select RTF format. RTF format paste doesn't exist under windows. So when you select RTF with linux, you get this error.
Comment 5 Simon Reed 2015-05-24 18:23:12 UTC
I am having this problem with LibreOffice 4.2.8.2 on Linux Mint 17.1 with Adobe Flash Player 11.2.202.460

I believe reports 40176 and 68765 are related to this one.

The problem I am having is using a similar copy-to-clipboard function on https://www.citethisforme.com/  (It used to work on that web site but they changed it a few weeks ago to Flash and it has not worked since.)  It just makes LibreOffice say "Requested clipboard format is not available.".  It is very annoying when using that web site since the purpose of it is to format text for you; using paste special defeats the object of the web site's function.

As for it existing in v3.3.0, going by a Google search for "Requested clipboard format is not available.", I think it may have also been reported in Star Office 6 in 2002 and oo.o 2.1 in 2007!
Comment 6 Yousuf Philips (jay) (retired) 2015-05-27 19:53:49 UTC
Yes the three have identical info, so the one with the most useful details should be kept and others closed as duplicates.
Comment 7 QA Administrators 2016-09-20 09:45:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920