Bug 68925 - MAILMERGE: mailmerge with txt,csv datasource(office automation)
Summary: MAILMERGE: mailmerge with txt,csv datasource(office automation)
Status: RESOLVED DUPLICATE of bug 80968
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: 85202
  Show dependency treegraph
 
Reported: 2013-09-04 09:51 UTC by domingo.sacristan
Modified: 2015-01-15 12:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
template (20.15 KB, application/vnd.oasis.opendocument.text)
2013-09-04 09:51 UTC, domingo.sacristan
Details
list (8.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-09-04 09:53 UTC, domingo.sacristan
Details
txt list (330 bytes, text/plain)
2013-09-05 12:44 UTC, domingo.sacristan
Details
Screenshoot of the text wrong behavior (192.30 KB, image/jpeg)
2013-09-05 12:46 UTC, domingo.sacristan
Details
Screenshoot of the test right behavior (160.26 KB, image/jpeg)
2013-09-05 12:47 UTC, domingo.sacristan
Details
text mailmerge datasource failure (194.82 KB, image/png)
2014-10-19 15:52 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description domingo.sacristan 2013-09-04 09:51:58 UTC
Created attachment 85180 [details]
template

Problem description: 
Conditions:
- the registered data source list contains only one record
- the data source window is open 

Steps to reproduce:
1. Try to print the document, confirm the question: "Your document contains address database fields. Do you want to print a form letter?"

2. When the Mail Merge window is open the data source table is highlighted but no records appear on records window.

3. No data of merge mail fields will print

The same behavior occur when work with the Mail Merge Wizard by "personalize document"

              
Operating System: Windows XP
Version: 4.1.1.2 rc
Comment 1 domingo.sacristan 2013-09-04 09:53:24 UTC
Created attachment 85181 [details]
list
Comment 2 domingo.sacristan 2013-09-05 12:43:28 UTC
Correction: Sorry the problem occur only with data source from type text(connection to text files). I have make more test with another data source types and the print run correct

Test case 1:
- Create data source from type "text files"
- copy to this folder the new text file example as attachment "testtxt.txt"
- Open Data Source Browser(F4) or Menue: "View-Data Sources"
- insert a few amount of fields into the template
- Try to print this document as form letter
- The record window is empty
- no data will appear on the database fields

Test case 2:
- Create data source from type "text files"
- copy to this folder the new text file example as attachment "testtxt.txt"
- Open Data Source Browser(F4) or Menue: "View-Data Sources"
- insert a few amount of fields into the template
- Close the Data Source Browser
- Try to print this document as form letter
- The record window work correct
- the print is correct
Comment 3 domingo.sacristan 2013-09-05 12:44:48 UTC
Created attachment 85247 [details]
txt list
Comment 4 domingo.sacristan 2013-09-05 12:46:15 UTC
Created attachment 85248 [details]
Screenshoot of the text wrong behavior
Comment 5 domingo.sacristan 2013-09-05 12:47:47 UTC
Created attachment 85249 [details]
Screenshoot of the test right behavior
Comment 6 domingo.sacristan 2013-09-05 12:55:03 UTC
Please take a look, we export frequently data from another applications as txt or csv files and use the mail merge functionality on Libreoffice to create reports similar to the attached template

Thanks!
Comment 7 domingo.sacristan 2013-09-05 13:48:50 UTC
The problem persist on Libreoffice 4.1.2 RC1
in addition to another information:
- By run Test case 1
- if the list contains more as one record, will be the first record of txt data source files ignored by print this document as form letter under the same terms as described
Comment 8 domingo.sacristan 2013-09-20 12:19:28 UTC
The problem persist on Libreoffice 4.1.2 RC2
Comment 9 domingo.sacristan 2013-10-01 12:00:28 UTC
Pleas consider this bug, we work daily with this kind of data source. The problem persist furthermore on Libreoffice 4.1.2 RC3 and the status of the bug is always unconfirmed. If you need more Information you can anytime contact me.

Thanks!
Comment 10 webmaster 2013-10-14 13:06:46 UTC
I confirm this behavior!
Comment 11 Markus Egger 2013-10-14 19:39:27 UTC
I confirm this wrong behavior!
Comment 12 domingo.sacristan 2013-10-18 13:56:19 UTC
Tested too with Libreoffice 4.3.1.1
The wrong behavior persist!
Comment 13 domingo.sacristan 2013-11-04 09:30:45 UTC
Tested too with Libreoffice 4.1.3
The wrong behavior persist!
Comment 14 Knaure 2013-11-04 14:35:14 UTC
This behavior also exists in BASE.  If you open a database table connected to a txt file the first record(s) in the table won't display.  That is, if you open the table after first logging on you might see all the records.  Then if you close the view and reopen the first record will disappear.  If you hit the refresh button while in table view the top record will disappear.  etc.
Comment 15 Alex Thurgood 2014-10-19 14:56:18 UTC
3 independent confirmations ----> confirmed
Comment 16 Alex Thurgood 2014-10-19 15:05:34 UTC
Hmm, on master, OSX Yosemite, I can not even set up a text based ODB file, all of the text files are greyed out in the Finder, even if I coose the semi-colon as field separator in the import options list
Comment 17 Alex Thurgood 2014-10-19 15:12:42 UTC
My problem could well be a different bug, caused by UI rework, testing now on LO 4322

Well, same problem there too, can't even select a txt file to create my ODB file
Comment 18 Alex Thurgood 2014-10-19 15:33:47 UTC
(In reply to Alex Thurgood from comment #16)
> Hmm, on master, OSX Yosemite, I can not even set up a text based ODB file,
> all of the text files are greyed out in the Finder, even if I coose the
> semi-colon as field separator in the import options list

Forget this comment, it clearly says to select folder containing text files, sigh, need more sleep
Comment 19 Alex Thurgood 2014-10-19 15:38:05 UTC
@Domingo : the testtxt file you added only contains one record !
Comment 20 Alex Thurgood 2014-10-19 15:51:42 UTC
@Domingo, testing on master 440 alpha, I see the record in the datasource browser window (pressing F4).


However, pressing Ctrl-P and answering yes to the question asked gives an error message :

The datasource can not be found, check your connection settings.

See attached screenshot. DEo you see this also with LO 4322 ?
Comment 21 Alex Thurgood 2014-10-19 15:52:24 UTC
Created attachment 108065 [details]
text mailmerge datasource failure
Comment 22 Alex Thurgood 2014-10-19 16:01:53 UTC
(In reply to Knaure from comment #14)
> This behavior also exists in BASE.  If you open a database table connected
> to a txt file the first record(s) in the table won't display.  That is, if
> you open the table after first logging on you might see all the records. 
> Then if you close the view and reopen the first record will disappear.  If
> you hit the refresh button while in table view the top record will
> disappear.  etc.

I can't confirm your statement for LO 4322. I used the originally attached text file, this always displays the first record no matter how often I open or close the table mode view
Comment 23 Alex Thurgood 2015-01-03 17:39:38 UTC
Adding self to CC if not already on
Comment 24 Lionel Elie Mamane 2015-01-05 14:23:23 UTC
This smells like bug 80968; please retest with a version where bug 80968 is fixed.
Comment 25 Lionel Elie Mamane 2015-01-15 12:32:34 UTC
assuming it is a duplicate of bug 80968.

If not and you can reproduce on 4.4.0.2 or 4.3.6, reopen.

*** This bug has been marked as a duplicate of bug 80968 ***