Bug 69004 - runtime errror R6025 after closing Help after a few jumps
Summary: runtime errror R6025 after closing Help after a few jumps
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.1.4.2:Win7
Keywords:
: 75901 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-05 22:33 UTC by Horst
Modified: 2014-04-14 20:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Backtrace output (26.07 KB, text/plain)
2014-04-02 20:14 UTC, Horst
Details
BT file from the Dump (11.87 KB, text/plain)
2014-04-04 17:19 UTC, Horst
Details
Dump and Debug file (2.03 MB, application/x-zip-compressed)
2014-04-06 16:33 UTC, Horst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Horst 2013-09-05 22:33:47 UTC
If I invoke the Help from any window in the Options menue and close it (red X) LO crashes with:
Runtime Error
R6025
-pure virtual function call

It started with version 4.0 and is still present in 4.1.1.2.

Clicking on the Debug button from windows does not show any additional info but closes LO.
Comment 1 Horst 2013-09-30 15:31:03 UTC
Getting the same error when jumping in Help a few links. Not only from Menue>Options.
Comment 2 jfjb1 2013-12-27 17:15:12 UTC
Same behavior with LO 4.1.4.2 Windows 7 Pro x64.
I updated from LO 3.6.x... so I can't tell when problem started in between.
Explicit error message says:

MS Visual C++ Runtime library
Runtime Error!
Program: C:\... default installation path ...\ soffice.bin
R6025
-pure virtual function call

Then Windows searches for an answer, doesn't find any, shuts down LibreOffice.

I have MS Visual C++ 2010 x64 (and x86) redistributable 10.0.40219 (1), KB2565063 installed at date of OS initialization on new computer: Feb. 2013.
There are no updates on MS Update site.
What gives?
Thanks for your attention.

JFJB
Comment 3 Horst 2014-02-04 18:59:20 UTC
Bug is still present in LO 4.2.0.4.
Comment 4 Julien Nabet 2014-03-31 18:21:53 UTC
Horst: do you have Java (1.6 or 1.7 but 64 bits) installed?
It seems this could be a workaround.
See fdo#74385 + fdo#76830
Comment 5 Horst 2014-03-31 20:18:59 UTC
(In reply to comment #4)
> Horst: do you have Java (1.6 or 1.7 but 64 bits) installed?
> It seems this could be a workaround.
> See fdo#74385 + fdo#76830

Hi Julien, I have Java 1.7 32-bit installed on Win 7 64-bit.
Comment 6 Julien Nabet 2014-03-31 20:24:53 UTC
For the test, could you also install Java 1.7 64 bits?
Comment 7 Julien Nabet 2014-03-31 20:25:35 UTC
... and give a new try with Help option in LibreOffice of course.
Comment 8 Horst 2014-03-31 20:53:03 UTC
(In reply to comment #7)
> ... and give a new try with Help option in LibreOffice of course.

Nope no luck.
Using LO4.2.2.1, installed Jave 64-bit 1.7.051, restarted PC.
Control Panel Applet shows Java 64-bit.
LO Options>Advanced show Java 32-bit.

Help still crashes :(.

Might this be a weird bug in the C++ compiler?
Comment 9 Julien Nabet 2014-04-01 05:55:11 UTC
Would it be possible you get a backtrace by following this link?
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace
Comment 10 Horst 2014-04-01 17:29:06 UTC
(In reply to comment #9)
> Would it be possible you get a backtrace by following this link?
> https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:
> _How_to_get_a_backtrace

I try my best, but it might take a while.
Comment 11 Horst 2014-04-02 20:14:26 UTC
Created attachment 96808 [details]
Backtrace output

Run the backtrace according to instructions.
Command !analyze -v did not produce any output. I waited about half an hour. The produced output is in the attachment.

Julien have fun or tell me what I did wrong.
Comment 12 Julien Nabet 2014-04-02 20:19:34 UTC
Horst: Sorry I can't help more since I never retrieved a bt with Windows (only with Linux).
Comment 13 Makrea 2014-04-02 21:49:27 UTC
ModLoad: 0d1d0000 0d1d7000   C:\Program Files (x86)\Avanquest\PowerDesk\DClickDesktopHook.dll

Your LibreOffice uses an extension to this program? Try disabling it.


ModLoad: 73850000 738f3000   C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll

Try uninstalling all VC++ packages and install again.


Julien, LibreOffice depends on what VC++ versions?
Comment 14 Makrea 2014-04-02 23:34:45 UTC
Try the ProcDump procedure as-well.
Comment 15 Stanislav Horacek 2014-04-03 09:53:57 UTC
*** Bug 75901 has been marked as a duplicate of this bug. ***
Comment 16 Horst 2014-04-04 17:19:20 UTC
Created attachment 96912 [details]
BT file from the Dump

BT output from WinDBG(x86). Killed the "Extension" which is a seperate prog "Powerdesk".
Could not upload the dump file, it is 7MB big. If you need it we could try it over dropbox.
Comment 17 Makrea 2014-04-06 14:04:16 UTC
Compressing to zip format should lower the size significantly.
Upload the zip with the BT inside.
Comment 18 Horst 2014-04-06 16:33:38 UTC
Created attachment 96993 [details]
Dump and Debug file

Zipping it seems to work.
Comment 19 Julien Nabet 2014-04-06 16:45:39 UTC
(In reply to comment #13)
> Julien, LibreOffice depends on what VC++ versions?
Sorry for the delay.
Quoting this link https://wiki.documentfoundation.org/Development/BuildingOnWindows :
"Compatible Visual Studio versions are 2010 and 2012. (For older branches also 2008 is supported.) Configure will try to use the most recent one. if you don't want, use --with-visual-studio=YYYY to force the version.

If you use an Express version, you will need additional setup. The simple path is to add --disable-atl and --disable-activex. If you need the related features, see Getting ATL work with VS Express
"
Comment 20 Makrea 2014-04-06 16:54:59 UTC
well, i'm guessing that if it is required to build it is required to run.

Why LibreOffice doesn't come with those VC++ Packages?
Sorry if I'm saying some nonsense.
Thanks for the reply.
Comment 21 Julien Nabet 2014-04-06 17:10:42 UTC
Makrea: I'm not an expert but I think it depends on if the libs are built statically (so included in the soft) or dynamically (not included in the soft and so the dlls must be present on the system).

You may find requirements of the different platforms here:
http://www.libreoffice.org/get-help/system-requirements/

Also, since there's no LO 64 for Windows for the moment, only Java 32 bits can be used.

Horst:
- did you install any LO specific extensions?
- for the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give it a new try?
Comment 22 Horst 2014-04-08 01:39:30 UTC
Julien, Makrea: It looks you are on to something with the extensions!

I run a virgin LO (new profile) and could not replicate the bug.

Running the old profile with a few extensions, bug was back. Then I disabled all extensions and the bug was gone.

Will enable one by one and see if I find the culprit.
Comment 23 Horst 2014-04-09 01:05:15 UTC
I found the culprt. Unfortunatly it is AltSearch which I love.

I have the following Extensions installed:
AltSearch
American spelling ...
Compose Special Character
CorelPolyGUI
History Master.

I disabled all and enabled one by one. Only with AltSearch enabld the bug can be replicated.
Comment 24 Kevin Hunter 2014-04-09 01:09:22 UTC
(In reply to comment #23)
> I found the culprt. Unfortunatly it is AltSearch which I love.

> I disabled all and enabled one by one. Only with AltSearch enabld the bug
> can be replicated.

Hmm.  If this bug is truly a duplicate of Bug 75901, then this is not the root cause because I have no extensions installed: mine is a vanilla install from the libreoffice.org provided debs.
Comment 25 Julien Nabet 2014-04-09 05:34:35 UTC
Horst: do you have Altsearch 1.4? According to http://extensions.libreoffice.org/extension-center/alternative-dialog-find-replace-for-writer, this version should be compatible with LO 4.1.X
However, nothing about compatibility with 4.2.X
and I don't find any English version of the website http://mujweb.cz/macrojtb/

Anyway, the problem is triggered by this extension so I'd put NOTOURBUG.
Comment 26 Horst 2014-04-09 14:32:23 UTC
(In reply to comment #25)
> Horst: do you have Altsearch 1.4? According to
> http://extensions.libreoffice.org/extension-center/alternative-dialog-find-
> replace-for-writer, this version should be compatible with LO 4.1.X
> However, nothing about compatibility with 4.2.X
> and I don't find any English version of the website
> http://mujweb.cz/macrojtb/
> 
> Anyway, the problem is triggered by this extension so I'd put NOTOURBUG.

Yes I have 1.4, I also downloaded the latest version and replaced it just to be sure. 

Are the other bugs also related to Altsearch? It is a Writer extension.

Should we tell the author to have a look at his source to fix the problem?
Comment 27 Makrea 2014-04-09 15:50:06 UTC
> Should we tell the author to have a look at his source to fix the problem?

If you like the extension that's a good idea.
Comment 28 Julien Nabet 2014-04-10 18:10:38 UTC
Horst: if you mean "other bugs", the "See also" ones, I don't know for the moment.
I'm gonna suggest the rename of profiling for those in which it's not been proposed yet.

About the extension, I agree Makrea, go ahead and send them an email. You can quote this tracker.
You can also suggest them to contact devs if needed by using the dev mailing list or http://nabble.documentfoundation.org/Dev-f1639786.html
Comment 29 Horst 2014-04-14 16:14:17 UTC
I just installed LO4.2.3.3 (latest Release) and can no longer repruduce this bug.
may be it got fixed by any patch. Can the other "See also" bug be tested with the new version?
Comment 30 Makrea 2014-04-14 20:55:31 UTC
Bug 76830 still happen on this version on a XP Pro SP3 x86 machine.

Regarding the VC++ version that LO 4.2.3.3 wants it is always VC++ 2010.
When the VC++ 2010 is uninstalled LO searches other locations of the drive in search of the msvcr100.dll. Other programs included... I give an example. Imagemagick software includes the VC++ dlls on installation folder. LO tries to use it when doesn't find at system32 folder...

I can prove that by analysing the dump that windows generates when closing the pure virtual function call window.

I had the VC++ 2012 and 2013 installed in the hope that by uninstalling VC++ 2010 LO started to use one of them... It doesn't. Wants only VC++ 2010.