Bug 69181 - EDITING: copy sheet command / ctrl+move_tab renames references
Summary: EDITING: copy sheet command / ctrl+move_tab renames references
Status: RESOLVED DUPLICATE of bug 85538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-10 15:21 UTC by ebricca
Modified: 2017-04-19 09:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ebricca 2013-09-10 15:21:36 UTC
Problem description: 

The context command on the sheet tab "Move/Copy Sheet ..."
makes the reference invalid (=#REF!.A1) 
(example below)

or renames the "reference target sheet" to the one one of the "copy sheet" (=Sheet1.A1 instead of =Sheet2.A1)
(happened to me to a range inside a VLOOKUP unable to reproduce)
or when pressing "ctrl" move_tab with mouse to copy (reproducable but doesn't happen all the time)

noticed in 4.1.0.4 / Windows 7 x64


Steps to reproduce:
1. create Sheet1 and Sheet2 and fill Sheet2 with data (A1)
2. create a reference in Sheet1 ( =Sheet2.A1 )
3. use the "Move/Copy Sheet ..." command mentioned above
4. look in the copied Sheet at the reference

Current behavior:

The Reference gets replaced with =#REF!.A1

or even "=Sheet1.A1" 

Expected behavior:

Should copy the sheet as is 
not manipulate References the way it does now.

Operating System: Windows 7
Version: unspecified
Comment 1 m.a.riosv 2013-09-10 21:20:01 UTC
Hi ebricca, thanks for reporting.

Maybe the problem is that you not are using absolute references, using relative references as you are doing, the formulas in the new sheet are modified for a non existent sheet.
Use;
=$Sheet2.A1
and do the copy, if you want retain the reference to Sheet2.

If you are not used about absolute/relative references, look in the help index for "absolute addresses in spreadsheets" or in the LibreOffice documentation about calc chapter 7 page 13, https://wiki.documentfoundation.org/Documentation/Publications#LibreOffice_Calc_Guide
Comment 2 ebricca 2013-09-11 08:09:04 UTC
(In reply to comment #1)
> Hi ebricca, thanks for reporting.
> 
> Maybe the problem is that you not are using absolute references, using
> relative references as you are doing, the formulas in the new sheet are
> modified for a non existent sheet.
> Use;
> =$Sheet2.A1
> and do the copy, if you want retain the reference to Sheet2.
> 
> If you are not used about absolute/relative references, look in the help
> index for "absolute addresses in spreadsheets" or in the LibreOffice
> documentation about calc chapter 7 page 13,
> https://wiki.documentfoundation.org/Documentation/
> Publications#LibreOffice_Calc_Guide

thanks, you are right "absolute reference" resolves the primary issue

the erratic behavior:

renames the "reference target sheet" to the one one of the "copy sheet" 
=Sheet2.A1
or
=#REF!.A1

where i can't see a rule remains
Comment 3 Kevin Suo 2013-12-05 06:21:03 UTC
This is same issue as Bug 50860 - EDITING: Copy Sheet Moves Formulas.
Marking is duplicate.
Comment 4 Kevin Suo 2013-12-05 06:21:29 UTC

*** This bug has been marked as a duplicate of bug 50860 ***
Comment 5 Timur 2017-04-19 09:14:42 UTC
Duplicate of duplicate.

*** This bug has been marked as a duplicate of bug 85538 ***