Bug 69294 - FILEOPEN: Incorrect Custom Animation Speed
Summary: FILEOPEN: Incorrect Custom Animation Speed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:ppt
Depends on:
Blocks: Custom-Animations PPT
  Show dependency treegraph
 
Reported: 2013-09-12 21:50 UTC by Tom Williams
Modified: 2019-01-11 14:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A PowerPoint presentation that has transitions not reproduced by Impress. (354.50 KB, application/vnd.ms-powerpoint)
2013-09-12 21:50 UTC, Tom Williams
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Williams 2013-09-12 21:50:29 UTC
Created attachment 85743 [details]
A PowerPoint presentation that has transitions not reproduced by Impress.

Problem description: 

Steps to reproduce:
1. Load the attached PowerPoint presentation in Impress
2. Press F5 to start the presentation
3. Click the mouse to advance to the next slide

Current behavior:
The next slide just appears with no transition effect.

Expected behavior:
The next slide should appear with a wipe up transition effect.  The transition appears properly in MS PowerPoint 2007.

              
Operating System: Ubuntu
Version: 4.0.4.2 release
Comment 1 ign_christian 2013-09-13 03:10:35 UTC
Hi Tom, I can confirm that attached file have no transition in "Slide Transition" tab. Tested on LO 3.6.7.2 (Ubuntu 12.04 32bit)

Is that file created with Powerpoint 2007? If that created with LO so it's a filesave problem (which LO version?).
Comment 2 Tom Williams 2013-09-13 14:05:11 UTC
Thanks for the reply.  I first encountered this issue back in 2010, so I forget if I created it in PowerPoint or OpenOffice.  I believe this was sent to me by someone else, so it was probably created in PowerPoint.

Here's the thing:  if I load that same file into PowerPoint 2007, when I click the first slide, the text slides up as expected.  When I do the same in LibreOffice, the text just appears and doesn't "slide" at all.

So, even though LibreOffice doesn't show any transitions when I first load the presentation, MS PowerPoint somehow manages to "find" and use them.
Comment 3 ign_christian 2013-09-14 02:01:20 UTC
I think it's an issue with animation speed, not slide transition. 

I can confirm the behavior within LO 4.0.5.2 (Win7 32bit), effect 'fly in' read with very fast speed. And yes if that opened with PPV 14, we can see that animation moving quite slow.

As far as I remember, I ever saw this issue (about animation speed) reported since this is an old issue. Would you mind do a favor searching that :)
Comment 4 Tom Williams 2013-09-14 14:58:42 UTC
Ok, I'll see what bug reports I can find about animation speed.  The animation speed point you make does make sense.

Thanks!
Comment 5 Tom Williams 2013-09-14 17:48:03 UTC
I did a search on "animation speed" and found several bug reports, none of which document what I've documented in this bug report.  The closest matches were bugs #61370 and #64483.

Peace...
Comment 6 ign_christian 2013-09-15 03:00:15 UTC
Hello Tom.. Thank you for did searching, I also found Bug 51964 which seems to be related.

After playing a bit with direction & speed, then we can set the speed in your file as expected. I also found that animation speed is somewhat different with Bug 51964, so I would have same belief as you that your file is created with Powerpoint. Perhaps this is a fileopen problem in which LO misinterpret animation speed within file created by Powerpoint.  

We can set status to NEW & platform to All since I can also confirm this behavior within Windows.

PS. thanks for confirming my reported bug :)
Comment 7 QA Administrators 2015-04-01 14:42:31 UTC Comment hidden (obsolete)
Comment 8 Tom Williams 2015-04-02 02:27:34 UTC
Ok, I just tried my test case in LibreOffice Impress 4.4.1 on Windows XP SP3.  The slide does advance with a transition effect but it's not as smooth as in MS PowerPoint 2007.  In Impress, the transition goes from top to bottom and in PowerPoint, the transition "wipes" from bottom to top.

Let me know if you need more information.

Thanks!
Comment 9 tommy27 2016-04-16 07:25:21 UTC Comment hidden (obsolete)
Comment 10 Tom Williams 2016-04-24 19:25:16 UTC
Ok, I just tried my test case in LibreOffice Impress 5.1.2 on Windows XP SP3.  The slide does advance with a transition effect but it's not as smooth as in MS PowerPoint 2007.  In Impress, the transition goes from top to bottom and in PowerPoint, the transition "wipes" from bottom to top.

Let me know if you need more information.

Thanks!
Comment 11 QA Administrators 2017-05-22 13:26:53 UTC Comment hidden (obsolete)
Comment 12 Tom Williams 2017-05-25 15:45:09 UTC
I re-tested this in Impress 5.3.3 (64-bit) on Windows 7.  When I click the mouse to advance to the next slide, there's no transition at all.  The next slide just appears.
Comment 13 QA Administrators 2018-05-26 02:42:05 UTC Comment hidden (obsolete)
Comment 14 Tom Williams 2018-05-26 17:10:36 UTC
I re-tested this in Impress 6.0.2 (64-bit) on Windows 7.  When I click the mouse to advance to the next slide, there's no transition at all.  The next slide just appears.

I'll try Impress 6.0.4 this weekend.
Comment 15 Tom Williams 2018-05-29 15:00:22 UTC
I re-tested this in Impress 6.0.4 (32-bit) on Windows 7.  When I click the mouse to advance to the next slide, there's no transition at all.  The next slide just appears.
Comment 16 Roman Kuznetsov 2019-01-11 09:34:04 UTC
I see fine work of animation in

Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Status->WFM
Comment 17 Tom Williams 2019-01-11 14:56:36 UTC
I re-tested this in Impress 6.1.2 (64-bit) on Linux and 6.1.4.2 (32-bit) on Windows 7.  When I click the mouse to advance to the next slide, the transition works as desired.  :)

Thanks for fixing this issue!