Bug 69320 - External Data Link to CSV
Summary: External Data Link to CSV
Status: RESOLVED DUPLICATE of bug 114995
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-13 14:13 UTC by Hungerburg
Modified: 2021-12-23 16:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screencopy showing that we can open a csv file provided by an http website (135.33 KB, image/png)
2013-11-17 20:11 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hungerburg 2013-09-13 14:13:25 UTC
A sheet can be filled with external data from the web:
https://help.libreoffice.org/4.0/Calc/Inserting_External_Data_in_Table_WebQuery

Obviously, data is expected to be an html table, because that works.

It would be nice, if CSV was supported too!

The dialog can already handle csv/text import (hitting enter in the URL input brings up the properties box), yet the "OK" button to make the connection live stays dim.

Kind regards

Peter
Comment 1 Jean-Baptiste Faure 2013-11-16 17:32:09 UTC
How it works if you type the url of the csv file in the field "Load URL" in the standard toolbar? Perhaps you need to activate this "button" to try it.

I do not have such an url to test myself.

Best regards. JBF
Comment 2 Hungerburg 2013-11-17 11:35:46 UTC
For you to test, a link http://dish.myzel.net/lotest.csv

Insert fails, because there are no ranges created in the other box in the dialogue to select from, after the import wizard is done.

The same data as html http://dish.myzel.net/lotest.html shows ranges and only selecting one of those activates the OK button.
Comment 3 Jean-Baptiste Faure 2013-11-17 20:11:47 UTC
Created attachment 89373 [details]
screencopy showing that we can open a csv file provided by an http website

(In reply to comment #2)
> For you to test, a link http://dish.myzel.net/lotest.csv
> 
It works for me if I copy-paste this url in the Load url combobox in the standard toolbar of Calc. Tested on version 4.1.4.0.0+ under Ubuntu 13.10 x86-64.
After having copied-pasted the url, hit the Enter key and wait until the csv dialog import opens. Do the appropriate choices (comma as separator in the case of your example) and validate, you get the same thing as me in the screencopy.

Best regards. JBF
Comment 4 Hungerburg 2013-11-18 18:58:55 UTC
I found the "Load URL" combobox - I had to add it there first. Still, this is not the same, that is just like opening a local file.

"External Data" though remembers the source, and creates a "Links" item in the "Edit" menu, where a refresh can be made.

Again, I suppose the "external data" wizard fails, because csv does not have "ranges".

Kind regards

Peter
Comment 5 Jean-Baptiste Faure 2013-11-21 22:25:01 UTC
You are right. In the case of a csv file you need to use Insert > Sheet From File... and check the checkbox "Link" in the "Insert Sheet" dialog.

Best regards. JBF
Comment 6 Hungerburg 2013-11-22 11:27:55 UTC
Merci bien Jean-Baptiste for your helpful comments, I am learning new things about libre office every time. Yet, again, this too is something different from what this issue is about, a proposed enhancement for reading data from the web.

PS: I am in control of the web service that data comes from, so I just changed the rendering to make LO able to use it. I just stumbled upon the "missing" feature -- If there is a business case, I do not know though; maybe CSV is dead and html tables rule the game nowadays, ms-excel also only can slurp those…

Still, it probably is very cheap to achieve, maybe just have the csv filter populate some internal structure that is left empty now and others, that are not as fortunate as I am, might be helped with it.
Comment 7 Owen Genat (retired) 2013-12-13 11:52:36 UTC

*** This bug has been marked as a duplicate of bug 35040 ***
Comment 8 Xisco Faulí 2021-12-23 16:07:26 UTC

*** This bug has been marked as a duplicate of bug 114995 ***