Bug 114995 - Link to External Data doesn't support Text Import from CSV
Summary: Link to External Data doesn't support Text Import from CSV
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
URL:
Whiteboard: target:6.1.0
Keywords:
: 116299 (view as bug list)
Depends on:
Blocks: HelpGaps Calc-External-Datalink
  Show dependency treegraph
 
Reported: 2018-01-14 07:02 UTC by Dan Dascalescu
Modified: 2018-03-12 14:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2018-01-14 07:02:55 UTC
Description:
This is a more precise description of bug 100993. Trying to import a CSV via Link to External Data appears to work initially, but the user is unable to import data.

Steps to Reproduce:
1. Sheet -> Link to External Data
2. Paste this URL: https://people.sc.fsu.edu/~jburkardt/data/csv/addresses.csv
3. Press Enter per bug  114994
4. Press OK in the Text Import dialog

Actual Results:  
Nothing is available for import.

Expected Results:
The CSV data that was previewed should be imported.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 m.a.riosv 2018-01-15 23:45:42 UTC
Link to external data it's not for import csv files, they are raw text.

You can use Menu/Sheet/Insert sheet from file, keeping the link if you like.

Then it can be updated through Menu/Edit/Link

Even they can be treated as a spreadsheet, referencing it directly.
Comment 2 Dan Dascalescu 2018-01-17 01:39:37 UTC
Miguel, let's try to see things from the user's perspective.

> Link to external data it's not for import csv files, they are raw text.

1. How is the user supposed to know that? Do you think the end user cares about the distinction between CSV and HTML tables? No. The user just wants the data.

2. If "Link to External Data" [is] not for import[ing] CSV files, then why does the Text Import dialog appears after I paste a CSV URL and press Enter in this dialog? If CSV URLs are not supposed to be imported that way, then the dialog should show an error.

3. What if the user wants to import CSV content from a URL? For example Yahoo! Finance offers CSV export - http://www.jarloo.com/yahoo_finance/

> Then it can be updated through Menu/Edit/Link

> Even they can be treated as a spreadsheet, referencing it directly.

That's good for local files, but not for files that change contents and are accessible via a URL, such as Yahoo! Finance exports.

If you really don't think this is a bug, please consider allowing CSV URLs as a feature request.
Comment 3 Xisco Faulí 2018-01-17 09:09:31 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 4 Heiko Tietze 2018-02-16 10:19:58 UTC
We talked about the scope yesterday, and CSV (or txt on general) is not yet implemented but could be loaded with a few changes. 

Since this ticket is about how users get feedback we better discuss the UX issues in bug 114994 (closing as dup).

*** This bug has been marked as a duplicate of bug 114994 ***
Comment 5 Eike Rathke 2018-02-16 21:28:39 UTC
Why duplicate? Let's add CSV support first as a standalone task.
Comment 6 Eike Rathke 2018-02-16 21:28:57 UTC
Taking.
Comment 7 Commit Notification 2018-02-16 21:49:19 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40530d0ce4883ac999d53f86c0483e1a47c9fd74

Resolves: tdf#114995 support CSV as Link to External Data

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko Tietze 2018-02-17 08:44:33 UTC
Nice! Help needs an update now.
Comment 9 Commit Notification 2018-02-22 16:18:48 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=235783d1ed47620748fe297f5ff5133121fbe75e

tdf#114995 CSV Link external data help page
Comment 10 Xisco Faulí 2018-03-12 14:51:58 UTC
*** Bug 116299 has been marked as a duplicate of this bug. ***