Download it now!
Bug 69631 - PDF: MS Graph chart from DOC files not exported to PDF unless clicked in
Summary: PDF: MS Graph chart from DOC files not exported to PDF unless clicked in
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisectRequest, filter:doc, filter:emf, filter:pdf, regression
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2013-09-21 05:21 UTC by Pavel
Modified: 2017-08-29 10:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
An archive with a .doc file that causes the problem and resulting pdf (212.22 KB, application/zip)
2013-09-21 05:21 UTC, Pavel
Details
Diagrams partially exported to PDF with LO 4.2.3.2 on Win (239.90 KB, application/x-force-download)
2014-04-01 12:51 UTC, Timur
Details
Diagrams properly exported to PDF with LO 4.1.5.3 AFTER click in.pdf (45.15 KB, application/x-force-download)
2014-04-01 14:38 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel 2013-09-21 05:21:55 UTC
Created attachment 86227 [details]
An archive with a .doc file that causes the problem and resulting pdf

Problem description: 

Steps to reproduce:
1. Open MS Office .doc file with diagram 
2. Try to export it to pdf
4. Open pdf file in reader
3. There is no diagram in pdf

The same bug when I try to print document on my (laser) printer

Current behavior: diagrams are not exported/printed

Expected behavior: Correct image of diagram in exported pdf

              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 ign_christian 2013-10-11 10:19:00 UTC
I can reproduce with LO 3.6.7.2 (Ubuntu 12.04 32bit).

@Pavel, what kind of image (diagram) in that file? SVG? JPG? EPS ?
Comment 2 Pavel 2013-10-11 10:38:40 UTC
(In reply to comment #1)
> I can reproduce with LO 3.6.7.2 (Ubuntu 12.04 32bit).
> 
> @Pavel, what kind of image (diagram) in that file? SVG? JPG? EPS ?

Sorry, I really don't know. 
I think you need to check MS specifications.

File was created in MS Office 2010(?) then diagram was inserted as shown here http://www.trainingtech.net/how-to-insert-charts-in-word-2010/
and everything was saved in compatibility mode with Office 2003.

That is all that I know. Sorry.
Comment 3 Pavel 2013-10-11 11:38:01 UTC
> @Pavel, what kind of image (diagram) in that file? SVG? JPG? EPS ?


Maybe I am wrong.
I've renamed sample.doc to sample.zip and extract files.
There is a 20kb file with name [3]EPRINT inside which constantly repeats "45 4D 46 2B" == EMF+
Wiki says it is Windows Metafile 
https://en.wikipedia.org/wiki/Windows_Metafile
Comment 4 Timur 2014-04-01 11:15:46 UTC
I tried with LO 4.1.5 and once it looked OK, properly exported, but again with that version and 4.2.3. it's only partially exported, chart is there without labels.
Comment 5 Timur 2014-04-01 12:51:59 UTC
Created attachment 96715 [details]
Diagrams partially exported to PDF with LO 4.2.3.2 on Win

I tried on Windows with LO 4.1.5 and somehow I got it once to look OK, properly exported, but again with that version and 4.2.3. it's only partially exported, chart is there without labels.
I tried on Linux with LO 4.2.1 and it looked OK, properly exported.
So until LO on Windows is confirmed to work properly with this, I change platform to "all".
Comment 6 Timur 2014-04-01 14:38:01 UTC
Created attachment 96729 [details]
Diagrams properly exported to PDF with LO 4.1.5.3 AFTER click in.pdf

I tried on Windows with LO 4.1.5 and 4.2.3 and it's only partially exported, chart is there without labels.
But, if we click in the chart, and Microsoft Graph is open, then export to PDF works fine after that. 

Although this bug started as "Linux only", I tried on Linux with LO 4.2.1 and 4.2.3 and it looks OK, properly exported.
So until LO on Windows is confirmed to work properly with this, I change platform to "Windows".
Comment 7 Timur 2014-10-07 07:54:53 UTC
I change title from "PDF: Diagrams from .doc files are not exported to pdf" to "PDF: Diagrams from DOC files not exported to PDF unless clicked in"
Comment 8 Timur 2014-12-09 13:29:53 UTC
Problem originated in LO 3.6.0 as a regression, because it worked fine in LO 3.5.
When Pavel reported with LO 4.0.2, it was a serious one, because there was no diagram at all. 
Later in LO 4.0.x diagram started to appear in PDF export. But, it's only partially exported, chart is there without labels. If we click in the chart, and Microsoft Graph is open, then export to PDF works fine after that. 
This remained the problem up to LO 3.5.1 and 4.4.0 beta 1. 
In LO 4.4.0 beta 2, file is imported without labels so it's exported to PDF like that!
Comment 9 steve -_- 2016-02-09 10:43:20 UTC
retested. persisting w master. adjusting hardware to all since reported on win and now reproduced on osx.

Version: 5.2.0.0.alpha0+
Build ID: e07ffae5046e9c91ef96026435cab84c3bcb4534
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-02-08_23:39:45
Locale: de-DE (de.UTF-8)
Comment 10 Xisco Faulí 2016-09-20 16:10:33 UTC
Adding keyword 'bibisectRequest' to see whether this regression is already present in the oldest build of bibisect-43all repository or not.
In case it's already present, change 'bibisectRequest' to 'preBibisect'.
Otherwise, change 'bibisectRequest' to 'bibisected' and add a comment with the output from 'git bisect log'
Comment 11 Timur 2017-08-29 10:17:54 UTC
LO 5.3.4 also NOK, 5.4.1 even worse on open and export, but 6.0+ OK. 
I hope it'll stay like that. I'd be good to know where this was fixed.
Of course, it has nothing with EMF-WMF, so I remove that useless block.