Download it now!
Bug 69709 - FORMATTING : pasting format with paintbrush icon deletes the value of the target cell
Summary: FORMATTING : pasting format with paintbrush icon deletes the value of the tar...
Status: RESOLVED DUPLICATE of bug 69450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.2 rc
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-09-23 13:06 UTC by Guillaume Mortier
Modified: 2013-09-28 07:14 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Mortier 2013-09-23 13:06:54 UTC
Steps to replicate :


- enter some values in 2 different cells
- apply some formatting on cell #1
- use the "braintbrush" icon to copy the format of cell #1 to cell #2
- the value of cell #2 is deleted.


New behaviour with version 4.1.2.2
Comment 1 Julien Nabet 2013-09-23 19:34:32 UTC
On pc Debian x86-64 with master sources updated today, I reproduced this problem.

I noticed these logs on console:
warn:i18nlangtag:15678:1:i18nlangtag/source/languagetag/languagetag.cxx:1302: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid 'hu-HU-u8'

warn:vcl:15678:1:vcl/generic/fontmanager/fontconfig.cxx:899: In glyph fallback throwing away the language property of en because the detected script for '0x9f3' is Bengali and that language doesn't make sense. Autodetecting instead.

Eike: with languagetag part, I think you might be interested in this one.
Comment 2 Eike Rathke 2013-09-23 21:57:23 UTC
@Julien:
Unrelated, that code didn't exist in 4.1, but ... anyway, what is the output of locale on your system? 'hu-HU-u8' looks very odd. Any own dictionaries installed that would lead to such a tag? Please send me a mail, no need to clutter up this bug.
Comment 3 Guillaume Mortier 2013-09-24 06:39:16 UTC
I just found another fuzzy behaviour of "paste - special":


try to copy and paste values only (char, numbers, dates) to a cell with some formatting attributes --> those attributes will be deleted.
Comment 4 Jouni Kosonen 2013-09-24 14:12:51 UTC
(In reply to comment #3)
> I just found another fuzzy behaviour of "paste - special":
> 
> 
> try to copy and paste values only (char, numbers, dates) to a cell with some
> formatting attributes --> those attributes will be deleted.

Does the Format Paintbrush share code path with Paste Special? If so, then maybe this is the same as #69450.

Basically, pasting only a subset of attributes no longer preserves the unselected attributes in the target but apparently resets them to the defaults.
Comment 5 Julien Nabet 2013-09-25 20:58:37 UTC
Markus: I put fdo#66646 (a bug you've fixed just today!) in cc. Am I wrong or is this related?
Comment 6 tntrush 2013-09-26 16:25:33 UTC
The same here, just updated from Fedora repositories.

Also, the "delete" button, deletes not only the contents but also the formatting of the cell.
Comment 7 Kevin Suo 2013-09-27 14:11:51 UTC
Reproduced in x64 ubuntu 13.04 LibreOffice 4.1.2.2.

LibreOffice 4.1.2.2 is the first version in which I notice this bug, this behaviour did not appear in previous releases, so I mark this as regression.
Comment 8 Kevin Suo 2013-09-27 14:13:35 UTC
The same issue in x86, so platform -> all; causes data loss, so "critical".
Comment 9 Kevin Suo 2013-09-27 14:24:08 UTC
(In reply to comment #6)
> Also, the "delete" button, deletes not only the contents but also the
> formatting of the cell.

I notice the same behaviour, only in 4.1.2.2.
 * input some text in cell A1;
 * When press "Delete" key from keyboard, not only the cell content but also its formats are deleted. (in previous releases this will only delete the content.)
 * When press "Backspase" key, it asks what to delete. (This is the same as in previous releases, and this is the only way to delete only the content of a cell in 4.1.2.2)

Maybe we should report another bug? or these two issues are relevant?
Comment 10 Markus Mohrhard 2013-09-27 15:51:44 UTC
Fixed in master. Will be pushed to 4-1 and 4-0 soon.
Comment 11 Markus Mohrhard 2013-09-28 07:14:07 UTC

*** This bug has been marked as a duplicate of bug 69450 ***