Bug 69748 - FILEOPEN: LibO shows only first and last page of a 5 pages .doc
Summary: FILEOPEN: LibO shows only first and last page of a 5 pages .doc
Status: RESOLVED DUPLICATE of bug 104425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:doc
Depends on:
Blocks:
 
Reported: 2013-09-24 08:09 UTC by Dmitry
Modified: 2016-12-24 18:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is example file in zip [doc and screenshot] (109.80 KB, application/zip)
2013-09-24 08:09 UTC, Dmitry
Details
PDF print output of test file viewed in MS Word Viewer (99.25 KB, application/pdf)
2014-11-02 09:17 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2013-09-24 08:09:11 UTC
Created attachment 86434 [details]
This is example file in zip [doc and screenshot]

Problem description: 

Steps to reproduce:
1. Open file
2. And now you can see the document. There shows only one page, but should be 2 pages.

              
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Thomas van der Meulen [retired] 2013-09-25 16:26:39 UTC
Thank you for your bug report, I CAN'T reproduce this bug running 
Version: 4.1.2.2
Build ID: 281b75f427729060b6446ddb3777b32f957a8fb 
and 
Version 4.0.5.2 
Build ID: 5464147a081647a250913f19c0715bca595af2f
on Mac osx 10.8.4. 

it always open with 2 pages just like the screen shot shows
Comment 2 Dmitry 2013-09-25 17:06:16 UTC
Hello!

I'll try to explain once again with this video: http://www.youtube.com/watch?v=7BCBXZkj8w0&feature=youtu.be&html5=1
Comment 3 tommy27 2014-11-02 09:16:09 UTC
the test file opened in MS Word Viewer is 5 pages.
the same test file opened in LibO is 2 pages like in screenshot (it shows only first and last which is almost empty) in LibO 4.4.0.0+master, 4.3.3.2 and OOo 3.3.0 as well.

so the issue, which is clearly inherited from OOo, is that pages 2, 3 and 4 are not shown. edited summary notes.
Comment 4 tommy27 2014-11-02 09:17:20 UTC
Created attachment 108789 [details]
PDF print output of test file viewed in MS Word Viewer
Comment 5 Xisco Faulí 2015-09-07 16:06:53 UTC
This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)

I change Importance to High - major as there's a loss of data
Comment 6 QA Administrators 2016-09-20 10:30:00 UTC Comment hidden (obsolete)
Comment 7 Justin L 2016-12-24 17:42:12 UTC
This bug was fixed on Dec 12ish, almost certainly by author Mike Kaganski <mike.kaganski@collabora.com>	2016-12-08 20:01:03 (GMT)
commit 6f5024de2e1a5cc533527e45b33d9a415467c48d
tdf#104425 sw: split rows w/large min height (fix layout loop)

*** This bug has been marked as a duplicate of bug 104425 ***