Bug 104425 - Table cell cannot be split if its minimum height is greater than page available height
Summary: Table cell cannot be split if its minimum height is greater than page availab...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:5.4.0 target:5.3.0.1
Keywords:
: 51691 69748 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-05 23:18 UTC by Mike Kaganski
Modified: 2019-05-20 08:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
A 1-cell table with cell's min height 26 cm (9.26 KB, application/vnd.oasis.opendocument.text)
2016-12-05 23:18 UTC, Mike Kaganski
Details
A PDF that shows how the file looks now (1.89 KB, application/pdf)
2016-12-05 23:21 UTC, Mike Kaganski
Details
A PDF that shows how the file looks if the cell's height is set to 5 cm (expected look) (1.60 KB, application/pdf)
2016-12-05 23:22 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2016-12-05 23:18:55 UTC
Created attachment 129332 [details]
A 1-cell table with cell's min height 26 cm

The attached document contains a table with one cell (Page available height without margins is 25.7 cm; Row height 26 cm; Fit to size; Allow row to break across pages and columns). Inside it there are three smaller 1-cell tables 10 cm height each.

The document contents is not shown properly in LO. It shows an empty first page; then the external table that is clipped on the bottom, with last subtable clipped, too; and then third empty page.

It is expected that there's no empty first page; as the table row is allowed to break across the pages, then the external table should do that and flow to the second page with its last subtable.

This is how it works, if the row height is set to be less than 25.7 cm.

Tested with:
* Version: 5.4.0.0.alpha0+
Build ID: f1ad7ee9f53e2650224eff0eb80ac4d57edb7f4c
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: ru-RU (ru_RU); Calc: CL

* OpenOffice.org 3.3.0
OOO330m20 (Build:9567)
Comment 1 Mike Kaganski 2016-12-05 23:21:18 UTC
Created attachment 129333 [details]
A PDF that shows how the file looks now
Comment 2 Mike Kaganski 2016-12-05 23:22:16 UTC
Created attachment 129334 [details]
A PDF that shows how the file looks if the cell's height is set to 5 cm (expected look)
Comment 3 Buovjaga 2016-12-10 16:34:26 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1fce5b024e9f25c3fcef2537a22474ece0dc416f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 10th 2016
Comment 4 Mike Kaganski 2016-12-10 21:14:32 UTC
A patch in progress: https://gerrit.libreoffice.org/31774/
Comment 5 Mike Kaganski 2016-12-11 12:04:07 UTC
removing "filter" keyword, because it's not a filter, but layout issue; it happens with any file format, e.g. a DOC(X) testcase may be generated using MS Word.
Comment 6 Commit Notification 2016-12-12 08:24:53 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f5024de2e1a5cc533527e45b33d9a415467c48d

tdf#104425 sw: split rows w/large min height (fix layout loop)

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-12-12 20:25:46 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a800eea613c0f5ad3302136766791dc58880fb3&h=libreoffice-5-3

tdf#104425 sw: split rows w/large min height (fix layout loop)

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Mike Kaganski 2016-12-21 20:08:13 UTC
*** Bug 51691 has been marked as a duplicate of this bug. ***
Comment 9 Timur 2016-12-22 17:57:24 UTC
I guess it's fixed, right?
Comment 10 Justin L 2016-12-24 17:42:12 UTC
*** Bug 69748 has been marked as a duplicate of this bug. ***