Download it now!
Bug 69841 - SetDataArray removes direct formatting
Summary: SetDataArray removes direct formatting
Status: CLOSED DUPLICATE of bug 69450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.1 rc
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-09-26 09:23 UTC by pierre-yves samyn
Modified: 2014-02-05 14:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
DataArray.ods including DataArray instruction (13.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-09-26 09:23 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-09-26 09:23:30 UTC
Created attachment 86629 [details]
DataArray.ods including DataArray instruction

Hello

The following statement should only copy the values ​​in the "target" range:

oTargetRange.DataArray = oSourceRange.DataArray

Actually, values are copied but the direct formatting is lost.

Steps to reproduce:

1 Open the attached spreadsheet (DataArray.ods)
2. Allow macros to run and click on the button
"Copy values."

The expected result is to copy the values  from the range A1:E10 to the range A15:E24. 

This "target" range is pre-formatted:
- Direct formatting in column A and E  (borders, background color, number...)
- Style formatting in column C.

After clicking the button the values ​​must be introduced in the range and formats preserved.

Actual result:
With plaform (Windows XP & Version: 4.1.2.1
Build ID: bf15ac65c2167fb1ef3daf3710609d4a4c369a9) copy
values ​​but the direct formatting is lost.

Also reproduced (qa-fr) with Vista-32b and Version: 4.1.2.2
Build ID: 281b75f427729060b6446ddb3777b32f957a8fb 

Last known correct versions : 4.0.5.2 and 4.1.1.2 

This technique is widely used in applications so I select "major" severity even if there is no data loss.

May be related to bug 69720 ?

Regards
Pierre-Yves
Comment 1 Michael Stahl (allotropia) 2014-02-05 11:39:12 UTC
can't reproduce this in 4.1.2.3, and i believe that this fixed it:

commit 9f5228cfbf9c6dde54215f75faccacb28abf67c0
Author:     Michael Meeks <michael.meeks@collabora.com>
AuthorDate: Fri Sep 27 15:59:32 2013 +0200

    fdo#69450 - IDF_ATTRIB & IDF_CONTENTS must be disjoint.

*** This bug has been marked as a duplicate of bug 69450 ***
Comment 2 pierre-yves samyn 2014-02-05 14:00:34 UTC
Hello

(In reply to comment #1)
> can't reproduce this in 4.1.2.3, and i believe that this fixed it:
> 

Verified. I close.

Thank you :)
Regards
Pierre-Yves