Download it now!
Bug 69720 - EDITING: Hitting DEL not only deletes the Cell content, but also removes formatting
Summary: EDITING: Hitting DEL not only deletes the Cell content, but also removes form...
Status: RESOLVED DUPLICATE of bug 69450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.1 rc
Hardware: Other All
: medium major
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA target:4.2.0 target:4.1.3
Keywords: bibisectRequest, regression
: 69756 70082 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-23 16:10 UTC by Helmut Leininger
Modified: 2015-12-17 07:32 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2013-09-23 16:10:06 UTC
Problem description: 

Steps to reproduce:
1. dreate borders for a cell
2. enter something
3. hit DEL key

Current behavior:
border is deleted

Expected behavior:
border should stay

              
Operating System: Windows 8
Version: 4.1.2.2 rc
Last worked in: 4.1.1.2 release
Comment 1 Julien Nabet 2013-09-23 19:36:27 UTC
On pc Debian x86-64 with master sources updated today, I reproduced this.
=> put it at NEW.
Comment 2 Cor Nouws 2013-09-24 08:23:05 UTC
problem somewhere between 4.1.1.2 and 4.1.2.1
Comment 3 Aurimas Fišeras 2013-09-25 09:03:16 UTC
Problem is present in latest LibreOffice too: Version: 4.2.0.0.alpha0+ Build ID: c6dcab339a04c7892765e87b56cf2fb4b3122a08
Comment 4 pierre-yves samyn 2013-09-26 08:54:47 UTC
Hello

Reproduced on windows XP with Version: 4.1.2.1
Build ID: bf15ac65c2167fb1ef3daf3710609d4a4c369a9

Formatting with style is preserved. Only the direct formatting  is lost.

Regards
Pierre-Yves
Comment 5 Markus Mohrhard 2013-09-27 15:44:50 UTC
*** Bug 69756 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2013-09-27 15:52:42 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e2bbf4bc723a9838bb8786908682ea2dd841866

add test case for fdo#69720



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Kevin Suo 2013-09-29 02:29:24 UTC
As I see from this link:
http://nabble.documentfoundation.org/Libreoffice-qa-ANNOUNCE-Tag-libreoffice-4-1-2-3-on-branch-libreoffice-4-1-2-created-td4075544.html
There is a 4.1.2.3 scheduled. So Why not push this to 4.1.2? This is really an annoying bug and a regression.
Comment 8 Markus Mohrhard 2013-09-29 05:58:07 UTC
(In reply to comment #7)
> As I see from this link:
> http://nabble.documentfoundation.org/Libreoffice-qa-ANNOUNCE-Tag-libreoffice-
> 4-1-2-3-on-branch-libreoffice-4-1-2-created-td4075544.html
> There is a 4.1.2.3 scheduled. So Why not push this to 4.1.2? This is really
> an annoying bug and a regression.

The only reason why we have a RC3 is this bug and its many duplicates. This bug should be marked a duplicate of Bug 69450. I talked to Michael and we decided to revert a small part of the earlier patch and fix all problems at once instead of trying to fix all the single problems.

*** This bug has been marked as a duplicate of bug 69450 ***
Comment 9 Cor Nouws 2013-10-03 16:21:34 UTC
*** Bug 70082 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2013-10-04 13:20:36 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=268cb4cff758b556085d7df532e7f8fbce0efd60&h=libreoffice-4-1

compare against IDF_HARDATTR, fdo#69720


It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Robinson Tryon (qubit) 2015-12-17 07:32:17 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]