Download it now!
Bug 69895 - SVG rendering incorrect (primarily placement of elements withing drawing)
Summary: SVG rendering incorrect (primarily placement of elements withing drawing)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 22:56 UTC by Matt
Modified: 2016-11-11 21:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test ODT (79.27 KB, application/vnd.oasis.opendocument.text)
2013-09-27 22:56 UTC, Matt
Details
Test ODT referenced SVG (94.54 KB, image/svg+xml)
2013-09-27 22:57 UTC, Matt
Details
Screenshot from 4.0.5.2 (correct rendering) (146.72 KB, image/png)
2013-09-27 22:58 UTC, Matt
Details
Screenshot from 4.1.1.2 (incorrect rendering) (148.94 KB, image/png)
2013-09-27 22:58 UTC, Matt
Details
SVG as rendered by OS X Finder (10.6.8) (99.84 KB, image/png)
2013-09-27 22:59 UTC, Matt
Details
SVG as rendered by Inkscape (X11 in OS X) (171.08 KB, image/png)
2013-09-27 23:00 UTC, Matt
Details
SVG as rendered by Firefox (23.0.1) (104.75 KB, image/png)
2013-09-27 23:00 UTC, Matt
Details
ODT as rendered in 4.0.5.2 from "Save as PDF" from OS X print dialog (372.57 KB, application/pdf)
2013-09-27 23:02 UTC, Matt
Details
ODT as rendered in 4.1.1.2 from "Save as PDF" from OS X print dialog (67.21 KB, application/pdf)
2013-09-27 23:03 UTC, Matt
Details
ODT as rendered in 4.0.5.2 from native "Export as PDF" (120.23 KB, application/pdf)
2013-09-27 23:04 UTC, Matt
Details
Screenshots showing display of attachments 86742/86743 in various LO versions (668.24 KB, application/zip)
2013-12-08 12:27 UTC, Owen Genat (retired)
Details
osx 10.10.1, LO 4.5 2014-12-16 works fine (189.12 KB, image/png)
2014-12-17 09:52 UTC, retired
Details
5.0.0.5 running on OS X 10.9.5 DOES NOT WORK (283.35 KB, image/png)
2015-08-13 14:51 UTC, Matt
Details
Working screenshot in 2016-11-06 Nightly (153.32 KB, image/png)
2016-11-11 21:03 UTC, eisa01
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt 2013-09-27 22:56:57 UTC
Created attachment 86742 [details]
Test ODT

There appear to be many SVG-related bugs (see, e.g., bug 68682, bug 66901, bug 66930, bug 67039, bug 62254, to name a few). It is quite possible this is a duplicate of one of those (most likely bug 62254).

However, I don't know for certain, and I have a test case, so I'm creating a new bug.
Comment 1 Matt 2013-09-27 22:57:34 UTC
Created attachment 86743 [details]
Test ODT referenced SVG
Comment 2 Matt 2013-09-27 22:58:21 UTC
Created attachment 86744 [details]
Screenshot from 4.0.5.2 (correct rendering)
Comment 3 Matt 2013-09-27 22:58:44 UTC
Created attachment 86745 [details]
Screenshot from 4.1.1.2 (incorrect rendering)
Comment 4 Matt 2013-09-27 22:59:41 UTC
Created attachment 86746 [details]
SVG as rendered by OS X Finder (10.6.8)
Comment 5 Matt 2013-09-27 23:00:15 UTC
Created attachment 86747 [details]
SVG as rendered by Inkscape (X11 in OS X)
Comment 6 Matt 2013-09-27 23:00:57 UTC
Created attachment 86748 [details]
SVG as rendered by Firefox (23.0.1)
Comment 7 Matt 2013-09-27 23:02:23 UTC
Created attachment 86749 [details]
ODT as rendered in 4.0.5.2 from "Save as PDF" from OS X print dialog
Comment 8 Matt 2013-09-27 23:03:07 UTC
Created attachment 86750 [details]
ODT as rendered in 4.1.1.2 from "Save as PDF" from OS X print dialog
Comment 9 Matt 2013-09-27 23:04:57 UTC
Created attachment 86751 [details]
ODT as rendered in 4.0.5.2 from native "Export as PDF"

Note: I was unable to do a native "Export as PDF" from 4.1.1.2 as LibreOffice kept crashing before the export could complete.
Comment 10 Matt 2013-09-27 23:06:58 UTC
I'm not sure how widespread SVG use is, but I'd like to lobby for inclusion of this bug (or at least this symptom) in bug 60270 (most annoying 4.1 bugs) or bug 65675 (most annoying 4.2 bugs) as appropriate.
Comment 11 retired 2013-11-21 11:38:39 UTC
Matt: you provided a lot of info but no exact steps of how to reproduce the bug. Also from your description it is not obvious what the issue at hand is.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 12 retired 2013-11-21 11:42:01 UTC
Pardon my ignorance, your two screenshots (correct and incorrect very clearly answer my question already).

But yet I fail to understand how to reproduce this. When I open your test document with 4.1.3.2 or Version: 4.2.0.0.alpha1+
Build ID: d93433ba1181f5d8f6ded0ed0c103df10ebb1f22
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-20_13:04:00

in both cases all I see is a writer document with a placeholder image and a file URL. So I don't see any image at all.
Comment 13 Matt 2013-11-21 18:55:13 UTC
Foss,

My apologies for not making this more clear. Here's how to reproduce:

1. Download and save the attachment <https://bugs.freedesktop.org/attachment.cgi?id=86742> as "svg_test.odt".

2. Download and save the attachment <https://bugs.freedesktop.org/attachment.cgi?id=86743> as "new_record_procedure.svg".

3. Make sure new_record_procedure.svg is in the same directory as svg_test.odt.

4. Open svg_test.odt.

You should see something like this: <https://bugs.freedesktop.org/attachment.cgi?id=86744>.

You will likely see something like this instead: <https://bugs.freedesktop.org/attachment.cgi?id=86745>.

I have verified this still happens as of release 4.1.3.2.

Hopefully that helps, but if not, lease feel free to kick it back to me. Again, please accept my apologies for making work for you.
Comment 14 Owen Genat (retired) 2013-12-08 12:27:39 UTC
Created attachment 90454 [details]
Screenshots showing display of attachments 86742/86743 in various LO versions

This appears to be a MacOS-build issue. I have opened attachment 86742 [details] (which references attachment 86743 [details]) under Ubuntu 10.04 x86_64 running:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

... and Windows 7 (6.1.7601) running:

- v4.1.2.2 Build ID: 281b75f427729060b6446ddb3777b32f957a8fb

... and MacOS 10.6.8 running:

- v4.1.2.2 Build ID: 281b75f427729060b6446ddb3777b32f957a8fb
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

The Windows and MacOS screenshots are suffixed. As can been seen the reported problem only appears to occur for the MacOS versions.
Comment 15 Owen Genat (retired) 2013-12-08 12:30:54 UTC
As per comment #14, confirmed. Status set to NEW. Given the display under v4.0.5.2 indicated in attachment 86744 [details] I have added the Keyword regression.
Comment 16 retired 2014-12-17 09:52:13 UTC
WORKSFORME

OS X 10.10.1

LO Version: 4.5.0.0.alpha0+
Build ID: 3e17677f705d004ebb87d1268d640da1a1c8cdf4
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-12-16_00:55:19
Locale: de_

Marking as RESOLVED WORKSFORME due the fact we don't know what commit fixed this issue (so not FIXED).

Feel free to reopen this issue if you still can reproduce this particular problem or if I did miss something peculiar.

screenshot attached
Comment 17 retired 2014-12-17 09:52:38 UTC
Created attachment 110943 [details]
osx 10.10.1, LO 4.5 2014-12-16 works fine
Comment 18 Matt 2015-08-13 14:51:41 UTC
Created attachment 117894 [details]
5.0.0.5 running on OS X 10.9.5 DOES NOT WORK

This still appears in 5.0.0.5 running on 10.9.5. @foss, could your observations stem from changes in 10.10.X?

FYI, here's one of the fonts used in the original doc (if it matters):

http://www.dafont.com/digital-strip.font
Comment 19 Buovjaga 2015-10-09 18:34:55 UTC
Not consistent results, but let's set to NEW in any case, as REOPENED is wrong.
Comment 20 Armin Le Grand 2015-11-06 17:35:02 UTC
Executing comment 13 on Win7 with LO 5.1.0.0.alpha1+ shows the placeholder frame with the URL, then shortly text 'read error', lot loading the SVG graphic. Open draw, D&D the SVG -> loads fine, no idea about the read error.
Reproduce:
- new writer
- insert graphic, as link ( box in doalog)
- save, reload
-> same happens.
Short solution: Use edit/links... and break the contained link. Works in orig BugDoc and self-created testdoc.
Comment 21 Julien Nabet 2016-07-03 11:40:28 UTC
I resetted assignee but if you really want to work on a patch about it, don't hesitate to revert my change + change Status to .
Also, it could be interesting to have an update with last stable LO version 5.1.4

Finally, since there are 2 ways to deal with svg in LO, we must distinguish svg problem when open it directly or when we use insert image/object in an existing file.
Comment 22 Matt 2016-07-12 13:34:05 UTC
I'm not sure when or how this got assigned to me. I have no patch to submit (nor do I anticipate working on one).

> Finally, since there are 2 ways to deal with svg in LO, we must distinguish svg problem when open it directly or when we use insert image/object in an existing file.

With respect to my test case (which prompted filing this issue in the first place), the SVG was created using Inkscape, then inserted as an image/object into the ODT.
Comment 23 Buovjaga 2016-07-12 15:20:47 UTC
Matt: so did you test with 5.1.4 yet?

You accidentally set yourself as assignee, check the history: https://bugs.documentfoundation.org/show_activity.cgi?id=69895
Comment 24 Xisco Faulí 2016-09-13 08:33:31 UTC
Adding keyword 'bibisectRequest'.
This regression can be bibisected with http://dev-downloads.libreoffice.org/bibisect/mac/Bibisect_MacOSX10.6%2b_lo-4.1_to_lo-4.2.tar.bz2
Comment 25 eisa01 2016-11-11 21:03:35 UTC
Created attachment 128674 [details]
Working screenshot in 2016-11-06 Nightly
Comment 26 eisa01 2016-11-11 21:06:14 UTC
Fixed by the new layout engine

Version: 5.3.0.0.alpha1+
Build ID: 17e9dc436bc6ad8d3a5bbde15d4d47262650aa2c
CPU Threads: 2; OS Version: Mac OS X 10.12; UI Render: default; Layout Engine: new; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-11-06_01:25:01
Locale: en-US (en_NO.UTF-8); Calc: group