Download it now!
Bug 69914 - UI - Widget Layout implementation incorrectly labeling templates and documents as listed in Thumbnail View panels -- StartCenter and Template manager [Accessibility]
Summary: UI - Widget Layout implementation incorrectly labeling templates and document...
Status: RESOLVED DUPLICATE of bug 73243
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y
  Show dependency treegraph
 
Reported: 2013-09-28 20:34 UTC by V Stuart Foote
Modified: 2016-10-25 19:42 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
JavaFerret List of accessibile roles for Start Center ThumbnailView (38.70 KB, image/png)
2013-09-28 20:39 UTC, V Stuart Foote
Details
JavaFerret List of accessible roles for Thumbnail View for Template Manager (34.29 KB, image/png)
2013-09-28 20:40 UTC, V Stuart Foote
Details
Screnn capture of active Start Center ThumbnailView (87.86 KB, image/png)
2013-09-28 20:41 UTC, V Stuart Foote
Details
Screen capture of active Template Manager Presentation Backgrounds ThumbnailView (122.51 KB, image/png)
2013-09-28 20:43 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2013-09-28 20:34:39 UTC
Thus far, at least on the Windows builds while the UI is graphically correct, the GTK Widget Layout seems to need additional annotation to retain correct UNO Accessibility API roles.

Version: 4.2.0.0.alpha0+
Build ID: 164b6ce7b27c0a9ec19019e7b078b9f8f382007d
TinderBox: Win-x86@39, Branch:master, Time: 2013-09-28_16:39:42 

The GTK Widget Layout implemented for Start Center and Template Manager has some annoying UNO Accessibility API flaws in that the ThumbnailView List correctly names only the first item in the list--and all "descendant" items on the list receive the same "name". And with keyboard cursor key <L,R,U,D> navigation through the list, only the first item will receive focus and update. Each additional list item will not receive focus, nor refresh its "name".
   
Expected result:

As the Thumbnail View list is traversed, correct index is kept, correct role is assigned, and parent name and role are correctly reported.

Someone with a current Linux build of Master should probably check behavior under ORCA and Accerciser. Same for a round with NSAccessibility on OS X with a current build of master.
Comment 1 V Stuart Foote 2013-09-28 20:39:53 UTC
Created attachment 86774 [details]
JavaFerret List of accessibile roles for Start Center ThumbnailView
Comment 2 V Stuart Foote 2013-09-28 20:40:57 UTC
Created attachment 86775 [details]
JavaFerret List of accessible roles for Thumbnail View for Template Manager
Comment 3 V Stuart Foote 2013-09-28 20:41:50 UTC
Created attachment 86776 [details]
Screnn capture of active Start Center ThumbnailView
Comment 4 V Stuart Foote 2013-09-28 20:43:24 UTC
Created attachment 86777 [details]
Screen capture of active Template Manager Presentation Backgrounds ThumbnailView
Comment 5 Jean-Baptiste Faure 2013-11-25 20:41:13 UTC
Typo in the summary
Comment 6 V Stuart Foote 2014-01-04 18:25:24 UTC
closing as duplicate of 73243 -- Thumbnail View in StartCenter and Template Manager not firing focus on List elements with keyboard movements

*** This bug has been marked as a duplicate of bug 73243 ***