Bug 73243 - ACCESSIBILITY: [a11y] Thumbnail View in StartCenter and Template Manager not firing focus on List elements with keyboard movements
Summary: ACCESSIBILITY: [a11y] Thumbnail View in StartCenter and Template Manager not ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: All All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 69914 (view as bug list)
Depends on:
Blocks: a11y mab4.2
  Show dependency treegraph
 
Reported: 2014-01-03 03:21 UTC by V Stuart Foote
Modified: 2016-10-25 19:57 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2014-01-03 03:21:43 UTC
Thumbnail View in StartCenter and Template Manager is not firing focus on List elements during keyboard navigation.

Mouse over events over the Thumbnail UI are now triggering cursor and program focus (resolves major part of Bug 71765).

But keyboard movement focus events are not being fired for the Thumbnail list elements of SC and TM when only keyboard navigation is used. Impacting Accessibility.

Steps to reproduce:

Launch an AT (NVDA, Orca)
Launch a monitoring probe (Accprobe, Accerciser)
Launch LibreOffice
Navigate into the Thumbnail View list of the StartCenter with TAB keys. Use cursor keys to traverse any of the recent documents.  No accessibility focus events are fired.

Alternatively launch the Template Manager and navigate to a populated Thumbnail View  -- e.g. the Presentation tab. TAB onto the Thumbnail View list. Use the cursor keys to traverse any of the template present. No accessibility focus events are fired.

Expected: Navigation between the list objects of the Thumbnail View(s) should generate both cursor and focus events consumable by AT.
Comment 1 V Stuart Foote 2014-01-03 03:48:45 UTC
Behavior on current master, and 4.2.0.1+ builds.

I'm not certain, but I kind of believe this behavior in the Thumbnail View list objects has existed since released for the 4.0.0 cycle--is an accessible role assignment or something similar missing for the list objects?

Against the deadline to do anything for the 4.2.0 release, hope it is something simple.
Comment 2 Cédric Bosdonnat 2014-01-03 08:52:00 UTC
Removing myself from CC: no time to work on these parts anymore.
Comment 3 V Stuart Foote 2014-01-04 18:25:24 UTC
*** Bug 69914 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2014-01-16 02:40:38 UTC
@Tamás ,

One more to add as you review these remaining UI issues for SC and TM.

Keyboard navigation will land on the Thumbnail View list. But the keyboard movements do not trigger a focus event onto the listItem the way that a mouse over event does.

Keyboard movments--<TAB> landing on first item of the Thumbnail list, or cursor <U,D,L,R> should result in a focus event firing for each thumbnail object, and should also trigger the "tool-tip" holding the documents URI.

The mouse over seems the harder to have accomplished. IMHO getting this last major piece in place would complete the A11y puzzle for the Start Center and Template Manager.

Stuart
Comment 5 V Stuart Foote 2014-01-18 17:54:28 UTC
Setting highest and adding to bug mab4.2

This issue is probably cause for bug 72639--Recent documents in the new start center don't send the proper a11y events. Could be merged, or not. But both should resolve when thumbnail view can be corrected.
Comment 6 Jacobo Aragunde Pérez 2014-01-21 16:50:17 UTC
Bug 72639 has been recently fixed. I've been able to test both the StartCenter and the Template Manager with Orca and the document/template names are being properly read now :) .

If you agree, this bug could be closed after a double check.
Comment 7 V Stuart Foote 2014-01-22 19:14:29 UTC
On Windows 7 sp1, 64-bit with
Version: 4.3.0.0.alpha0+
Build ID: 77637324abc193d831bb4a0fa6f9a91ef3601960
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-22_16:19:04

Confirming resolved fixed.