Download it now!
Bug 70097 - Import filter for Korean Hangul Word Processor (HWP) files should detect and reject incompatible versions
Summary: Import filter for Korean Hangul Word Processor (HWP) files should detect and ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.0
Keywords:
: 64486 (view as bug list)
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2013-10-03 19:15 UTC by Ron
Modified: 2016-02-14 17:25 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
This file is a Hangul Word Processor file. I can send many more examples if required. (20.50 KB, application/x-hwp)
2013-10-03 19:15 UTC, Ron
Details
attachment-25922-0.html (1.46 KB, text/html)
2013-10-03 20:26 UTC, Ron
Details
attachment-25922-1.dat (1 bytes, multipart/alternative)
2013-10-03 20:26 UTC, Ron
Details
hangul97.hwp (11.27 KB, application/x-hwp)
2013-10-03 20:26 UTC, Ron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ron 2013-10-03 19:15:49 UTC
Created attachment 87085 [details]
This file is a Hangul  Word Processor file.  I can send many more examples if required.

Problem description: 

LibreOffice will not successfully open newer .hwp (Korean suffix) document files.
I've been able to open older versions of these files.  But the newer versions that I've received from the Korean government or Korean universities only open with unintelligible random characters.


Steps to reproduce:
1.  Launch Libreoffice Writer
2. File/open My_English_history.hwp  <- Hangul Word Processor. I have attached this file with the report.

Current behavior:
File loads only showing random characters. such as "########"

Expected behavior:
Should display correct Hangul Korean Text Characters such as;

My English History
_____반 ____번   이름__________________

1.다음을 읽고 o/x로 답하세요.
1) 난 영어로 간단하게 내 소개를 할 수 있다.(이름, 나이, 출신, 취미...) (  )
2) 난 영어로 할 수 있는 노래가 한 곡 쯤은 있다. (  )
3) 난 알파벳을 쓸 수 있다. (  )
4) 난 처음 보는 단어라도 (거의)읽을 수 있다. (  )
5) 난 짧고 간단한 대화는 듣고 이해할 수 있다. (  )
6) 난 외국인과 그럭저럭 의사소통이 가능하다. (  )
7) 외국인을 보면 무조건 도망간다. 제발 말 걸지 마! (  )
8) 난 영어 문법 책 1권 이상 끝냈어요. ^^  (  )
9) 난 영어를 잘 못하지만 잘하고 싶다.  (  )
10) 난 중학교에 들어와서 영어 공부를 열심히 하고 싶다.  (  )

2. 영어를 교실 밖에서 사용해 본 경험이 있으면 다 써보세요. 쫑알쫑알~



              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Rob Snelders 2013-10-03 19:30:33 UTC
Can you send a version of the same file saved in the old format? And/Or as odt?
Comment 2 Ron 2013-10-03 20:26:50 UTC
Created attachment 87089 [details]
attachment-25922-0.html

I have attached a working .hwp file.



Ron


On Thu, Oct 3, 2013 at 3:31 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Rob Snelders <programming@ertai.nl> changed bug 70097<https://bugs.freedesktop.org/show_bug.cgi?id=70097>
>  What Removed Added  CC   programming@ertai.nl
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Ron 2013-10-03 20:26:50 UTC
Created attachment 87090 [details]
attachment-25922-1.dat
Comment 4 Ron 2013-10-03 20:26:50 UTC
Created attachment 87091 [details]
hangul97.hwp
Comment 5 Rob Snelders 2013-10-04 19:06:22 UTC
It looks to me as there is a "new" hwp-format that we can't read/write.
Problem confirmed
Comment 6 Ron 2013-10-04 19:39:00 UTC
Plese let me know if you need anything else from me.
Happy to help.


On Fri, Oct 4, 2013 at 3:06 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Rob Snelders <programming@ertai.nl> changed bug 70097<https://bugs.freedesktop.org/show_bug.cgi?id=70097>
>  What Removed Added  Status UNCONFIRMED NEW  Ever confirmed   1
>
>  *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=70097#c5> on bug
> 70097 <https://bugs.freedesktop.org/show_bug.cgi?id=70097> from Rob
> Snelders <programming@ertai.nl> *
>
> It looks to me as there is a "new" hwp-format that we can't read/write.
> Problem confirmed
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 7 Commit Notification 2013-10-06 08:51:16 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d2492b2747e4302159eadbc6221ccf153e71b6f

Mention fdo#70097



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Changwoo Ryu 2014-01-07 06:37:50 UTC
*** Bug 64486 has been marked as a duplicate of this bug. ***
Comment 9 Changwoo Ryu 2014-01-07 06:45:33 UTC
The hwp filter in LO is for an old "3.x" format. Newer 5.x format (since 2002) is a different format based on OLE compound document.

I think checking hwp 3.x signature and returning failure is all what this hwp filter can do.
Comment 10 Changwoo Ryu 2014-01-24 12:05:58 UTC
It seems to be "fixed" in LO 4.1.4.2. LO 4.1.4.2 just displays "version incompatibility incorrect file version" instead of corrupted open.
Comment 11 Julien Nabet 2014-08-31 14:06:57 UTC
On pc Debian x86-64 with master sources updated today, LO tries to read it but fails but try to display it.

I noticed these console logs:
Throwing InvalidHeaderException
warn:oox.storage:4358:1:oox/source/helper/zipstorage.cxx:66: ZipStorage::ZipStorage exception opening input storage: 
VisioDocument: version 0
Found xml parser severity error Document is empty
Comment 12 Matthew Francis 2015-04-08 06:21:35 UTC
Raised a new bug 90513 as an enhancement to implement the missing file format(s).

However, that's going to be a large job of work, and I think it would be sensible to detect and reject incompatible file format versions in the mean time - that should be a much smaller job, and can continue to be dealt with on this bug.

(I cannot reproduce comment 10 - on 4.4.2.2/OSX, attachment 87085 [details] continues to import unintelligibly)


The current lack of support is due to a missing feature, and isn't known to cause any other negative effects such as crashes/hangs, so on balance this bug can be an enhancement too.

-> Updated Summary
-> Severity: enhancement
Comment 13 David Tardon 2015-04-08 14:49:18 UTC
This works as expected: any file that is not detected by a specific filter is opened as a text file in Writer, rather than popping a message about an unknown format. You can question the decision to do that, but it is not specific to HWP in any way.