Bug Hunting Session
Bug 70098 - Selecting mutlitple table cells (also rows&cells) in Writer by Ctrl + click
Summary: Selecting mutlitple table cells (also rows&cells) in Writer by Ctrl + click
Status: RESOLVED DUPLICATE of bug 34397
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-03 19:22 UTC by gorgonz
Modified: 2016-12-02 19:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gorgonz 2013-10-03 19:22:59 UTC
env: 400m0(Build:305), opensuse 12.3

Now: It is not possible to select more then one row for further actions (CTRL or SHIFT: and left mouse)

Future: to be able to select rows according to standards( CTRL or SHIFT)

example use case: Wanted to format a table in such a way, that all odd rows have the same definite size s1 and all even rows with the definite size s2.

This is ugly to do at the moment, because you must select one row, use context menu and then height. A dlg will open and you will edit the size value, then ok.

Maybe you can imagine, why this took me about 20 minutes.

With this Enh. it would have taken me less than 1 minute ;-)
Comment 1 Dominique Boutry 2013-10-27 21:34:53 UTC
Reproducted with LibO 4.1.2.3 on Win7 :
- possible with Calc
- not possible with Writer tables
Comment 2 icerabbit 2013-10-29 14:14:01 UTC
LO 4.1.0.4 - Mac OS X 10.8.5

Was going to request the same thing.

I've tried everything I can think of in Writer to make multiple selections:

shift click ctrl click alt click start/option click

I get the dark bold arrow in the left margin, but nothing works to select more than one?

I want to be able to manipulate the text and formatting of multiple cells in entire rows (but not the entire table) in different parts of the table, to be able to fit the entire document on a single page.

As it stands I will need to repeat my actions a dozen times per row type. Rather than make two large alternating selections and do one manipulation for the set. Or batches of brush format copying. (or do some other time consuming thing with defining extra styles ... for a one off document)
Comment 3 Zeki Bildirici 2014-10-15 14:00:17 UTC
I(In reply to icerabbit from comment #2)
> LO 4.1.0.4 - Mac OS X 10.8.5
> Was going to request the same thing.

I've just about to fill another request, the bugzilla search couldn't find similar report. Still missing it on LibreOffice 4.3.2.

I think Shift+ left click works as it is meant to behave (for neighbourcells).

Missing Ctrl+ left click for multiple selection on Writer tables is really annoying thing. 

Also it is not only limited for rows, multiple selection based coloumns so  cells are not possible.

Hope it will be fixed soon. 

Best regards,

- http://ask.libreoffice.org/en/question/21071/select-multiple-cells-of-a-table-in-writer-like-in-calc/ 
- http://ask.libreoffice.org/en/question/24536/writer-how-to-select-several-individual-not-consecutive-rows-in-a-table/
Comment 4 Norbert X 2015-01-31 20:12:23 UTC
It seems that bug is not fixed in

Version: 4.4.0.3
Build ID: 40m0(Build:3)
on Ubuntu Precise Pangolin 12.04.5 with PPA:

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.4.0~rc3-0ubuntu1~precise1
  Candidate: 1:4.4.0~rc3-0ubuntu1~precise1
  Version table:
 *** 1:4.4.0~rc3-0ubuntu1~precise1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.5.7-0ubuntu7 0
        500 http://mirror.yandex.ru/ubuntu/ precise-updates/main amd64 Packages
        500 http://mirror.yandex.ru/ubuntu/ precise-security/main amd64 Packages
     1:3.5.2-2ubuntu1 0
        500 http://mirror.yandex.ru/ubuntu/ precise/main amd64 Packages
Comment 5 Norbert X 2015-08-05 15:30:29 UTC
Bug exists in LibreOffice 5.0 (Ubuntu 12.04.5 with PPA, 1:5.0.0~rc5-0ubuntu1~precise1).
Comment 6 QA Administrators 2016-09-20 10:21:16 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2016-12-02 19:49:30 UTC

*** This bug has been marked as a duplicate of bug 34397 ***