Bug 70289 - Extension update progress bar does not work
Summary: Extension update progress bar does not work
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 113206 (view as bug list)
Depends on:
Blocks: Extension-Manager
  Show dependency treegraph
 
Reported: 2013-10-08 16:59 UTC by Emir Sarı (away)
Modified: 2017-10-18 16:47 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screen capture (174.00 KB, image/png)
2016-03-30 12:06 UTC, laurentlepoittevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2013-10-08 16:59:03 UTC
Hi,

While updating extensions, the download progress bar in extension update window immediately goes 100%, in the background it downloads, but it does not show the progress of the download. 

For testing, you can try it out with the newly 2.3 update of LanguageTool. 

This is reproducible in OS X, have no idea about the other OSs. 

This was reproducible from the first LO version, therefore setting version to 3.3.0.
Comment 1 Rob Snelders 2013-10-11 15:24:01 UTC
Can you please provide also the newest version you tested with?
Comment 2 Emir Sarı (away) 2013-10-11 16:03:30 UTC
Reproducible with 4.1.2.3.
Comment 3 tommy27 2014-04-30 23:05:20 UTC
@Emir San
what about 4.2.x?
Comment 4 Emir Sarı (away) 2014-05-01 11:22:48 UTC
@tommy27,

Still reproducible with 4.2.x.
Comment 5 tommy27 2014-05-01 19:24:05 UTC
would you please attach an old .oxt package so I can install it and try to update on a newer version trying to reproduce that issue?
Comment 6 retired 2014-08-04 18:07:34 UTC
Here are old versions of the LanguageTool extension: https://www.languagetool.org/download/

installed 2.5 under LO 4.3.0.4 OSX 10.9.4
Check for updates in extension manager
find 2.6 update
click "install"
progress bar is at 100% immediately.

Confirmed, NEW
Comment 7 retired 2014-08-04 18:08:43 UTC
wow the longer I look at this, the more confusing it actually is. sitting in front of a full progress bar while nothing happens, update is not finished only cancle update is possible is *very* irritation.

raising importance to "normal" from minor.
Comment 8 QA Administrators 2015-09-04 02:48:30 UTC Comment hidden (obsolete)
Comment 9 laurentlepoittevin 2016-03-30 12:06:24 UTC
Created attachment 123955 [details]
screen capture
Comment 10 laurentlepoittevin 2016-03-30 12:08:40 UTC
Hello everyone,
I confirm the Extension Manager application freezes and no longer responds. But this can sometimes work, I change picture 1.6.4 install once, not grammalectre example.
A report that disabling OpenCL, or Java changes nothing.
libreoffice 5.1.2.1
Comment 11 Muhammet Kara 2016-12-07 13:24:16 UTC
Actually the progress bar works, but not the way you think it does. It shows the status of the whole update progress of all extensions, not the download status of an individual extension. So if you have only one extension to update, you immediately see it as 100%.
Comment 12 Muhammet Kara 2016-12-12 08:22:17 UTC
Could you please check the current behavior?
Comment 13 Alex Thurgood 2017-01-06 09:17:59 UTC
Current behaviour is affected by bug 99784
Comment 14 Xisco Faulí 2017-10-18 08:43:28 UTC
*** Bug 113206 has been marked as a duplicate of this bug. ***
Comment 15 Xisco Faulí 2017-10-18 08:45:20 UTC
(In reply to Muhammet Kara from comment #11)
> Actually the progress bar works, but not the way you think it does. It shows
> the status of the whole update progress of all extensions, not the download
> status of an individual extension. So if you have only one extension to
> update, you immediately see it as 100%.

Hi Muhammet,
Probably a RESOLVED NOTABUG?
Comment 16 sergio.callegari 2017-10-18 09:24:24 UTC
Either I do not understand, or it is utterly unclear how it is meant to work.

> It shows
> the status of the whole update progress of all extensions, not the download
> status of an individual extension.

So, if you have only one extension, the whole update progress of all extensions should be the same as the update progress of that extension, shouldn't it? 

However,

> if you have only one extension to update, you immediately see it as 100%.

Why? Until you have not downloaded it, the extension is not updated. How can the progress be 100% even before the download has begun?

I suspect that the logic you imply is that if you have 2 extensions to update, the application shows the bar at 50% as soon as the download of the first extension starts and at 100% as soon as the download of the second extension starts.

To me, this is just confusing to the user. There are many problems

1) If the downloads are carried out in parallel, then even with 2 extensions to update the bar goes immediately to 100%.

2) Even if the two downloads are serialized, the behavior seems wrong. The bar should jump to 50% when the first extension update is installed (that is has /finished/ download) and to 100% when the second extension has /finished/ installing too.

3) Even better, the bar should track the first download, progressively growing to 50% while the first extension downloads and installs ant then progressively growing to 100% as the second extension downloads and installs.

Please, do not close as RESOLVED, NOTABUG, because even if the progress bar does what it was meant to do, what it was meant to do is not consistent with what users expect from a /progress/ bar.

If it cannot be fixed easily, I strongly suggesting removing the confusing bar altogether and leaving just a visual indication that the user has to wait.
Comment 17 Muhammet Kara 2017-10-18 11:21:32 UTC
Adding Heiko for UX input.
Comment 18 Heiko Tietze 2017-10-18 11:53:11 UTC
The progress bar is pointless when it has only one or two states (50%/100%). We should remove it and just show the hourglass cursor. 

Of course the better solution is to take the total bytes to download plus the time to install into account and have a real progress bar. But even better is to not bother the user with technical details and just inform after the upgrade has been done.

By the way, the extension management could be improved on more aspects: https://design.blog.documentfoundation.org/2016/11/11/additions-to-libreoffice/
Comment 19 sergio.callegari 2017-10-18 16:47:54 UTC
> The progress bar is pointless when it has only one or two states (50%/100%).

Even worse than that. It has states that are reached /before/ the slow phase of a long-lasting action is completed rather than /after/ it, as it would be expected.

> We should remove it and just show the hourglass cursor

Agreed, until a better solution can be implemented.

> Of course the better solution is to take the total bytes to download plus the time to install into account and have a real progress bar.

Agreed. Probably the total bytes to download would be more than enough.

> But even better is to not bother the user with technical details and just inform after the upgrade has been done.

The issue here is that there are some extensions that are really quite large. E.g.  LanguageTool is 76 MB. On a slow connection their download can take several minutes. Hence, some form of visual feedback that something is going on is really needed.