Bug Hunting Session
Bug 70500 - EDITING: Selecting with Shift+PageUp/PageDown is not working
Summary: EDITING: Selecting with Shift+PageUp/PageDown is not working
Status: RESOLVED DUPLICATE of bug 94679
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisectRequest, regression
: 90992 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-15 16:12 UTC by Zoltán Hegedüs
Modified: 2016-06-23 11:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test of PageDown key (29.98 KB, application/vnd.oasis.opendocument.text)
2013-10-28 09:21 UTC, Dominique Boutry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Hegedüs 2013-10-15 16:12:44 UTC
If I start the selecting a part of text with Shift+PageUp/PageDown, it manages only when I press the PageUp/PageDown key only 1 time. If I press again, the selection disappears as I should unbend the key Shift, but the key Shift was keeped pressed continuously. I can continue the selection with the 4 cursor keys. If I start the selection with one of the 4 cursor keys, and later I switch to PageUp/Pagedown (while I am keeping pressed the key Shift continuously), the result is the same, as I should unbend the key Shift, the selection disappears.

This error happened in an older version, I do not remember the version number (3.5 or 3.6), and then corrected. The error come back (appeared again).
Operating System: Windows XP
Version: 4.0.5.2 release
Comment 1 Dominique Boutry 2013-10-28 09:21:14 UTC
Created attachment 88218 [details]
Test of PageDown key
Comment 2 Dominique Boutry 2013-10-28 09:33:21 UTC
I noticed a behaviour with PageDown key (without any selection) which may be underlying to the present bug case. When I press successive PageDown key on the attachment 88218 [details], I see 2 cases :
- either the press causes both a scroll and a movement of the caret relative to the text,
- or the press causes only a scroll (the caret remains tighten to the same text character, it may be hiden or not, after that).

Now in conjunction with the area selection : Shift + PageDown key causes :
- a visible growing of the selected area,
- a simple scroll without growing of the selected area, its bottom remaining visible,
- a simple scroll and the bottom of the selected area becoming hiden, eventually making the user think that the whole selection has gone.
Comment 3 QA Administrators 2015-04-01 14:40:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 4 Buovjaga 2015-04-21 16:31:49 UTC
Reproduced with master Win & Linux.

NOT reproduced with 3.5 OR 3.6, so regression.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.5.0.0.alpha0+
Build ID: afb82d3729bda2754d0add08cc6c4dce1dc76d59
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-14_00:05:04
Locale: en_US

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

Version 3.6.7.2 (Build ID: e183d5b)
Comment 5 Buovjaga 2015-05-01 18:05:36 UTC
*** Bug 90992 has been marked as a duplicate of this bug. ***
Comment 6 Cor Nouws 2015-05-03 14:05:16 UTC
I can reproduce this in Version: 5.0.0.0.alpha1+
Build ID: ec7f227f90fbdd0bd17c0b885a832e6408106deb
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-28_12:54:35
Locale: nl_NL.UTF-8

I can not reproduce this in Versie: 4.4.3.2 
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: nl_NL 

..
Comment 7 Joel Madero 2015-05-11 19:27:12 UTC
One important caveat to this issue is that you must go slow - if you rapidly push pg down then it works fine.

In terms of a bibisect - this one is crazy as it appears throughout 44max, but not in 35all...I thought he packages overlapped but maybe there's some range of commits that are not covered?

cc'ing Robinson to get his input - might not be bibisectable.
Comment 8 Robinson Tryon (qubit) 2015-12-14 05:33:49 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]
Comment 9 Justin L 2016-06-23 11:07:19 UTC
fixed in 4.4.6 / 5.0.4 / 5.1

*** This bug has been marked as a duplicate of bug 94679 ***