Bug Hunting Session
Bug 70547 - Other: Formula base character size is not choosable by Writer document
Summary: Other: Formula base character size is not choosable by Writer document
Status: RESOLVED DUPLICATE of bug 32419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-16 19:26 UTC by Zoltán Hegedüs
Modified: 2014-08-28 11:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Hegedüs 2013-10-16 19:26:24 UTC
I can not set the base character size of the mathematic formulas by Writer document: I can set the size of a concrete formula, or all new formulas, but I can not set different base sizes for different Writer documents for the new formulas. For example, I want if I open the file noname10.odt, the size of the new formulas will be 10 in this file, and if I open the file noname11.odt, the size of the new formulas in this file will be 11.
Operating System: Windows XP
Version: 4.0.5.2 release
Comment 1 Dominique Boutry 2013-10-23 16:33:42 UTC
The MATH user's guide states (§ Changing the appearance of formulas > Changing the font size) that there is a current value (for the formula being edited and the new formulas to create) and a default value (global ; see the note "Don't forget to revert it back to its original value when the work is finished" !).

A default value "by Writer doc" would be great. An enhancement, not a bug.
Comment 2 Zoltán Hegedüs 2013-10-23 20:32:06 UTC
I set the importance from normal to enhancement, and the status to new.
Comment 3 Owen Genat (retired) 2013-11-13 04:43:22 UTC
This would seem related to bug #32419, which is an enhancement to have a formula initially obtain the base character size from the paragraph in which it is anchored.
Comment 4 Owen Genat (retired) 2013-11-13 05:09:24 UTC
Actually, bug #33827, which is an enhancement to implement styles for formula may more likely be related. Both bugs I have linked provide similar examples in their description, but appear to be different approaches to solving the same problem i.e., allowing the user to style all existing and new formula in a simple (single action) manner.
Comment 5 Owen Genat (retired) 2013-12-09 02:40:44 UTC
Bug 67373 is likely also related, although I do grant that the report here is more specific in the request of a per-document setting. Version set to Inherited From OOo as this functionality has never existed. Platform set to All/All.
Comment 6 Owen Genat (retired) 2014-01-06 10:25:42 UTC
Setting version back from "Inherited From OOo" to what it was prior (for bugs marked enhancement), for QA tracking purposes. My mistake. Apologies.
Comment 7 Owen Genat (retired) 2014-08-28 11:32:02 UTC

*** This bug has been marked as a duplicate of bug 32419 ***