Bug 70624 - index order depend on the screen zoom and on chapter position
Summary: index order depend on the screen zoom and on chapter position
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5 all versions
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2013-10-18 16:14 UTC by gioni
Modified: 2019-01-26 13:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
writer doc created with styles (32.32 KB, application/vnd.oasis.opendocument.text)
2013-10-18 16:14 UTC, gioni
Details
text created with styles (32.32 KB, application/vnd.oasis.opendocument.text)
2013-10-23 16:59 UTC, gioni
Details
heading in header (10.58 KB, application/vnd.oasis.opendocument.text)
2015-07-02 00:14 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gioni 2013-10-18 16:14:58 UTC
Created attachment 87829 [details]
writer doc created with styles

I noticed 2 problem on my text created with styles.
- try to bring chapter 1.1 one level up (also 2.1 and 3.1 if you want). Update index. Index order will change.  

- try to change screen zoom and the update index. Index order will change. Try to change screen zoom till to have 6 or 8 page on the screen... and see the result.
Comment 1 gioni 2013-10-22 06:54:18 UTC
up
Comment 2 gioni 2013-10-23 16:59:29 UTC
Created attachment 88045 [details]
text created with styles
Comment 3 sophie 2013-10-31 10:36:56 UTC
Hi Gioni, I can't reproduce your problem and noticed that Manual:CAPITOLO has no hierarchical style applied (and hence there is no style with level 1) so it may be your first problem. Changing the zoom didn't change the Index too for me - Sophie
Comment 4 gioni 2013-10-31 11:34:05 UTC
Hi Sophie,
thank you for your reply. This problem is booring me from at least 3-4 year...
By the way, 
1- I achieved this result (index order) after several attempts because I have no full knowledge of LO. I will study the problem more deeply.
2- After you change zoom level, you must upgrade index.  

bye
Comment 5 Commit Notification 2013-12-30 13:21:51 UTC Comment hidden (off-topic)
Comment 6 Björn Michaelsen 2014-01-17 00:43:54 UTC Comment hidden (obsolete)
Comment 7 Joel Madero 2015-05-02 15:43:41 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-06-21 12:16:26 UTC
Never confirmed (Miklos's commit references this mistakenly).
Is this still a problem in 4.4 or 5.0?

Set to NEEDINFO.
Change to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 9 gioni 2015-07-01 17:01:04 UTC Comment hidden (obsolete)
Comment 10 gioni 2015-07-01 17:11:33 UTC
sorry for my previous answer... didn't check the problem issue with the chapter position. 
This problem still persist in 4.4.4 and in 5.0.0.2 too.
The index zoom related problem instead has been solved.
Comment 11 Gordo 2015-07-02 00:14:34 UTC
Created attachment 116979 [details]
heading in header

I thought the columns might have contributed to the out-of-order headings in the Navigator, but I have reduced it to the outline numbering Level 1 style being in the header.

In the attachment, the table of contents is correct, but if you remove the empty paragraphs before “Test 1.1” and “Test 2.1”, and update the table of contents, then it will be incorrect.

The Navigator shows the headings in the wrong order regardless of there being the empty paragraph or not.

Windows Vista 64
Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Comment 12 Buovjaga 2015-07-02 08:24:48 UTC
NEW per comment 11.
Comment 13 Justin L 2016-12-26 14:56:45 UTC
confirmed still a problem with LO5.3beta2 and Ubuntu x64
used bibisect43all oldest to confirm that it has always existed: notBibisectible

Steps to reproduce using document from comment 11:
-ctrl-click on Test 1.1 in the index and remove the extra CR. Now Test 1.1 is the first paragraph on the page (with Test1 in the header)
-go back to the index, right-click and choose update-index.
-notice that the order of test1.1 and test1 have switched.
Comment 14 QA Administrators 2017-12-27 03:25:02 UTC Comment hidden (obsolete, spam)
Comment 15 Justin L 2019-01-12 08:35:04 UTC
re-confirmed with 6.3 master.