Download it now!
Bug 70674 - EDITING: Wizard for forms couldn't create a form with timestamp-field except arrangement "Data Sheet"
Summary: EDITING: Wizard for forms couldn't create a form with timestamp-field except ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.1.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.2.0 target:4.1.4
Keywords:
: 72876 (view as bug list)
Depends on:
Blocks: 71027
  Show dependency treegraph
 
Reported: 2013-10-20 14:41 UTC by Robert Großkopf
Modified: 2016-05-10 00:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Try to create a form for the table with the wizard - deselect the normal arrangement "Data Sheet" (3.38 KB, application/vnd.oasis.opendocument.base)
2013-10-20 14:41 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-10-20 14:41:48 UTC
Created attachment 87880 [details]
Try to create a form for the table with the wizard - deselect the normal arrangement "Data Sheet"

Try to create a form with the form-wizard for a table with a timestamp-field. Since LO 4.1.1.1 it is only possible, when you don't change the arrangement of the form "As Data Sheet". 
When you chose another arrangement 
- the timestamp-field is shown as one field
- the timestamp-field is very small (also a date- or a time-field, but it's not this bug).

You could only see this since LO 4.1.1.1 All LO 4.* -versions before don't show the changes of the arrangement before finishing the wizard.

When you try to finish the wizard the wizard doesn't execute. You could only cancel the wizard or create the form without the timestamp-field.
Comment 1 Lionel Elie Mamane 2013-10-29 19:20:06 UTC
Fixed half of it in my development tree... Weird problem remaining where the date & time controls don't get the right background colour applied because the weak reference to a FmFormObj held by the SvxShape is gone... I can't for the life of me find out who is supposed to hold it (and who does in the case of a formatted text)...
Comment 2 Lionel Elie Mamane 2013-10-30 04:41:47 UTC
(In reply to comment #1)
> Weird problem remaining where the date & time controls don't get the right
> background colour applied

I'm forking that one into a different bug. Fix for "first half" pushed to
master, backport requested at https://gerrit.libreoffice.org/6482
Comment 3 Commit Notification 2013-10-30 04:48:08 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f374ac73f8789aa6daa16969ebb25e2803373f8

fdo#70674 adapt wizard code to incompatible Date/Time API change



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2013-11-03 10:29:50 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=148770af39a82f52a5d267e40941684791df4c66&h=libreoffice-4-1

fdo#70674 adapt wizard code to incompatible Date/Time API change


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Christian Lohmaier 2016-05-10 00:24:37 UTC
*** Bug 72876 has been marked as a duplicate of this bug. ***