Download it now!
Bug 70859 - Other: Error saving file to a Vnxe 3100 SAN in NAS CIFS mode
Summary: Other: Error saving file to a Vnxe 3100 SAN in NAS CIFS mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.0 target:4.1.4
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-25 10:08 UTC by Olivier MORIN
Modified: 2013-11-29 19:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Error messages in french (17.31 KB, application/zip)
2013-10-25 10:08 UTC, Olivier MORIN
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier MORIN 2013-10-25 10:08:14 UTC
Created attachment 88105 [details]
Error messages in french

Problem description: Error saving file to a Vnxe 3100 SAN in NAS CIFS mode

Steps to reproduce:
Install Librofice 4.x
Create a document in a share folder on a Vnxe3100
Modify it
Save it
After 1 or to oepartion, errot message and file is locked
Tested in the same envirronement with Openoffice 4 : OK
             
Operating System: Windows 7
Version: 4.0.5.2 release
Comment 1 Julien Nabet 2013-10-25 21:04:05 UTC
Olivier: just for the test, could you give a try to pre release 4.1.3? (see http://www.libreoffice.org/download/pre-releases/)
Comment 2 Olivier MORIN 2013-10-28 09:14:08 UTC
(In reply to comment #1)
> Olivier: just for the test, could you give a try to pre release 4.1.3? (see
> http://www.libreoffice.org/download/pre-releases/)

Bonjour,

4.1.3.1 installed this morning, same problem.
Comment 3 Julien Nabet 2013-10-28 10:19:22 UTC
Michael: do you know who may help here?
BTW, quick translation of error messages:
Error during saving of the document ..., access denied
then
IO Error for second screenshot.
Comment 4 Maxim Monastirsky 2013-10-28 11:14:57 UTC
Looks like a duplicate of Bug 68082 (see especially Bug 68082 comment 4), which might be in turn caused by the same cause as (the recently fixed) Bug 67534.

@Olivier MORIN: Could you please run LibreOffice installation, choose 'Modify' and uncheck the installation of Windows Explorer extensions? Does it solve your problem?
Comment 5 Olivier MORIN 2013-10-28 13:12:40 UTC
Yes after unsinstalling this extenion it is OK.

I have installed the libreoffice-4-1~2013-10-25_22.57.18_LibreOfficeDev_4.1.4.0.0_Win_x86 and it is also OK.
Comment 6 Maxim Monastirsky 2013-10-28 13:19:06 UTC
(In reply to comment #5)
> I have installed the
> libreoffice-4-1~2013-10-25_22.57.18_LibreOfficeDev_4.1.4.0.0_Win_x86 and it
> is also OK.
Did you install it from the command line with 'WRITE_REGISTRY=1'? If not it's irrelevant, because dev buils don't write the appropriate registry values by default.

Anyway I'm able to reproduce this bug using 4.1.3.1 with a simple Windows 7 share. Uninstalling shell extensions solves the problem.
Comment 7 Olivier MORIN 2013-10-28 13:53:31 UTC
Yes i did !
Comment 8 Julien Nabet 2013-10-28 13:58:10 UTC
Maxim: first thank you for the help here.
About fdo#67534, the fix is present from 4.1.4 not 4.1.3 so it's normal you can reproduce the problem with 4.1.3
Comment 9 Maxim Monastirsky 2013-10-28 15:20:19 UTC
(In reply to comment #8)
> About fdo#67534, the fix is present from 4.1.4 not 4.1.3 so it's normal you
> can reproduce the problem with 4.1.3
Yes I know, just wanted to prove that it's related to shell extension.

What we have now: Olivier MORIN confirmed that it's fixed in 4.1 dev build. I can also confirm the same for several master builds, the oldest one is from 2013-10-15_15:51:52. master build from 2013-10-10_06.40.14 still had that bug. The fixes for Bug 67534 were pushed at 10-11 & 10-14. So it's resonable to assume that it's indeed a duplicate. Closing as RESOLVED FIXED.