Download it now!
Bug 70955 - Problem with printing (exporting to pdf) WMF images pasted from MS Excel
Summary: Problem with printing (exporting to pdf) WMF images pasted from MS Excel
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2013-10-28 12:21 UTC by PITRider
Modified: 2019-05-14 09:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
original file (64.62 KB, application/vnd.oasis.opendocument.text)
2013-10-28 12:21 UTC, PITRider
Details
pdf created in linux (2.58 MB, application/x-7z-compressed)
2013-10-28 12:24 UTC, PITRider
Details
pdf created in windows (1.09 MB, application/x-7z-compressed)
2013-10-28 12:24 UTC, PITRider
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PITRider 2013-10-28 12:21:13 UTC
Created attachment 88225 [details]
original file

Problem with printing (exporting to pdf) objects pasted from MS Excel
Comment 1 PITRider 2013-10-28 12:24:00 UTC
Created attachment 88226 [details]
pdf created in linux
Comment 2 PITRider 2013-10-28 12:24:29 UTC
Created attachment 88227 [details]
pdf created in windows
Comment 3 Joel Madero 2014-07-21 01:51:35 UTC
@PITRider - we need:

1. Reproducible steps (exact steps)
2. Your computer information (OS and LibreOffice version)

You say "printing" but then you say "exporting to pdf" - these are completely different. Make sure to be clear on what you mean, are you printing to file (thus creating a pdf) or exporting to pdf (which uses entirely different code in LibreOffice)

Marking as NEEDINFO - once you do step 1 and 2 please set to UNCONFIRMED. Thanks and sorry for the long delay
Comment 4 PITRider 2014-07-21 07:52:46 UTC
(In reply to comment #3)
> @PITRider - we need:
> 
> 1. Reproducible steps (exact steps)
> 2. Your computer information (OS and LibreOffice version)
> 
> You say "printing" but then you say "exporting to pdf" - these are
> completely different. Make sure to be clear on what you mean, are you
> printing to file (thus creating a pdf) or exporting to pdf (which uses
> entirely different code in LibreOffice)
> 
> Marking as NEEDINFO - once you do step 1 and 2 please set to UNCONFIRMED.
> Thanks and sorry for the long delay

OS: Windows XP (sp2,sp3)
LibreOffice: 4.2.5.2

LO freezes with this odt file
print (on paper or virtual printer) and export to pdf produce the same result
Comment 5 Buovjaga 2014-11-04 10:27:49 UTC
I confirm.
The result is nearly identical both with printing to PDF and exporting.
On exporting, the cells with vertical text on the 1st page have more text visible than when printing. My PDF export has text visible in three more cells compared to PITRider's Windows export.

PITRider's Linux export looks nearly perfect - only some text contents going outside their cells.

As noted in comment 4, the file is indeed a bit freeze-prone.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-04_00:06:27
Comment 6 Ari Järvinen 2015-02-02 16:13:37 UTC
I have same problem. Can't print to .pdf using PDFcreator or export to PDF format without Excel tables corrupted. Only few cells from beginning of table print out, rest is who knows where.
If Excel sheet is opened by Calc and you copy paste table from there, everything works fine. Well, not fully. If you have to centralize vertically text in cells, last few rows might then pass out of sight.

Win7 Pro 64-bit, LibreOffice 4.3.5.2
Comment 7 QA Administrators 2016-02-21 08:36:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21
Comment 8 QA Administrators 2019-05-14 02:59:08 UTC Comment hidden (obsolete)
Comment 9 Timur 2019-05-14 09:58:20 UTC
No repro LO 6.0 and master. Probably fixed long time ago.