Bug 71039 - FILESAVE: Red message in OffLine Help when have to write the new FILE TEMPLATE MENU of version 4.0
Summary: FILESAVE: Red message in OffLine Help when have to write the new FILE TEMPLAT...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
: 75084 82981 94132 104098 104102 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-30 08:35 UTC by Samuel Mounier
Modified: 2016-11-24 02:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mounier 2013-10-30 08:35:32 UTC
Problem description:
When I look at the online help, red text indicating a bug appears.

D'oh! You found a bug (# text/shared/00/00000401.xhp dokuvorlage not found).

text/shared/00/00000401.xhp#dokuvorlage
text/shared/00/00000401.xhp#dokuspei

Steps to Reproduce:
1. F1 to access help
2. looking for template (or modèle in French)
3. select "template"

Just below the text format "To access this command"
Red text appears.

Current behavior:
The red text

Expected behavior:
The text should be menu items "File> Save as Template"
              
Operating System: Windows 7
Version: 4.1.3.2 rc
Last worked in: 4.0.6.2 rc
Comment 1 Stanislav Horacek 2013-10-30 16:57:17 UTC
Confirming, help is outdated here and does not reflect that there is a new template manager. Apart from templates pages, pages like description of File menu should be also updated.

This particular problem was caused by the commit d5d84f0ec4584e32147eeab355d0ab73e7dd9172 that removed some old stuff; but it should be solved complexly.
Comment 2 Stanislav Horacek 2014-02-18 08:30:05 UTC
*** Bug 75084 has been marked as a duplicate of this bug. ***
Comment 3 Stanislav Horacek 2014-09-28 17:47:16 UTC
*** Bug 82981 has been marked as a duplicate of this bug. ***
Comment 4 Kolbjørn Stuestøl 2015-02-01 16:28:39 UTC
The error still occures in version 4.3 and 4.4
(Windows 7)
Comment 5 Regina Henschel 2015-09-11 14:00:30 UTC
*** Bug 94132 has been marked as a duplicate of this bug. ***
Comment 6 Robinson Tryon (qubit) 2015-12-09 18:29:04 UTC Comment hidden (obsolete)
Comment 7 Regina Henschel 2016-01-02 17:02:15 UTC
The item "Templates" in the menu "File" is associated with the command ".uno:TemplateMenu". With this uno command as hid you get the help file source/text/shared/01/01110000.xhp

So it makes sense to keep this file and adapt it to the new submenu.

The variable id="dokuvorlage", which has been deleted from file source/text/shared/00/00000401.xhp, is only used here. Therefore there is no need to restore the variable. But the problem is solved, when inserting the needed text directly.

The file source/text/shared/01/01110000.xhp has text for "Address Book Source", but that is no longer part of the submenu "Templates". Actually the menu item has been the dialog "Templates: Address Book Assignment". This assignment dialog it now in menu Tools.

The submenu "Templates" has in LibreOffice 5.2 the items
 "Manage" (.uno:NewDoc), help in file source/text/shared/01/01010000.xhp
 "Save as Template…" (.uno:SaveAsTemplate), help in file source/text/shared/01/01110300.xhp
The links need to be adapted in file source/text/shared/01/01110000.xhp.
Comment 8 Gabor Kelemen 2016-10-13 11:53:36 UTC
This problem was fixed here:
https://cgit.freedesktop.org/libreoffice/help/commit/source?id=a2e692fc4eeeb04fb0664bcac58f3e5dba9164cd

Of course the redesigned Templates window need brand new help pages, that should happen in bug #94454. But until then this kind of ugliness is gone :).
Comment 9 Gabor Kelemen 2016-11-23 15:29:08 UTC
*** Bug 104098 has been marked as a duplicate of this bug. ***
Comment 10 craig@arno.com 2016-11-23 18:34:24 UTC
Confirming this bug still exists in 5.2.3.3 x64 under Impress Help "Saving (Templates)" and "Templates".

Changing status from "Resolved/Fixed" to "Reopened".
Comment 11 craig@arno.com 2016-11-23 19:33:07 UTC
I verified this bug in Windows 10 x64 and Ubuntu 16.04 LTR x64.

"OffLine Help" -must- be installed:

Under Windows "LibreOffice_5.2.3_Win_x64_helppack_en-US.msi"

Under Ubuntu "sudo apt install libreoffice-help-en-us"
Comment 12 Xisco Faulí 2016-11-23 19:34:18 UTC
*** Bug 104102 has been marked as a duplicate of this bug. ***
Comment 13 Adolfo Jayme 2016-11-24 02:57:09 UTC
Closing again, as the fix was pushed for LO 5.3.x.