Bug 71147 - FILEOPEN: lwp-files open not or without charts/tables
Summary: FILEOPEN: lwp-files open not or without charts/tables
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.1.4 target:4.2.0
Keywords:
: 70892 (view as bug list)
Depends on:
Blocks: LWP
  Show dependency treegraph
 
Reported: 2013-11-01 22:22 UTC by klausmiehling
Modified: 2020-01-20 18:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
lwp file that does not open at all (967.24 KB, application/vnd.lotus-wordpro)
2013-11-01 22:22 UTC, klausmiehling
Details
lwp file that opens without charts/tables (1.12 MB, application/vnd.lotus-wordpro)
2013-11-01 22:30 UTC, klausmiehling
Details
console + bt for fnf1500 document (23.20 KB, text/plain)
2013-11-02 22:56 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description klausmiehling 2013-11-01 22:22:12 UTC
Created attachment 88517 [details]
lwp file that does not open at all

Problem description: 

Steps to reproduce:
1. ....open lwp file
2. ....
3. ....

Current behavior: file does not open, program says: "Allgemeiner Fehler. Allgemeiner Ein-/Ausgabefehler" 

or:

file opens with loss of formatting (italics, IPA font, though installed) and loss of all charts/tables AND all their content

Expected behavior: opens without loss of text

              
Operating System: Windows 7
Version: 4.1.2.3 release
Comment 1 klausmiehling 2013-11-01 22:30:38 UTC
Created attachment 88518 [details]
lwp file that opens without charts/tables

the file "fnf 1500 - 1570" does not open at all, the file "Finanzen 2013" opens without charts/tables and therefore lost almost all of its content
Comment 2 m.a.riosv 2013-11-02 01:36:13 UTC
Hi Klausmiehling, thanks for reporting.

Reproducible with:
Win7x64 
Version: 4.1.4.0.0+ Build ID: d6ee64b75581cbeb92534271ee6f4e87f07aa5c

Maybe I am wrong, but I think won't be easy find this solved in a short time.
Saving your file in LotusWordPro as MS word 7.0 or as Wordperfect achieves a better results.
Comment 3 Julien Nabet 2013-11-02 22:56:03 UTC
Created attachment 88539 [details]
console + bt for fnf1500 document

On pc Debian x86-64 with master sources updated today, I had a crash by trying to open fnf1500 document.

I attached console logs + bt
Comment 4 Commit Notification 2013-11-04 13:56:12 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03a5b16e056bf8ddab5a6b204db8706da7f7be26&h=libreoffice-4-1

Related: fdo#71147 lwp-files open not or without charts/tables


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-11-04 13:56:29 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a210df8e50d94f557ceaa21e5f4943db97777812

Related: fdo#71147 lwp-files open not or without charts/tables



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 m.a.riosv 2013-11-04 19:01:32 UTC
Thanks Julien for a so quick patch, which solve opening the file with tables.
Win7x64Ultimate
Version: 4.2.0.0.alpha0+ Build ID: 7c19dd02d9241e06ecfeeb9ba4ab2971cba7ef43
TinderBox: Win-x86@42, Branch:master, Time: 2013-11-03_23:15:10

Letters with umlauts looks like boxes, even with locale in German(Germany).
And open fine without select any file type, but selecting Lotus-Wordpro-Document for open, results in a:
 General Error.
 General input/output error.
Comment 7 tommy27 2013-11-04 21:06:50 UTC
*** Bug 70892 has been marked as a duplicate of this bug. ***
Comment 8 klausmiehling 2013-11-30 23:36:27 UTC
I downloaded the patch and copied it in the libre Office Folder - I didn't know what else to do, since am no Computer expert ...

But I hoped for the next version. I installed Version 4.1.3.2 today, but still the word pro files open without tables and without the table content.
Comment 9 Julien Nabet 2013-12-01 07:56:33 UTC
klausmiehling: Only the crash is fixed. Lotus Word pro is closed software, I mean we don't have the specs of it.

Michael: except if someone wants to do some reverse engineering, I don't think this bug can be fixed and would put RESOLVED/WONTFIX, what do you think?
Comment 10 Michael Meeks 2013-12-02 09:57:37 UTC
As you say - lwp is a tad difficult to fix without any specs. of course, that doesn't mean it is un-fixable; but it takes some work - patches most welcome.

No idea how to categorise the bug - but if it's real, leaving it open but in some backwater is prolly better ?
Comment 11 QA Administrators 2015-04-19 03:21:22 UTC Comment hidden (obsolete)
Comment 12 Buovjaga 2015-06-16 09:52:45 UTC
attachment 88517 [details] opens ok.

attachment 88518 [details] doesn't show charts or tables.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 13 QA Administrators 2016-09-20 10:02:04 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2019-12-03 14:12:52 UTC Comment hidden (obsolete)
Comment 15 m.a.riosv 2019-12-06 01:03:15 UTC
General Error, general input/output error
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 60e8941fd581bb06cbf6be62edb8c387e7c07812
CPU threads: 4; OS: Windows 10.0 Build 19035; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: CL
Comment 16 Xisco Faulí 2020-01-20 18:34:29 UTC
(In reply to m.a.riosv from comment #15)
> General Error, general input/output error
> Version: 6.5.0.0.alpha0+ (x64)
> Build ID: 60e8941fd581bb06cbf6be62edb8c387e7c07812
> CPU threads: 4; OS: Windows 10.0 Build 19035; UI render: default; VCL: win; 
> Locale: es-ES (es_ES); UI-Language: en-US
> Calc: CL

Reported in bug 130093