Bug Hunting Session
Bug 71423 - Impress frequently crashes when selecting or editing tables in slides while styles & formatting dialog is open
Summary: Impress frequently crashes when selecting or editing tables in slides while s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: highest blocker
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard: target:4.3.0 target:4.2.4
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-11-09 10:57 UTC by Gerry
Modified: 2015-01-26 22:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
hs_err_pid3856.log (146.59 KB, text/plain)
2013-11-09 10:57 UTC, Gerry
Details
gdbtrace.log (9.88 KB, text/x-log)
2013-11-11 17:47 UTC, Gerry
Details
strace.log.7z (2.43 MB, application/x-7z-compressed)
2013-11-11 17:49 UTC, Gerry
Details
gdbtrace(with libreoffice-gdb).log (39.47 KB, text/x-log)
2013-11-19 18:01 UTC, Gerry
Details
gdbtrace(with libreoffice-gdb 2nd test).log (24.91 KB, text/x-log)
2013-11-20 07:39 UTC, Gerry
Details
Screenshot-at-freeze-before-crash.png (278.55 KB, image/png)
2014-04-02 14:40 UTC, Gerry
Details
Another-screenshot-at-freeze.png (388.03 KB, image/png)
2014-04-02 14:51 UTC, Gerry
Details
Third-screenshot-at-freeze-before-crashing-png (386.25 KB, image/png)
2014-04-02 15:05 UTC, Gerry
Details
Table selection bug.png (181.48 KB, image/png)
2014-04-16 09:38 UTC, Gerry
Details
Examples of tables for crash-test. (50.69 KB, application/vnd.oasis.opendocument.presentation)
2014-11-09 19:16 UTC, Ljiljan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-11-09 10:57:40 UTC
Created attachment 88924 [details]
hs_err_pid3856.log

After one of the last LibreOffice Updates for Ubuntu 13.04, LibreOffice Impress behaves unstable. It crashes very frequently when editing tables in slides. This occurred with several different files on my system.

It seems to be a crash related to Java. Please see output below and error log in the attachment.

System:
Ubuntu 13.04 Gnome3 Shell, 64-Bit
LibreOffice Version: 4.1.3.2, Build ID: 410m0(Build:2)


gerry@host:~$ soffice 
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f0bdabccfb4, pid=5856, tid=139688929548800
#
# JRE version: 7.0_25-b30
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libmergedlo.so+0x14d7fb4]  SfxTemplatePanelControl::GetISfxTemplateCommon()+0x70f4
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/gerry/hs_err_pid5856.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   https://bugs.launchpad.net/ubuntu/+source/openjdk-7/
#

[error occurred during error reporting , id 0xb]
Comment 1 Gerry 2013-11-11 17:38:34 UTC
On the weekend, I did a bit more testing with regards to these crashes of LibreOffice Impress. It actually costed me quite some nerves as I needed to get a presentation done for today and it crashed very often when editing tables.

What did I do?
* I disabled the extensions Zotero and Languagetool. No change, still crashes.
* I disabled Java in the options. No change, still crashes.
* I installed LibreOffice Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24) from the LibreOffice website. The crashes also occur in this version, but a bit less frequent (I think so).

What other testing could I do? Unfortunately, I cannot attach the presentation here, but I could send it to someone's email address.
Comment 2 Gerry 2013-11-11 17:47:16 UTC
Created attachment 89041 [details]
gdbtrace.log
Comment 3 Gerry 2013-11-11 17:49:25 UTC
Created attachment 89042 [details]
strace.log.7z

Added a backtrace and a strace log.
Comment 4 Joel Madero 2013-11-19 14:30:48 UTC
Hey Gerry,

Thanks for the trace - have you made sure to try with a fresh profile? I'm requesting additional input here before moving to NEW but with all the info you provided, likely it will be marked as NEW and we'll hopefully get it fixed soon.
Comment 5 Björn Michaelsen 2013-11-19 15:26:11 UTC
(In reply to comment #2)
> Created attachment 89041 [details]
> gdbtrace.log

Hi Gerry, can you install libreoffice-dbg to get debug symbols, which will make the stacktrace way more readable?
Comment 6 Gerry 2013-11-19 18:01:53 UTC
Created attachment 89483 [details]
gdbtrace(with libreoffice-gdb).log

@Björn: As you suggested, I installed libreoffice-gdb and continued testing. With libreoffice-gdb it took a bit longer (about 1 minute) until LO finally crashed. Please find the new gdbtrace.log attached.
Comment 7 Gerry 2013-11-20 07:39:01 UTC
Created attachment 89513 [details]
gdbtrace(with libreoffice-gdb 2nd test).log

Please find attached the gdbtrace.log from a second test with libreoffice-gdb. This time LO crashed within a few seconds when I started editing a table in the presentation.
Comment 8 retired 2013-11-24 10:55:47 UTC
Gerry: Can you please provide a test document so this can be tested against and subsequently be confirmed. If your document contains sensitive data, please clear that or replace it with random information.

A step-by-step description of how to reproduce the issue is most helpful and will help to speed up the processing of this problem a lot.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 9 Gerry 2013-11-24 18:55:56 UTC
Thanks Foss for looking into the bug. I will try removing the sensitive information and hope that this doesn't change the tendency to crash. 

This time (in my test today), Impress hung long enough so that Apport-gtk of Ubuntu appeared. This is the information Apport collected from the crash:

http://ubuntuone.com/0GjQPx4giewJrRlrZ0zqbN (36MB)

I think the relevant information on the LibreOffice crash starts in line 1731.
Comment 10 Gerry 2013-11-24 19:48:56 UTC
Besides the apport-gtk crash report in comment 9, I can also provide the presentation with removed sensitive stuff. You can download it here: http://ubuntuone.com/0f3drWdEA0hD0hw13tPd5A (7.4MB)
With this cut-down presentation, Impress also crashes.

How to reproduce the crash:

* Please start Impress
* File -> Open -> choose attached file
* There is no single event that crashes Impress, but it has always to do with tables in the presentation. Hence, to reproduce the crash you need to play a bit with tables. Do, for example:
** on slide 54: Select with the mouse both heading cells of the table and choose Arial for both and font size 18. (sometimes it already crashes here). Then try to make the table smaller by selecting the middle blue rectangle in the bottom of the table and try to move the bottom edge of the table upwards (this usually makes tables smaller). (sometimes it crashes by doing this).
* If it still does not crash, try to do something similar with slides 55, 58, 59, 62, 63,.... (highlighting more than one cell and change font and font size, change content, try to change the table size from the bottom upwards, and so forth).
* On my system, there is a 100% chance that Impress crashes when I play a bit with tables in this presentation.
Comment 11 Pierre C 2013-11-30 17:39:00 UTC
I can confirm frequent crashes when using tables in Impress.
This behaviour began in LO 4.1 branch and 4.0.5.
I've never been able to have steps to reproduce the crashes but working with tables is now a problem. This afternoon again, with LO 4.1.4.1.

The crashes came at the same time with this bug :

https://bugs.freedesktop.org/show_bug.cgi?id=68923 

(witch is a very annoying bug)
Comment 12 metric24088 2013-11-30 23:14:38 UTC
I am experiencing the same (very annoying) bug on 

Windows 7 Home Premium 6.1.7601 SP1 Build 7601.  

I am trying to edit tables in Impress and it hangs every time.  I am similarly trying to change font sizes, colors, and background colors.  I have started from a fresh profile and the behavior is the same.  I am using 

LibreOffice Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a
Comment 13 Joel Madero 2013-11-30 23:20:47 UTC
Because of the great backtrace as well as the confirmation from other users - I am moving this to NEW.

Also putting it on MAB list
Comment 14 Pierre C 2013-12-01 11:03:47 UTC
A major problem (IMHO) is that, currently, there is no stable version of LO being stable for using table with impress.

I can confirm comments #10 and #12 frequently crashes but very difficult to reproduce. Just have to play with tables, modifying background, copying, pasting, changing font size, colour, and so on...

All LO 4.1.x and LO 4.0.6 crashes too (not LO 4.0.5 ) so all LO available for download are buggy 

actually three bugs seems to have appear at the same time and may be linked :

that one and these :

https://bugs.freedesktop.org/show_bug.cgi?id=68923


https://bugs.freedesktop.org/show_bug.cgi?id=72178
Comment 15 Gerry 2013-12-19 10:37:16 UTC
Unfortunately, this bug had not been fixed for yesterday's release 4.1.4.

I can also confirm this bug with the most recent LO update for Ubuntu: Version: 4.1.3.2, Build ID: 410m0(Build:2)

It is a severe bug! For a completely different presentation yesterday, I almost could not meet the deadline, because of crashes due to this bug. Working with tables in Impress is not possible at this stage!
Comment 16 Gerry 2013-12-27 00:15:21 UTC
Please consider fixing this bug for 4.1.5. Thanks in advance!
This is one of the worst Impress bugs for a long time. The crashes when working with tables in slides are unbearable.

If you need any additional information, please request this information.
Comment 17 Pierre C 2013-12-27 00:21:07 UTC
@Gerry Isn't it too late for Christmas guess ?

I hope that this bug will be fix soon. I hope... But I don't trust it'll be
Comment 18 Pierre C 2013-12-27 00:28:51 UTC
I've just tried with the latest 4.1.5.0+. It just took me 10 seconds to make it crash. Just a new presentation, insert a table as default, and starting to fill it randomly...

But with 4.2.0 RC1, I've played 1 min with tables... and no crash
Comment 19 Joel Madero 2013-12-27 00:41:53 UTC
I just did exactly as requested with 4.1.3.2 and was unable to reproduce on ubuntu 13.10. 

If it's fixed on 4.2 then it was likely "accidentally" fixed - a bibisect may be useful

https://wiki.documentfoundation.org/QA/HowToBibisect

You'll have to use the 2013-11-25 package that is listed on that wiki.
Comment 20 Joel Madero 2013-12-27 00:42:34 UTC
Oh, please try with a fresh profile before doing a bibisect - it might just be a wonky profile

https://wiki.documentfoundation.org/UserProfile
Comment 21 Pierre C 2013-12-27 08:36:13 UTC
I did all my test with a fresh profiles.

anyway LO must not crash whatever you profile is

I did not told that the bug were fixed in LO 4.2 branch. As said before, it is difficult it reproduce the bug. maybe I was simply lucky this time

If the bug has disappear accidental, it can be back bay the same way 

I will do new test soon on 4.2.0 RC1
Comment 22 Björn Michaelsen 2014-01-17 09:51:45 UTC
(This is an automated message.)

Setting priority to highest as this is a 4.1 MAB. This is part of an effort to make the importance of MAB reflected in priority too.
Comment 23 davidemf 2014-02-13 12:59:44 UTC
I was observing the described bug in version 4.2.0.4 of LO (Windows 7 64).

Selecting the only table in the presentation was enough to crash Impress after a few seconds. On the other hand, not touching the table allowed working on the presentation without issues for as long as desired.

I tried the suggested clean profile*, and I am here to report that I do not observe the bug anymore. I can select and modify the table of the above mentioned file without a glitch.

I do not remember which version of LO was installed before I upgraded to 4.2.0.4.

* - I.e.:
Closed LO
Renamed C:\Users\Username\AppData\Roaming\LibreOffice\4\user
to C:\Users\Username\AppData\Roaming\LibreOffice\4\user-old
Restarted LO
Comment 24 Pierre C 2014-02-13 13:35:47 UTC
With LO 4.1.5.3 (Seven x64)
1 Launch LibreOffice
2 Create new presentation by file -> new -> presnetation
3 insert table, keep default values
4 click on the last cell
5 press tab to insert a new line on the table
==> Crash
Lo is unable to recover the file

I've done it three times => Same crash

BUT

If you create the new presentation with the Impress icon (after launching LibreOffice) there is no crash !

trying it three times 

and the coming back to first way to create new presentation three times and then 3 crashes.

No crash with dev-master
Comment 25 Pierre C 2014-02-13 16:16:58 UTC
Humm... after a reboot, this way to make LO crash does not work any more

But, playing with tables still make LO crash very quickly
Comment 26 Pierre C 2014-03-09 17:07:25 UTC
As I've had to work with table in one of my presentations. I can confirm that with LO 4.1.6+ it crashes but also with LO 4.2.2.1.

Working with tables is unbearable !

And no one seems to get attention at it...

I can only said to my student : DON'T USE ANY TABLE IN IMPRESS

(as I told them quite before : don't use embedded font with LO)
Comment 27 Joel Madero 2014-03-09 17:14:17 UTC
Hey Thorsten - 
Assuming you've seen this one on the MAB list but wanted to CC you in case you're interested in taking a look. Looks like there's a nice gdb trace - if you want a bibisect let me know and I'll get one done ASAP. 


Thanks!
Comment 28 Pierre C 2014-03-23 10:57:16 UTC
At least, there is a workaround.

Just use AO 4.1 beta
Comment 29 Gerry 2014-03-24 16:47:35 UTC
I don't want to be inpatient, but I am now somewhere between 50-100 crashes due to this bug with many different presentations on three different computers (Ubuntu with LO 4.1.x, Mint with LO 4.1.x, Windows7 with LO 4.2.x). Every crash of Impress stole me a couple of minutes of work, summing up to at least one work-day lost, not counting my lost nerves ;-) Uuuh

To sum up:
* Working with tables in LO Impress is a pain
* All recent LO versions are affected: 4.0.6 , 4.1.x, 4.2.x 
* It is a regression (4.0.5 and earlier was okay!!-> see comment 11 and comment 14))
* It is an all OS problem
* Reproducing the bug exactly step-by-step is somewhat difficult, but working with tables in Impress is generally unstable and creating a presentation with a couple of tables almost surely leads to at least one crash.
* choffardet assumes that bug 68923 and bug 72178 is related -> comment 14
Comment 30 Pierre C 2014-03-24 20:06:16 UTC
I just can't understand why is this bug ignored !
As it was just told. I use three computers, and the bug is present in all of these computers. 
It's a serious regression. most often, there is no data-loss, but sometimes,some of the work isn't recovered.

Just yesterday : To write a simple word in a cell, LO crash for each letter.

This bug should be a blocker for the last 4.1.6.

But IMHO, it won't be solved. And not sure it'll be for 4.2 branch

The only hope is that's the bug get away as it comes

Tjis bug may be a duplicate of this one :

https://bugs.freedesktop.org/show_bug.cgi?id=76180

 EDITING: Impress crashes after adding / moving table
Comment 31 Gerry 2014-03-24 20:22:57 UTC
@Joel Madero: IMHO choffardet is right that this definitively should be a blocker for 4.1.6, the last revision of the 4.1.x branch. If I understand the ReleasePlan right, then "conservative" users will use that version at least one more year. 

Joel, would you be so kind to put this in the next ESC call as a candidate for BLOCKER for release 4.1.6?
Comment 32 Pierre C 2014-03-27 09:28:49 UTC
With le latest 4.3.2

opening a presentation. working on it 20 minutes.

When on a slide with a table.

Selecting a column -> align centre ==> crash (of course now I save it before touching a table)

I guess no-one is working on this bug.
Comment 33 Pierre C 2014-03-27 09:33:49 UTC
After reopening the file. the table shows differently (all blue instead of alternate gray)

When opening the files with AOo, the tables also show all blue instead of alternate grey.

Maybe a way to trace the bug ?
Comment 34 Joel Madero 2014-03-31 22:50:20 UTC
FWIW we don't actually have true blockers - we will almost never not release due to a bug. I agree this one is pretty nasty but it's not going to block releases - we've done what we can - it's set very high and put on the MAB list. I'll see if there's anything else we can do to help encourage a volunteer to tackle it
Comment 35 Thorsten Behrens (CIB) 2014-04-02 08:03:06 UTC
Played a bit with the sample documents, couldn't make it crash. Could someone who sees this attach a screenshot just before the crashing? I'm particularly interested in the state of the Styles & Formatting floater.

Backtrace hints at

        const SfxStyleFamilyItem *pItem = GetFamilyItem_Impl();
        pStyleSheetPool->SetSearchMask(pItem->GetFamily(),  
                                       SFXSTYLEBIT_ALL_VISIBLE);

pItem being NULL or something. Band-aid fix is trivial, but would be good to know this is really the sticking point.
Comment 36 Pierre C 2014-04-02 08:19:15 UTC
This bug is quite curious.

I've yet a sample doc : 
https://www.dropbox.com/s/dutvaaopn2rjrng/impress%20crash.odp

To make LO crash, I just have to select the word 'Domaine' and right-clic on 'default'.

LO crash almost every times

It crashes on my laptop and on my notebook (both with Seven x64)

But it does not crash with LO 4.1.6+ (on both computers) and does not crash on Vmwares with LO 4.1.3.2 and XP or Seven x64

But with any LO on these computers I can always make LO crash, just playing with tables (inserting columns, lines, copy, pasting, changing font, size, color) it just take less than 5 min. sometimes 5 seconds, and yes rarely, I can't make it crash
Comment 37 Gerry 2014-04-02 14:40:28 UTC
Created attachment 96789 [details]
Screenshot-at-freeze-before-crash.png

(In reply to comment #35)
> Played a bit with the sample documents, couldn't make it crash. Could
> someone who sees this attach a screenshot just before the crashing? 

Please find attached a screenshot at the time of the freeze (before LO crashed).
(Remark: I don't know why the screenshot looks a bit weird. My LibreOffice Windows looks normal before crashing)
Comment 38 Gerry 2014-04-02 14:51:39 UTC
Created attachment 96790 [details]
Another-screenshot-at-freeze.png

Another screenshot at freeze (before crash). (Remark: This screenshot looks nicer :-)
Comment 39 Gerry 2014-04-02 15:05:37 UTC
Created attachment 96791 [details]
Third-screenshot-at-freeze-before-crashing-png

Attached the third (and last) screenshot of the freezes (before crashing). (Sometimes the crash came too fast so I was not able to create a screenshot. In such case for example, the styles&formatting was free floating).

After Thorsten's hint, I realized that the crashes seem to only occur when the Styles&Formatting window is open. If it is not open at all, I could never reproduce a crash in my tests today.
Comment 40 Gerry 2014-04-09 15:37:09 UTC
> Could someone who sees this attach a screenshot just before the crashing? I'm
> particularly interested in the state of the Styles & Formatting floater.

Hi Thorsten, were the attached screenshots helpful for identifying the problem behind the crashes? Do you need any other information? Thanks!
Comment 41 Thorsten Behrens (CIB) 2014-04-09 17:50:26 UTC
(In reply to comment #40)
> Hi Thorsten, were the attached screenshots helpful for identifying the
> problem behind the crashes? Do you need any other information? Thanks!
>
Yep, thank you - especially the confirmation that it hinges on the styles & formatting floater!
Comment 42 Commit Notification 2014-04-10 17:44:48 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=058cfa72dcdd91df302be45f7fc59b0d961a420b

Fix fdo#71423 - crash while editing Impress tables.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 43 Thorsten Behrens (CIB) 2014-04-10 17:50:24 UTC
choffardet, davidemf - committed a band-aid fix that _should_ fix this
(can't really tell, since I don't see the crash). Can one of you pick
a new nightly build from
http://dev-builds.libreoffice.org/daily/master/ tomorrow, and try to
verify if it's fixed indeed?
Comment 44 Gerry 2014-04-12 14:14:31 UTC
Thanks a lot Thorsten!

@choffardet: Do you have the possibility to test the nightly build as suggested by Thorsten in comment 43? I am travelling and could only try it out later next week.
Comment 45 Gerry 2014-04-12 14:27:35 UTC
@davidemf: Same question to you, of course. Thanks.
Comment 46 Pierre C 2014-04-12 14:31:49 UTC
Yes I will try it. but server GUI install is still proposing the master from march the tenth. I'm waiting for the one of 04/11/2014. Maybe tomorrow
Comment 47 Thorsten Behrens (CIB) 2014-04-15 19:03:16 UTC
anyone of the reporters able to quickly check? there are builds available now from http://dev-builds.libreoffice.org/daily/master/
Comment 48 Pierre C 2014-04-15 20:15:21 UTC
I've made some tests with this latest dev master. And I wasn't able to make LO crash when using tables.
It doesn't mean the bug is over. Sometimes it tooks me five seconds. Sometime five minutes. Some times I can't. But next day it took me only one second...

BUT in this version, there is no extensions. And LO impress had curious behaviour.

- Selecting all the table show a partial frame on the table even if all the table is highlighted.
- Changing font size of all the table changes only some cells
- Adding a row by pressing tab on the last cell works sometimes but not every times.
- All these seem very slow

and more 
-the difficulty to select a text frame is still here (this bug went at the same time with crashing impress with tables)
Comment 49 Gerry 2014-04-16 09:38:30 UTC
Created attachment 97464 [details]
Table selection bug.png

Hi Thorsten,

I did a fresh LO 4.3 nightly install in a VirtualBox with WindowsXP SP3 and after some tests, I was not able to get a crash with Tables im Impress. I did a variety of test and there was no crash. That's excellent!

However, as choffardet describes, tables in Impress now behave very strange. It is very difficult to "grab" the edges of the tables in order to be able to resize the table. Furthermore, sometimes the edges are not there where the edges of the table are (see the screenshot attached). 

I also encountered situations where I was not able to select more than the content of one single table cell with the mouse. Only after clicking outside the table and then again inside the table, I was able to select multiple cells. Very strange.


Version: 4.3.0.0.alpha0+
Build ID: 087a79db1272858f107656c5ca3c6efb45680986
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-16_01:43:37
Comment 50 Thorsten Behrens (CIB) 2014-04-16 10:09:17 UTC
(In reply to comment #49)
> I did a fresh LO 4.3 nightly install in a VirtualBox with WindowsXP SP3 and
> after some tests, I was not able to get a crash with Tables im Impress. I
> did a variety of test and there was no crash. That's excellent!
> 
Cool, that's good news, thanks to both of you for testing!

> However, as choffardet describes, tables in Impress now behave very strange.
> It is very difficult to "grab" the edges of the tables in order to be able
> to resize the table. Furthermore, sometimes the edges are not there where
> the edges of the table are (see the screenshot attached). 
> 
> I also encountered situations where I was not able to select more than the
> content of one single table cell with the mouse. Only after clicking outside
> the table and then again inside the table, I was able to select multiple
> cells. Very strange.
> 
But I would assume that would be the same in a master build before
Thursday last week, right? And then worth a separate bug report.
Comment 51 Commit Notification 2014-04-16 10:25:52 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4128c63d655869e0ab7befde2c46761d8e1b273f&h=libreoffice-4-2

Fix fdo#71423 - crash while editing Impress tables.


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 52 Gerry 2014-04-16 11:47:12 UTC
With regards to this bug, good news: After installing a slightly older nightly build (2014-04-08) in my test environment (Virtualbox and WinXP SP3), I could reproduce the crashes with tables. This means that Thorsten's fix is successful.

With regards to the other problems, I am not sure whether they are introduced by this fix (is this possible, Thorsten?) or by something else. Testing a nightly from the 8th of April, I could reproduce some of the other problems, but not all. E.g. I cannot confirm the bug of my screenshot in that earlier build.
Nevertheless, I opened bug 77523 for these problems.


Version: 4.3.0.0.alpha0+
Build ID: 615f6aa293a6da90da94e6e78828198ffbc0ca5e
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-08_01:30:26
Comment 53 Andras Timar 2014-04-16 12:12:52 UTC
back to RESOLVED FIXED
Comment 54 Pierre C 2014-04-16 19:42:25 UTC
this bug appears at the same time with that one (crash tables)
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=68923
Comment 55 Commit Notification 2014-04-24 10:12:06 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c9c50b74fe1ca51e975deda780228386cefa8301&h=libreoffice-4-2-4

Fix fdo#71423 - crash while editing Impress tables.


It will be available already in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 56 Reece Hart 2014-05-16 01:58:55 UTC
Confirming fixed. Thank you!

Ubuntu 14.04, x86_64.

As with others, 4.2.3 crashed incessantly when editing tables. 4.2.4 from ppa (https://launchpad.net/~libreoffice/+archive/libreoffice-4-2) resolved the issue.
Comment 57 Ljiljan 2014-11-09 09:21:45 UTC
I am experiencing this bug in LO 4.3.3.2 (Ubuntu 14.04, 64-bit).

Table was copied from Writer. I managed to edit table (change font, size, delete columns etc...) however, following events triger LO Impress  crashing:

 - first column is selected and I press CTRL + C (LO Crashes)
 - I selected for slides (three slides contain tables) and wanted to move it to different positions... LO crash
Comment 58 Ljiljan 2014-11-09 19:16:15 UTC
Created attachment 109169 [details]
Examples of tables for crash-test.
Comment 59 Ljiljan 2014-11-09 19:18:39 UTC
I uploaded Impress ODP file with tables which always crashes Impress when trying to copy first column...

"Examples of tables for crash-test." if attachment. 

How to reproduce the error (LO 4.3.3.2)

1. Open the attachment
2. Select first column
3. Press CTRL + C
4. Impress should crash
Comment 60 jordimp 2014-11-10 11:46:44 UTC
Hi,

I'm sorry to report that this bug is not properly fixed.

LibreOffice crashes immediately on my system (Mac OSX 10.9.5) whenever I try to copy a table from a slide (or a slide containing a table) in Impress. I have updated to the latest LO version (4.3.3) without any improvement.

On the contrary, I have now downgraded to LO 4.2.7.2 and I can copy slides with tables without problems.

So something has gone wrong again from 4.2 to 4.3.

-jordimp
Comment 61 Michael Stahl (CIB) 2014-11-10 12:11:33 UTC
jordimp, please file a *new* bug report.  this one has *59* comments already and no developer will look at such a mess.