Bug 71646 - FILESAVE: [docx] wrong directionality after save file created by MS
Summary: FILESAVE: [docx] wrong directionality after save file created by MS
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Faisal Menawer
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on: 43093
Blocks: rtl-meta
  Show dependency treegraph
 
Reported: 2013-11-15 14:13 UTC by Faisal Menawer
Modified: 2013-12-14 13:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LTR left aligned save bug (22.26 KB, application/vnd.ms-word.document.12)
2013-11-15 14:16 UTC, Faisal Menawer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Faisal Menawer 2013-11-15 14:13:59 UTC
This bug are based on this comment:
https://bugs.freedesktop.org/show_bug.cgi?id=43093#c17


"a file originally created using Word 2013, and contains LTR left aligned text. It opens fine using the above LO build, but if I save again and reopen, it turns into RTL left aligned. If then I open the file with Word 2010 SP2, it opens as RTL right aligned. It's a bug only with this file, I can't reproduce it with other files."

Steps to reproduce:
1- open the attachment.
2- save it as docx.
3- open it again.

Current behavior:
the direction changed to RTL.

Expected behavior:
the direction still LTR.
Comment 1 Faisal Menawer 2013-11-15 14:16:37 UTC
Created attachment 89274 [details]
LTR left aligned save bug
Comment 2 Commit Notification 2013-11-15 15:28:20 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84b3d6dc3a7d5ba52b00285e59e7aa6b5ca15837

DOCX:fdo#71646 fix wrong direction when save the file.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Maxim Monastirsky 2013-11-17 09:46:58 UTC
Fix verified with a master build (Build ID: f7e6521efca5e5966a65e84848a1c35d71ba1a0b).

@Faisal: Thank you very much for your efforts in fixing these bugs!
Comment 4 Faisal Menawer 2013-11-18 17:21:20 UTC
@maxim: thank you for your great test :)

change the status to resolve fixed
after comment3 verified.
Comment 5 Lior Kaplan 2013-12-14 13:23:47 UTC
Mark as verified per Comment #3