Download it now!
Bug 71655 - EDITING: Random crashing
Summary: EDITING: Random crashing
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-15 17:56 UTC by antti.niemi
Modified: 2014-08-04 16:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description antti.niemi 2013-11-15 17:56:54 UTC
Libreoffice Writer crashes randomly. Sometimes it happens while editing a formula, once it crashed when tried to add an image from file.


OS: Arch Linux x86-64
Desktop environment: KDE

Libreoffice Writer version: 4.1.2.3
Build ID: 4.1.2.3 Arch Linux build-2
Operating System: Linux (Other)
Version: 4.1.2.3 release
Comment 1 Joel Madero 2013-11-15 18:23:46 UTC
We will need some kind of a backtrace or something more than the information provided in order to do anything - just not enough information for us to actually reproduce the bug.

Marking as NEEDINFO - 

https://wiki.documentfoundation.org/Development/How_to_debug


If you can debug the problem and post the log please mark as UNCONFIRMED and we'll try to track down the problem. Additionally, a fresh profile *may* help 
https://wiki.documentfoundation.org/UserProfile
Comment 2 Julien Nabet 2013-11-15 20:18:07 UTC
antti.niemi:
- did you install any LO specific extensions?
- do you reproduce this on a brand new file?
- did you try to rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give it a new try?
Comment 3 antti.niemi 2013-11-28 19:56:18 UTC
I found a way to reproduce at least one problem - sometimes when opening the Save/Save as dialog the program crashes. However, this seems to happen only when desktop compositing is enabled. 

To the questions: No extensions are installed (as far as I know), and this has happened with brand new files.



Console output when it crashes:


$ libreoffice --writer
"/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A60G_50026B7331050730" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SH_224BB_R8WS68ECC03Z00" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/WDC_WD10EZEX_00RKKA0_WD_WMC1S4054416" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/WDC_WD10EZEX_00RKKA0_WD_WMC1S4048750" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A60G_50026B7332001ACB" : property "Drive" does not exist 
"/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A60G_50026B7332001ACB" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A60G_50026B7332001ACB" : property "Device" does not exist 
"/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A60G_50026B7331050730" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/KINGSTON_SV300S37A60G_50026B7331050730" : property "Device" does not exist 
"/org/freedesktop/UDisks2/drives/WDC_WD10EZEX_00RKKA0_WD_WMC1S4048750" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/WDC_WD10EZEX_00RKKA0_WD_WMC1S4048750" : property "Device" does not exist 
"/org/freedesktop/UDisks2/drives/WDC_WD10EZEX_00RKKA0_WD_WMC1S4054416" : property "DeviceNumber" does not exist 
"/org/freedesktop/UDisks2/drives/WDC_WD10EZEX_00RKKA0_WD_WMC1S4054416" : property "Device" does not exist 
LibreOffice(2128) KFileItemPrivate::init: "Untitled 1" does not exist anymore
LibreOffice(2128) KSambaSharePrivate::isSambaInstalled: Samba is not installed!
LibreOffice(2128) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 
LibreOffice(2128) KSambaSharePrivate::isSambaInstalled: Samba is not installed!
QWidget::repaint: Recursive repaint detected
Comment 4 Julien Nabet 2013-11-28 20:01:27 UTC
antti.niemi: what was the result after having renamed your LO directory profile (cf my previous comment)

It seems you use network shares (cf Samba), could you tell more about this? Which Samba version, do you write on Samba share, etc.
Comment 5 antti.niemi 2013-11-28 21:14:22 UTC
I will try renaming the profile dir later.

I don't use Samba and samba packages shouldn't even be installed (that's what console output says too although I don't understand why Libreoffice tries to access Samba resources).
Comment 6 Maxim Monastirsky 2013-11-28 21:24:40 UTC
(In reply to comment #3)
> QWidget::repaint: Recursive repaint detected
It's Bug 69002.
Comment 7 Julien Nabet 2013-11-28 21:30:31 UTC
Thorsten: could it worth it we cherry-pick the patch to 4.1 branch?
Comment 8 QA Administrators 2014-07-08 17:29:02 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 9 QA Administrators 2014-08-04 16:15:08 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO