Download it now!
Bug 72429 - by inserting Hyperlinks it keeps crushing down - sudden close!
Summary: by inserting Hyperlinks it keeps crushing down - sudden close!
Status: RESOLVED DUPLICATE of bug 69002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-07 11:50 UTC by gallusgyorgyulus
Modified: 2013-12-07 15:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
someone helped me generate this log by runnung soffice —backtrace (29.17 KB, text/plain)
2013-12-07 11:50 UTC, gallusgyorgyulus
Details
the output from term2 (57.33 KB, text/plain)
2013-12-07 14:45 UTC, gallusgyorgyulus
Details
terminal output (2.89 KB, text/plain)
2013-12-07 15:22 UTC, gallusgyorgyulus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gallusgyorgyulus 2013-12-07 11:50:55 UTC
Created attachment 90404 [details]
someone helped me generate this log by runnung soffice —backtrace

In a spreadsheet, I want to insert some hyperlinks of type "Document" by using the brouse button for the file path, the open dialog appears, and the crash comes in this dialog-box at clicking on a file or trying to scroll the list of files. It also happend at pressing the open button - after selecting a file.
 This does not happen everytime, but after max. 4-5 Hyperlink-Inserts it comes for sure!
 It is a sudden crash, LibreOffice simply "dissapears", it closes suddenly without any message.
Comment 1 Jorendc 2013-12-07 13:10:26 UTC
@Julien: you mind to have a look at this backtrace?

/me isn't sure it succeeded.

Thanks in advance for your time,
Joren
Comment 2 Julien Nabet 2013-12-07 13:19:32 UTC
gallus: you can try this:
- open 2 terminal (let's call them term1 and term2)
- in term1, open your file in Calc
- in term2, type this:
   - type this "LOPID=$(pidof soffice.bin)" (without the quotes)
   - type this "gdb soffice.bin $LOPID" (without the quotes)
   - type "c" (idem)

then reproduce the crash
at the moment of the crash, it'll seem to freeze, go to term2
and then type "bt"
Comment 3 gallusgyorgyulus 2013-12-07 14:36:13 UTC
Julien: I did what you said, but you must understand I'm new to linux so I didn't get far. I understand that was a debugging what I did, and at the end I got on my second terminal the following: "---Type <return> to continue, or q <return> to quit---" - What should I do now?

 I saved the output from terminal 2 in a text file, but didn't see here how to attach it to my comment.
 On terminal 1 I got "QWidget::repaint: Recursive repaint detected
"
Comment 4 Julien Nabet 2013-12-07 14:41:04 UTC
To attach the file, use this link:
https://bugs.freedesktop.org/attachment.cgi?bugid=72429&action=enter

Once you retrieved the backtrace, you can type "q"

It could be a dup of fdo#69002 since you can see:
QWidget::repaint: Recursive repaint detected
Comment 5 gallusgyorgyulus 2013-12-07 14:45:03 UTC
Created attachment 90410 [details]
the output from term2

so, here's what happend in term2  :)
Comment 6 Julien Nabet 2013-12-07 15:03:56 UTC
Ok the bt begins here:
Program received signal SIGSEGV, Segmentation fault.
0x00007f10474eb830 in QTransform::type() const () from /usr/lib64/libQtGui.so.4
(gdb) bt
#0  0x00007f10474eb830 in QTransform::type() const () from /usr/lib64/libQtGui.so.4
#1  0x00007f1047506bc8 in ?? () from /usr/lib64/libQtGui.so.4
#2  0x00007f104750e5ae in ?? () from /usr/lib64/libQtGui.so.4
#3  0x00007f104749913e in QPainter::drawPixmap(QPointF const&, QPixmap const&) 

Could you attach the rest of the bt by doing "q" as indicated by this:
#12 0x00007f1048a1918a in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib64/libkdeui.so.5
---Type <return> to continue, or q <return> to quit---

type "q" until you don't have any lines anymore like
#<number> 0x000...
and we'll have the complete bt. (you can let aside what's above the line:
Program received signal SIGSEGV, Segmentation fault.

(put it at NEW since there's a bt)

Thorsten: do you confirm the dup with fdo#69002 put in See also? would it be ok to cherry-pick the fix to 4.1 branch?
Comment 7 gallusgyorgyulus 2013-12-07 15:22:04 UTC
Created attachment 90413 [details]
terminal output
Comment 8 gallusgyorgyulus 2013-12-07 15:24:07 UTC
So, in the meantime I've checked the #69002 and then done some file-openings from LibreOffice - the crash was there, so I think it's about the same bug
Comment 9 Julien Nabet 2013-12-07 15:49:17 UTC
Ok following what you indicated, I put this tracker as a dup.

*** This bug has been marked as a duplicate of bug 69002 ***