Download it now!
Bug 71667 - EDITING: Function wizard delete the outer functions in a formula while editing an inner one.
Summary: EDITING: Function wizard delete the outer functions in a formula while editin...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Eike Rathke
URL:
Whiteboard: target:4.3.0 target:4.2.0.1 target:4.1.4
Keywords: regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-11-16 03:04 UTC by m.a.riosv
Modified: 2013-12-08 16:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2013-11-16 03:04:39 UTC
Win7x64Ultimate
Version: 4.2.0.0.alpha0+ Build ID: df21d317dacc4533ac999f3c3088765393842676
TinderBox: Win-x86@42, Branch:master, Time: 2013-11-05_00:13:53

Create a formula in any cell:
=SUM(MAX(B2:C2))
Open the functions wizard.
Edit the range in MAX(), it is no need for modify it.
The SUM() function disappear.
Back doesn't not restore the initial formula.
Comment 1 sophie 2013-11-19 13:51:15 UTC
I do not reproduce if I use the shrink button to edit the range. I can reproduce if I click in the Formula area, only the Max function is retained and the Sum function is deleted.
Using Version: 4.2.0.0.alpha1+
Build ID: f99736820a23cb7e37139607713658dea1c69dd4
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2013-11-17_23:56:22
Tested also withVersion: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a and the Sum function is not deleted, so regression is confirmed as well.
Marked as New and change Plateform to all - Sophie
Comment 2 m.a.riosv 2013-11-24 21:19:49 UTC
Easy to understand the meaning of the status change.
I cannot believe 4.2 can be released with this bug.
Comment 3 Markus Mohrhard 2013-11-28 15:31:25 UTC
(In reply to comment #2)
> Easy to understand the meaning of the status change.
> I cannot believe 4.2 can be released with this bug.

Sorry that you can't believe it but we would release with this bug. It is not even under the top 10 calc bugs that would ship in 4-2.
Comment 4 m.a.riosv 2013-11-28 22:12:56 UTC
(In reply to comment #3)

First, change Severity and Priority without any explication, I think it is not usually the procedure here.

Second, I didn't ask for your help (remember, was your request don't do it).

Third, of course, we would release with this bug (a regression), if we do so, the problem is for the users. Alternatively, an option, is add to the help menu an entry about what are the not solved dangerous bugs.

Fourth, and the most important, thinking as user, any option for data loss/change, without notice, is beyond than a critical bug and a high risk in their work. This case can be one of the worse because can change results with an unknown formula modification and without any notice.

Fifth, IMMHO the first priority must be the user data safety and the trust on results.

Sixth, what are going to do in relation with the bug, of course, is your choice, I have nothing to say, but if you are going to try solve it, thanks in advance, if not, please why bother.

I would be happy to know where find the top 10 calc bugs, and how they are sorted.
Comment 5 Markus Mohrhard 2013-11-29 23:53:00 UTC
(In reply to comment #4)
> (In reply to comment #3)
> 
> First, change Severity and Priority without any explication, I think it is
> not usually the procedure here.
> 
> Second, I didn't ask for your help (remember, was your request don't do it).
> 
> Third, of course, we would release with this bug (a regression), if we do
> so, the problem is for the users. Alternatively, an option, is add to the
> help menu an entry about what are the not solved dangerous bugs.
> 
> Fourth, and the most important, thinking as user, any option for data
> loss/change, without notice, is beyond than a critical bug and a high risk
> in their work. This case can be one of the worse because can change results
> with an unknown formula modification and without any notice.
> 
> Fifth, IMMHO the first priority must be the user data safety and the trust
> on results.
> 
> Sixth, what are going to do in relation with the bug, of course, is your
> choice, I have nothing to say, but if you are going to try solve it, thanks
> in advance, if not, please why bother.
> 
> I would be happy to know where find the top 10 calc bugs, and how they are
> sorted.

If you feel so strong about this bug complain at the QA list about this evil Calc developer. If you don't want calc developers looking and changing your bug reports don't mark them as blocker. It is more or less expected that I look at these bugs but if you disagree or feel that I'm not fair to your bug reports ask one of the bugzilla admins if they can defend your point of view.
Comment 6 m.a.riosv 2013-11-30 01:24:55 UTC
(In reply to comment #5)

> If you feel so strong about this bug complain at the QA list
This is my choice, when, why and how.

> about this evil Calc developer.
Please don't place in my mouth what I have not said.

> If you don't want calc developers looking and changing your
> bug reports don't mark them as blocker.
Where is my head?, it's funny report for nothing.

> It is more or less expected that I look at these bugs
It is your choice, but agree.

> but if you disagree or feel that I'm not fair to your bug reports
What I disagree is **changing the importance without any explanation**, please this is an open project, all can be and must be discussed.

> ask one of the bugzilla admins if they can defend your point of view.
I know, because as you know, I did once, and don't expect you can recognize it, at the end it was a great help to get the right direction.

Once again I am interested to know where find the top 10 calc bugs, and how they are
sorted.

But if I can't understand you and you can't understand me, what we are doing?, I think both have more valuable things to do with our time.
Comment 7 Jean-Baptiste Faure 2013-12-04 15:06:16 UTC
Reproducible for me with version 4.1.5.0.0+ under Ubuntu 13.10 x86-64

I agree with the importance as set by Markus because there is a workaround (it is easy to do the same thing without using the functions wizard) and there is no data loss (the change in the formula can't been not seen).

That said, it is clear for me that this bug should be in the MAB list.

Best regards. JBF
Comment 8 m.a.riosv 2013-12-04 16:32:58 UTC
And how the users know they can not use the wizard?, we are to disable it while waiting for a bug fix?
Comment 9 Jean-Baptiste Faure 2013-12-04 18:38:20 UTC
(In reply to comment #8)
> And how the users know they can not use the wizard?, we are to disable it
> while waiting for a bug fix?

When you encounter the bug in the functions wizard, you see immediately that something goes wrong and you can abort the current operation and then do the same thing without the wizard. Of course it is not optimal, but it is not blocking.

Best regards. JBF
Comment 10 m.a.riosv 2013-12-04 21:27:37 UTC
Ok Jean, thanks, I prefer forget this issue.
Comment 11 Eike Rathke 2013-12-04 21:33:03 UTC
May be related to bug 72278.
Comment 12 Commit Notification 2013-12-05 01:06:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dfd1a47a38dac743f9ed0f1e9507714bac027d35

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2013-12-05 01:16:29 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4bea81272d502c044febc419a16c86bbdadf5513&h=libreoffice-4-2

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 m.a.riosv 2013-12-05 01:27:38 UTC
Thanks Eike.
Comment 15 Eike Rathke 2013-12-05 01:39:56 UTC
Pending review
for 4-1 at https://gerrit.libreoffice.org/6935
for 4-1-4 at https://gerrit.libreoffice.org/6936
Comment 16 Jean-Baptiste Faure 2013-12-05 08:02:25 UTC
Hi Eike,
Thank you very much for the quick fix. It works as expected in version 4.2.0.0.beta2+ (Build ID: c0b0d3abf4919b9375fb8d73dfc7340b40c193b0).

Best regards. JBF
Comment 17 Commit Notification 2013-12-05 09:27:01 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22ff85716967e573ec3bfdb8c9b17cab7b30d8a4&h=libreoffice-4-1

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix


It will be available in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2013-12-06 00:37:59 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff927df4929022656668e4e98511c198134247cc&h=libreoffice-4-1-4

resolved fdo#71667 and fdo#72278, fdo#69971 follow-up fix


It will be available already in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 m.a.riosv 2013-12-07 02:42:40 UTC
Thanks Eike, by fix it so quickly. I hate invisible bugs, so really nice seeing this fixed. 
Works fine with:
Version: 4.2.0.0.beta2+ Build ID: 039dadf3b48484ba5d1fc71de5561288e6b7c5cb
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2013-12-06_22:54:58
Comment 20 m.a.riosv 2013-12-08 16:33:24 UTC
Works fine also in:
Version: 4.1.5.0.0+ Build ID: cb4225144f1fff44f9bb972fe06f51524da11b8
Version: 4.3.0.0.alpha0+ Build ID: c6fe5c6f371328cb6cf61d68f016a04f8b635a48
TinderBox: Win-x86@39, Branch:master, Time: 2013-12-08_02:58:23