Bug Hunting Session
Bug 71779 - [request] [CALC] Suggest and autocomplete functions while typing in formula bar
Summary: [request] [CALC] Suggest and autocomplete functions while typing in formula bar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 71778 (view as bug list)
Depends on:
Blocks: AutoCorrect-Complete Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2013-11-19 10:10 UTC by Dotan Cohen
Modified: 2017-06-20 22:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2013-11-19 10:10:29 UTC
In Windows, LO Calc presents only a single function suggestion when starting a cell with the `=` character. When the user types “=co” Calc shows only COUNTIF(). I tried using the arrow keys, tab, and other ideas to coax other function suggestions out of it (such as CONCATENATE) but I could not get LO to show the other possible completions. The user expects that Calc will show a complete list of available functions matching the text, and that the user could select one with the arrow keys.

Tested on Windows 8 with LibreOffice 4.1.
Comment 1 Ady 2013-11-19 10:35:07 UTC
Currently in LibreOffice Calc 4.1.3.2 there is no autocomplete / suggest / predict functions. The reason you might see COUNTIF suggested is because you already used such function and it is listed in the "Last used" functions category. To see those "last used functions", you could open the function wizard and select the first "last used functions" category.

This could be an enhancement request, but not a bug.
Comment 2 Ady 2013-11-20 13:27:22 UTC
Changing summary description to reflect feature request.
Comment 3 Maxim Monastirsky 2013-11-20 13:29:32 UTC
And marking as 'NEW'.
Comment 4 Ady 2013-11-20 13:30:02 UTC
*** Bug 71778 has been marked as a duplicate of this bug. ***
Comment 5 Eike Rathke 2017-06-20 22:31:51 UTC
Meanwhile implemented with a tooltip presenting a collection of functions that can be travelled using Ctrl+Tab