Bug 71956 - Other: The ability to set a different color for diacritics is missing for Arabic
Summary: Other: The ability to set a different color for diacritics is missing for Arabic
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Jonathan Clark
URL:
Whiteboard: BSA target:24.8.0
Keywords:
: 129330 (view as bug list)
Depends on: 61444
Blocks: Font-Rendering RTL-Arabic-and-Farsi
  Show dependency treegraph
 
Reported: 2013-11-24 05:40 UTC by Munzir Taha
Modified: 2024-05-22 18:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
a picture with Allah's name and a red colored fatha (53.11 KB, image/png)
2020-01-22 06:17 UTC, Safeer Pasha
Details
a file with colored fatha in arabic that shows that the problem is solved (8.04 KB, application/vnd.oasis.opendocument.text)
2020-01-25 14:36 UTC, Safeer Pasha
Details
Screenshot illustrating rendering fix (12.91 KB, image/png)
2024-05-22 17:32 UTC, Jonathan Clark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2013-11-24 05:40:02 UTC
Problem description:
Currently, I see no way to set the color of diacritics. In Arabic diacritics are separate glyphs and should be treated as such in the sense that one can select them and apply any formatting to them.

Steps to reproduce:
Type two Arabic glyphs e.g:
ضَ
Current behavior:
Cannot change the color of the second glyph

Expected behavior:
Should be able to set the color for each glyph separately.

Operating System: Linux (Other)
Version: unspecified
Comment 1 Munzir Taha 2013-11-24 20:23:46 UTC
I want to be able to type this word in libreoffice
https://en.wikipedia.org/wiki/File:Arabic_components_(letters)_in_the_word_Allah.svg
Comment 2 Safeer Pasha 2020-01-22 06:17:52 UTC
Created attachment 157311 [details]
a picture with Allah's name and a red colored fatha
Comment 3 ⁨خالد حسني⁩ 2020-01-23 05:36:53 UTC
How was that image created? Please also attach the ODT file. This issue is not fixed.
Comment 4 Safeer Pasha 2020-01-25 14:36:54 UTC
Created attachment 157422 [details]
a file with colored fatha in arabic that shows that the problem is solved
Comment 5 ⁨خالد حسني⁩ 2020-01-30 05:58:41 UTC
This is not really fixed, the mark position is incorrect and depending on the font can be greatly misplaced. For this to be really fixed, the mark position should be the same with and without colors in any font.
Comment 6 Munzir Taha 2020-05-08 03:20:45 UTC
I am not sure how you selected the diacritic and changed its color. Why didn't you make the whole word as the one I referred to? If you have typed it separately and then moved it to that location, that won't count of course. There should be an easy way to select the diacritic.

For the implementation to be complete, there should also be a way to find and change the Arabic diacritic color. An example of an app that already implemented this so you understand the issue better is:

https://helpx.adobe.com/indesign/using/arabic-hebrew.html#id_26234
Comment 7 Heiko Tietze 2020-05-08 05:56:00 UTC
*** Bug 129330 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Clark 2024-05-22 17:32:37 UTC
Created attachment 194281 [details]
Screenshot illustrating rendering fix
Comment 9 Jonathan Clark 2024-05-22 17:36:57 UTC
As of the fixes for bug 61444 and bug 124116, Writer should now correctly render diacritics with different colors (subject to those diacritics having separate glyphs in the font).

However, it is not yet possible to select the diacritics and apply colors to them in the user interface.

I've attached a screenshot illustrating this rendering change, using a hand-crafted fodt file.
Comment 10 Heiko Tietze 2024-05-22 17:53:22 UTC
(In reply to Jonathan Clark from comment #9)
> However, it is not yet possible to select the diacritics and apply colors to
> them in the user interface.
Don't think that's needed. If there would be a use case, I could imagine some decomposition mode similar to field Field Names where the individual glyphs are separated could do the trick UI-wise. My take: FIXED.

Awesome work!
Comment 11 Jonathan Clark 2024-05-22 18:33:06 UTC
(In reply to Heiko Tietze from comment #10)
> Don't think that's needed. If there would be a use case, I could imagine
> some decomposition mode similar to field Field Names where the individual
> glyphs are separated could do the trick UI-wise. My take: FIXED.

This sounds reasonable to me, so I will mark it fixed.


This bug was fixed as part of the fix for bug 124116, in the following commit:

https://git.libreoffice.org/core/commit/ab0a4543cab77ae0c7c0a79feb8aebab71163dd7

tdf#124116 Correct Writer text shaping across formatting changes

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.